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Ashlar-Vellum Modeling Products
Ashlar extends the Vellum family of products with the introduction of Argon, Xenon 
and Cobalt.  The three products were created specifically for designers who need to 
generate or manipulate precise 3D models.  Argon provides the base foundation of 
the modelers whereas Xenon and Cobalt add functionality that greatly enhances 
productivity for certain design processes.  The differences in Argon, Xenon, and 
Cobalt were developed to provide value and choice for consumer and product 
designers who frequently have diverse design tool requirements due to their unique 
environments.

Argon  
Argon provides the core foundation for all modeling products.  Based upon the 
ACIS geometry engine, Argon integrates precise curve, surface, and solid modeling 
design methods through the easy to use Vellum interface.  Designers can use curves 
to create surfaces/solids, surfaces to create solids, and then choose from one of the 
many feature operations such as shelling and blending to further refine their design.   

Not only does Argon provide a wide variety of modeling tools, but Argon provides 
means to precisely share data with other CAD/CAM/CAE packages through DXF/
DWG STEP, IGES, PRO/E, Parasolids (UG, SolidEdge, SolidWorks), and ACIS 
(AutoCAD, Inventor, Mechanical DeskTop) translators.

Xenon 
Xenon adds additional functionality to the Argon core package by enabling associa-
tivity between the design data.  Associativity is a transparent relationship created 
between the original geometry and the resulting shape.  These relationships are 
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stored in a history tree such that any modifications to the original shape can be 
replayed to update the design.  You can view the history tree for curves, surfaces 
and solids using Design Explorer.  Associativity is a critical component for rapidly 
exploring design concepts and iterations through modifications.  

The following scenario is an example of how associativity can enhance a designer's 
productivity.

1. Designer creates a collection of curves defining an organic shape in space.

2. Surfaces are added to the curves.

3. Surfaces are trimmed to other surfaces or relimited as needed.

4. Surfaces are stitched into a watertight body represented as a solid.

5. Body is shelled and faces drafted for manufacturing demands.

6. Body edges are smoothed with any of the seventeen blend or chamfer tools.

7. A 2D drawing is generated consisting of side, front, top and isometric views.

8. Design requires modifications on the original curves.

9. Curves are modified and steps 2 -7 automatically update through associativity.

Cobalt v5
Cobalt is the next generation of Ashlar's Vellum Solids modeling program. Cobalt 
adds more drawing composition, assembly modeling, bill of materials, and GD&T 
tools relative to Xenon.  Cobalt is the package of choice for creating industry stan-
dard drawings.

Another major feature of Cobalt is that it provides an equation-driven parametric 
constraint management system.  Using constraints, the designer can over, under or 
fully constrain profiles to move in relations relative to other curves and/or dimen-
sion values.  One of the more exciting features using the constraint system is to ani-
mate dimension values by providing minimum/maximum ranges and the number of 
steps to evaluate.  Below is a collection of dimension and geometry constraints sup-
ported by Cobalt v5.

• Horizontal, vertical to reference system

• Coincident, colinear, parallel, concentric

• Tangent, symmetric, perpendicular, offset, equal lengths

• Horizontal, vertical, parallel, radial, and diameter distance constraints
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Documentation
Most of the graphics in this manual apply to both Macintosh and Windows operat-
ing systems. For those instances requiring a platform specific reference, a Windows 
graphic is used.

Installing Ashlar-Vellum 3D Modeling Products
You can find instructions for quick and easy installation on the CD-ROM that is 
included with your product or, if you downloaded an Ashlar-Vellum Modeling prod-
uct from our web site, running the installer will place an informational Read Me on 
your hard drive. 

Serial Number/Registration Code
Your serial number and registration code are required to operate the software; the 
serial number and registration code are located inside the CD package.  If the regis-
tration code is not there please call 800-966-2349 to request it.  If you purchased 
through our website they were sent to you via email.

Enter your name and company name to personalize your copy of the software.  If 
you choose not to register your copy, your Ashlar-Vellum Modeling product will run 
in demonstration mode for fourteen (14) days. For information regarding the pur-
chase of Ashlar-Vellum products in the US call 1.800.877.2745.

It is important to register your Ashlar-Vellum Modeling product so we can provide 
you with the best possible service. Registered users of our software are eligible for 
free technical support (for thirty [30] days after receipt of Registration code), infor-
mation regarding new versions and products, discounts and special offers on new 
products.

System Requirements

Windows

Minimum Requirements
• Windows 98

• Pentium II

• Video Card
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• 256 MB RAM

• 150 MB Free hard drive space

• CD-ROM

Macintosh
• OS 8.6

• G3 Native

• Video Card w/ OpenGl

• 256 MB RAM

• 512 MB Allocated virtual memory

• 150 MB Free hard drive space

• CD-ROM

Recommended Requirements

Windows
• Windows NT/2000

• Pentium 4 or AMD Athlon

• 32 MB Accelerated Video Card w/ OpenGL

• 512 MB RAM

• 250 MB Free hard drive space

• CD-ROM

Macintosh
• OS 9.1

• G4

• 32 MB Accelerated Video Card w/ Open GL

• 512 MB RAM

• 1 GB Allocated virtual memory

• 250 MB Free hard drive space
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• CD-ROM

Tutorial Introduction
This tutorial is a learning, productivity and reference tool that will introduce you to 
some of the most commonly used features and functions in the Ashlar-Vellum mod-
eling products: Cobalt, Xenon and Argon. You’ll also be introduced to our world 
renowned Drafting Assistant that anticipates your next design action, making 
Ashlar-Vellum software work the way you think. You’ll discover how easily you can 
go from 2D design to 3D with the Drafting Assistant and create your own designs.

The exercises are organized into chapters beginning with an introduction of Ashlar-
Vellum’s integrated design environment and continuing with the creation and modi-
fication of an inline skate chassis.  

The majority of the exercises in this tutorial apply to all three products.  However, 
both Xenon and Cobalt feature intelligent history-based associativity that speeds the 
design revision process and aids in design management.  The design modification 
exercise featuring the Design Explorer applies only to Cobalt and Xenon.  Although 
Cobalt includes additional features not available in Xenon or Argon, the exercises in 
this tutorial do not address these features.

By the end of this tutorial, we hope you will have obtained enough familiarity with 
the model creation tools to create your own parts and explore features and tools 
not covered in these exercises.

Menus and Submenus

Choosing Commands
As you proceed through the exercises, you will be directed to choose commands 
contained in submenus of other menus, like the pull down menu. For example, you 
might be asked to set a color by going to the Color submenu of the Pen menu. That 
will be shown as Pen>Color.

Margin Notes
Margin notes provide alternative ways of doing a procedure or may refer to another 
section or chapter for related information. There are three types of margin notes: 
Tip, Tech Note and Referral. These notes are given special treatment so that you 
can instantly recognize their significance and locate them for future reference.
1-5



 

Tutorial Introduction

1-6

                                        
Tip
A tip provides instructions for getting the most out of Ashlar’s 3D modeling prod-
ucts. Tips may show you how to speed up an operation or perform some timesav-
ing drawing technique.

Tech Note
A technical note provides additional technical information that may help you when 
using a tool or an alternative way of doing a procedure in an exercise.

Referral
A referral directs you to related information contained elsewhere in the manual for 
the particular topic being addressed.

Style Conventions
This manual uses various style conventions which highlight certain terms or 
phrases. The list below includes an explanation and an example in parentheses. 
The conventions are as follows:

Bold Tool palette names (Light palette); tool names 
(Single Line tool); Keyboard-entered text; Defini-
tion terms (as shown in these style conventions)

Italic Terms used for the first time in a chapter; Drafting 
Assistant notations (midpoint); tool and dialog box 
options (Angle data field); section references (User 
Guide); Message Line directions (Single Line: Pick 
the beginning point.); margin note headings (Tip); 
menu commands (Zoom Previous); filenames 
(prefs.ini); stand alone extensions (.dwg); directory 
names; drawing names

Bold and Italic Command series (Layout>Preferences>Snap)

ALL CAPITALS Key names on the keyboard (ENTER, RETURN)

Title Capitalization Dialog box names (Edit Objects); menu names 
(Pen menu); special Vellum phrases (the Drafting 
Assistant)

all lower case File names (prefs.ini); stand-alone file extensions 
(.dwg)
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Step Conventions
The numbered tasks in the exercises describe the activity you are to perform, and 
the bulleted steps beneath the numbers tell you how to accomplish the task. If you 
already know how to accomplish the task, you should do it without following the 
bulleted directions, then proceed to the next numbered task.

Exploring
Some users like to go off on their own to explore while going through the exercises 
of a tutorial. This is an excellent way to learn more about Ashlar’s 3D modeling 
products. If you are adventuresome, open a new document for your explorations 
and then switch back to the tutorial document when you want to continue with the 
exercises.

Occasionally, the tutorial may verify a position or entry that seems obvious to you. 
If the condition is vital to the next step and you might have inadvertently deviated 
from the tutorial path, verification (for example, “the x,y location is 0,0”) has been 
added to ensure that you get the correct result from the exercise.

There’s More than One Way
Ashlar-Vellum Modeling products often provide more than one way to perform a 
task. This tutorial describes only one method at a time and may show you a differ-
ent way to do the same task later. When you start to develop a preference, feel free 
to substitute your own method for whatever is suggested here, provided you're cer-
tain that your method produces the same outcome as the tutorial.

Basic Terminology
This manual uses the following terms for mouse activities:

Pointer An arrow or any other graphic symbol that allows 
selection or creation of an object. Move the pointer 
to point to a command or an object on the screen. 
Depending on its location, the pointer is an arrow 
or may look like the current tool.

  

To move the pointer, move the mouse on the 
mouse pad.

Arrow Pointer Selection Arrow Center-Point Circle
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Point Move the mouse until the pointer is over the item 
you want.

Press Press and hold down the mouse button.

Click Quickly press and release the mouse button once.

Double-click Click the mouse button twice, quickly in succes-
sion.

Drag Press and hold down the mouse button, move the 
mouse, then release the mouse button.



     
3D Modeling Environment
Ashlar-Vellum’s 3D design environment was developed to allow you to focus on the 
part you are designing rather than on the software. In this chapter you’ll do the fol-
lowing:

• Familiarize yourself the user interface

• Explore the Drafting Assistant

• Save preferences

• Select objects

• Be introduced to drawing techniques

Exercise 1: Ashlar-Vellum’s User Interface
This exercise introduces you to the user interface.

1. Launch one of our 3D modeling products (Cobalt, Xenon or Argon).

Our Modeling product opens, displaying an untitled document with an empty 
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drawing area.

2. Take a look at the menu bar. There are twelve menus.

File Contains commands that affect entire documents 
(files), including opening and closing files, setting 
preferences and defining your Print Setup (Win-
dows) or Page Setup (Macintosh).

Edit Contains commands to select and manipulate 
objects. These include such things as copying and 
pasting as well as changing an object’s direction, 
resolution, layer and type.

Layout Contains commands and settings that specify the 
drawing area and provide program features and 
functionality such as the Grid, Layer Manager, 
Group and Align.

View Contains commands for displaying your document 
and includes choosing and setting views and zoom 
options.
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Planes Contains commands for choosing and defining the 
work plane.

Pen Contains commands to specify pen characteristics 
(color, weight, and pattern), polygon patterns, 
polygon fill, crosshatching and arrows.

Text Contains commands to set the font, size, style and 
case of your text (lower, upper and title capitals).

Dimension Contains commands that specify dimensions, their 
format and tolerance.

Verify Contains commands to obtain information about 
your file and specific objects in your file. These 
include properties of an object, direction, curva-
ture and object counts.

Window Contains commands for displaying tool palettes, 
the Design Explorer, Trackball and Showing or 
Hiding objects.

PhotoRender Contains commands for rendering your geometry 
and setting options for rendering.

Animation Contains commands for generating Quicktime mov-
ies.

Help Contains the commands to access the on-line help 
file.
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3. Take a look more closely at the main tool palette.

4. This tool palette contains drawing and editing tools used for constructing, edit-
ing and annotating geometry as you develop parts and assemblies. Most of 
these tools in the palette have subpalettes containing tools with related func-
tions. The arrow in the lower right corner of the tool icon represents the pres-
ence of a subpalette.

Selection tool Select object(s) and points in the drawing area.

Line tools Create line segments, connected lines, line parallel 
to existing lines and points. As you create a line, 
the coordinate locations, line length and angle 
from horizontal appear in the Status Line.

Arc tools Create arcs with center, beginning and end points.
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Circle tools Create circles with a center point and diameter.

Ellipse/Conic tools Create ellipses with a center, major axis point and 
minor axis point or conic curves defined by a start 
point, end point, shoulder and slope control 
points.

Polygon tools Create rectangles, inscribed polygons, circum-
scribed polygons, arbitrary polygons and polygons 
from curves.

Spline tools Create smooth, free-form curves passing through 
specified points - NURBS (Non-Uniform Rational 
B-Splines). NURB splines don’t develop kinks as a 
spline is altered and you can make changes to a 
specific area without affecting the remainder of the 
spline. This palette also includes the Helix Curve 
tool.

Text tools Create text for annotating designs in the drawing 
area. You can set the text characteristics, such as 
font, text size and case. The Text tools in our 3D 
modeling products do not use text boxes but text 
objects that can be moved independently.
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Dimension tools The Dimension tool palette has been added to the 
main tool palette for easy access.

Fillet/Chamfer tools Construct fillets and chamfers from corners formed 
by nonparallel lines or curves. Our 3D modeling 
products automatically trim fillets and chamfers by 
default but you can override this to prevent trim-
ming.

Trim tools Lengthen or shorten lines and curves. Generally, 
you select the limiting object(s) before you select a 
specific trim tool.

Curve Extras tools Contains tools for offsetting, extruding, revolving, 
exploding (creating) curves from edges and pro-
jecting curves.

Transformation tools Contains tools and commands for transforming 
geometry with respect to scale, location and the 
like. These Transformation tools include: Move, 
Rotate, Expand/Shrink and Mirror.

5. Select the Opposite-Point Circle tool, the first tool in the Circle tools subpal-
ette.

When you select a tool and move the pointer 
into the drawing area, the pointer becomes a 
smart pointer representing the tool and display-
ing indicators for multi-step procedures.
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On one side of the smart pointer is a dot, the hot spot, showing the point 
you should specify. This dot indicates that the first click of the mouse 
places a point on one edge of a circle being created. The dot changes 
position on the pointer during each step of construction.

6. Take a look at the Message Line at the top of your drawing area.

The Message Line provides instructions for using the current tool. Since the 
Opposite-Point Circle tool is selected, the Message Line reads, Opposite-Point 
Circle: Pick first point on circle [Ctrl = Copy Previous (Windows) or Option = 
Copy Previous (Macintosh)].

Notice that the Message Line tells you not only the step for using the tool but 
notifies you of an additional option. These options are available for a number 
of tools in our 3D modeling products.

7. Click the first point of the circle. The hot spot on the smart pointer moves to the 
other side of the circle pointer icon.

The Message Line now reads, Opposite-Point Circle: Pick opposite point on circle

8. Move the smart pointer. As you do so, a rubberband image appears. (The 
smaller circle, in the graphic here, is the smart pointer for the Opposite-Point 
Circle tool.)

9. Click to indicate the second point of the circle.

The circle appears and the hot spot on the smart pointer returns to its original 
position for creating another circle.

10. Take a look at the Status Line at the bottom of the drawing area.

When you select a tool, the Status Line contains data fields that provide infor-
mation about the geometry being created, such as measurements, angles, coor-
dinates and the like.

You can use the Status Line in three ways: to create an object with keyboard 
entries, to edit an object that was just created and is still selected, and to create 
additional wireframe objects using the current tool.
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Tech Note:

You can set the angle incre-
ment for the Step Trackball 
using the View Rotation 
Options dialog box. See 
Chapter 7 of the User Guide 
section for information.
11. Notice that the X data field is highlighted. Whenever you construct an object, 
the data field that you are most likely to change is active.

12. Choose Window>Trackball.

The Trackball displays.

The trackball lets you rotate the view orientation of your geometry in the draw-
ing area. This Sphere Trackball allows you to drag your view to the desired 
rotation.

13. Click the arrow button on the right side of the Trackball title bar.

The Trackball changes to the Step Trackball.

This trackball gives you the ability to rotate your views in regular angle incre-
ments or in a continuous movement. By clicking an arrow, your drawing rotates 
5° in the direction selected.

14. Click the arrow button on the Trackball title bar again to return to the Sphere 
Trackball.
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Exercise 2: Exploring the Drafting Assistant™
The Drafting Assistant™ is the feature that separates our 3D modeling products 
from other design and drafting software. The Drafting Assistant™ thinks like a 
designer. It automatically knows where you typically want construction lines and 
displays them temporarily when you need them.

The Drafting Assistant™ also makes it easy to select existing points for construction 
by displaying information about the pointer’s location in the drawing area. If a 
Drafting Assistant™ notation displays when you click, the construction snaps onto 
the geometry being created.

When the pointer is in the drawing area, the Drafting Assistant™ locks onto specific 
points on existing objects as you move the pointer near them.

1. Create a circle using the Opposite-Point Circle tool. The circle size does not 
matter.

2. Select the Single Line tool, the second tool from the top in the main tool pal-
ette.

The pointer becomes a crosshair.

3. Move the pointer across around the edge of the circle. Click the first point when 
an on notation appears and the first point of the line is on the circle.
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4. Move along the circle in a 45° angle and notice that a Drafting Assistant™ con-
struction line appears.

The Drafting Assistant™ also tells you when the snap point has locked onto the 
following points of an object.

center

The center of an arc or circle. Move the pointer 
across the arc or circle to display on for the arc 
or circle, then move the pointer near the center to 
display the center point notation.

endpoint

The endpoint of lines, arcs, circles, ellipses 
and splines. 

midpoint

The midpoint of lines, arcs, circles, ellipses 
and splines.

intersection

The intersection of two curves (permanent and the 
Drafting Assistant’s dynamic construction lines).

quadrant

center

endpoint

midpoint

intersection

quadrant



Exercise 2: Exploring the Drafting Assistant™
Quadrant points on an arc or circle displayed at 
3 o’clock, 6 o’clock, 9 o’clock and 12 o’clock. 

vertex

The vertices of an ellipse, spline, or dimension 
point.

Tangent

Tangent points of an arc or circle. If you click a 
point on an arc or circle and drag the pointer away 
at about a 45° angle, the Drafting Assistant locks 
onto a tangent.

Perpendicular

Perpendicular points off any curve. If you click a 
point on a curve and drag away at a 90° angle the 
Drafting Assistant locks onto a perpendicular.

The Drafting Assistant™ also displays the three types of dynamic construction 
lines you’ll most likely use during geometry construction. These appear tempo-
rarily to help you align geometry along the X-axis, Y-axis and 45° angle (if in 
the Top plane).

5. Click to place the final point.

Once you’ve set a point, the Drafting Assistant™ construction line disappears. 
Your drawing is not cluttered with unnecessary, extraneous lines.

6. Double-click on the Selection tool, the first tool in the main tool palette, to 
select all geometry.

7. Press BACKSPACE (Windows) or DELETE (Macintosh) to delete all geometry 
from the drawing.

vertex

tangent

perpendicular
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8. Select the Single Line tool again.

9. Click somewhere in your drawing to set the first point.

As you move the pointer, a dynamic construction line extends automatically 
from the last point you created.

10. Move the pointer along the temporary horizontal construction line and click to 
place the second point of the line. The exact distance does not matter for this 
segment length or any of the segments created in the rest of this exercise. Just 
approximate the line length using the graphics as a reference.

You’ve completed the first line segment.

11. Move the pointer over the left endpoint of the line segment.

When you perform this kind of action over one or more points, you activate 
them. The Drafting Assistant™ automatically displays construction lines relative 
to them.

12. Click on the endpoint to place the first point of another segment.

13. Move the pointer vertically up from that point.
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14. Click to place the endpoint of this new line segment.

15. Select the Connected Lines tool.

• Place the pointer over the Single Line tool and press the mouse button to 
display the Line tools subpalette.

• Drag to the Connected Lines tool and release the mouse button. The Con-
nected Lines tool now displays selected in the palette.

This tool creates connected lines segments rather than single line segments cre-
ated with the Single Line tool.

16. Move the pointer to the right endpoint of the horizontal line to activate that 
control point and then move the pointer in a 45° direction.
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A 45° dynamic construction line appears.

17. Click on a point along the 45° construction line to place the next point.



Exercise 2: Exploring the Drafting Assistant™
18. Now move the pointer away from the point horizontally so that a construction 
line appears aligned along the X-axis. Don’t worry if the pointer isn’t exactly on 
the displayed construction line as long as the align x and on notations display.

19. Click the next point somewhere to the right of the last point.

Notice that the point is placed on the construction line even though the pointer 
wasn’t exactly on that line when you clicked the mouse.
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20. Move the pointer vertically up from the point and a vertical dynamic construc-
tion line displays through that last point.

21. Continue moving the pointer so that it is aligned with the top endpoint of the 
vertical line segment and the last point placed. Two construction lines will dis-
play, as shown here.

These construction lines are Drafting Assistant’s attempt to anticipate your next 
action by displaying a possible location for the endpoint. The Drafting Assis-
tant™ displays intersect, align x and align y notations.
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22. Double-click to place the last point along that construction line, as indicated in 
the Message Line.

23. Save (or discard) this file if you wish.

• Choose File>Save.

• Type the desired file name.

• Click OK.

This exercise was a very simple example of the power of the Drafting Assistant™. 
The Drafting Assistant™ will help you with more complex drawings, including 3D, 
as you’ll discover in the next three chapters.

Exercise 3: Saving Preferences
Our 3D modeling products allow you to save preferences for a particular session 
and in the style in which you work.

1. Choose File>New to display an untitled drawing.

2. Choose File>Preferences.

The Preferences dialog box contains a category list of preference groups, group 
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settings and dialog box buttons.

The preference categories include Colors, Display, Drafting Assistant, Filing, 
General, Grid, Select and Units.

3. Choose the Display category.

4. From the Object Type section choose Surface.

For surface and solid object types you have the ability to set, Resolution, Iso 
Lines, Silhouette and Edge Color.

Resolution Controls how accurately an object’s curves appear. 
You can set the curve resolution to Coarse, 
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Medium, Fine, Very Fine and Super Fine. An object 
with a Coarse resolution draws more quickly but 
may be less appealing visually than an object with 
a Super Fine resolution.

Iso Lines Iso (isopram) lines control the number of U and V 
lines displayed for a surface or solid object. Iso 
lines are constant parameter curves that lie on an 
object. U and V are the letters used to define these 
lines (and their coordinates) in parameter space 
and are standard for the industry. A zero in both 
fields turns off iso lines. U/V values may enhance 
the visual appearance of a surface or solid at the 
expense of drawing speed.

The graphic below shows a surface with both the 
U and V iso lines set to five.

Silhouette Controls the silhouette edge draw mode. A silhou-
ette is a set of edges that separates visible faces 
from invisible faces of an object with respect to a 
given viewing direction. For example, a sphere has 
no real edges. The silhouette feature reads the 
sphere and displays a circle.

There are three options, Off, On and Smart. Silhou-
ette edges are view dependent and can cause a 
significant reduction in drawing speed. If the Smart 
mode is selected, silhouettes will be dynamically 
drawn based on performance considerations.

Edge Color Controls the edge color of rendered objects sepa-
rate from the entity itself. The pull-down menu 
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provides four options, Foreground, Background, 
Entity and User-Defined. To specify a user-defined 
color, click on New, choose a color in the palette 
and click OK. The new color displays in the Edge 
Color window with its color values.

5. Explore the various categories and settings available. See the User Guide section 
for information on each of these settings.

When you change any of the preference settings, the changes apply only to new 
objects.

Exercise 4: Selecting Objects
Once you create an object, you will undoubtedly want to make changes. In order to 
do so, you first have to select the object. In our 3D modeling products, the step at 
which you select the object depends on which operation you want to perform. 
When you select an object it highlights until you select another object or deselect it 
by clicking in the drawing area. You can select an object with the Selection tool or 
by the hollow selection tool that appears temporarily when using one of the Edit-
ing tools. Selecting an object does not affect the properties of the object. You can 
select both objects and points.

Selecting an Object
1. Select the Center-Point Circle tool.

2. Create a circle of any size in your drawing area.
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3. Select the Single Line tool.

4. Create a line of any length.

5. Choose the Selection tool, the first tool in the main tool palette.

6. Place the pointer over the circle and click. 

The circle highlights red (the default selection color set in Preferences).

7. Click in the drawing area to deselect the circle.

Selecting and Modifying Object with an Editing Tool
When editing an object, you may be asked to select an object after selecting the 
tool.
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1. Select the Divide at Location tool. 

2. Move the pointer into the drawing area. The pointer has become a hollow 
selection tool.

3. Select the line.

The line highlights and you can now perform the next step with the tool.

4. Click on the line at some location.

The line divides at that location even though you can’t see it.

5. To verify the division, choose the Selection tool.



Exercise 4: Selecting Objects
6. Click on the line at some location and you will see that only a portion of the 
line highlights showing that the line has been divided.

Selecting an Object and Modifying it with a Command
You can also edit an object simply by changing one of its properties. Maybe you 
want to apply a center pattern to a circle to indicate a bolt-hole. You’ll need change 
the pen pattern.

1. Using the Selection tool, select the circle.

2. Choose Pen>Pattern>Center.
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The circle pen pattern changes to a center pattern display.

Exercise 5: Drawing Technique Options
In our 3D modeling products, all objects are created by clicking. As you create 
geometry a rubberband image of the geometry displays showing you how the 
object will appear when you click the last point. 

As mentioned previously, each dot on the icon represents a point you must place. 
The smart pointer indicates the order for designating points.

1. Select the 2-Point Center Ellipse tool.

2. Move the pointer to the drawing area and click to set the center point of the 
ellipse.

3. Move the pointer to the another location. (It doesn’t matter 
where.) As you do a rubberband image of the line appears.

If you keep moving the pointer, the rubberband images 
adjusts accordingly.

4. Click to set the corner point of the control rectangle of the ellipse, as indicated 
in the Message Line. 



Exercise 5: Drawing Technique Options
5. Notice that the X field in the Status Line at the bottom of the drawing area is 
highlighted.

This field represents the X location of the center point of the ellipse. Immedi-
ately after construction you can change the X location or any other value in the 
Status Line. If the geometry is not satisfactory, press BACKSPACE (Windows) or 
DELETE (Macintosh).

6. Use the TAB key to tab to the L1 data field.

7. Type 1.75.

8. Press TAB twice to highlight the L2 data field.

9. Type 1.0.

10. Press ENTER (Windows) or RETURN (Macintosh) and the ellipse updates.

Using the Status Line you can sketch out your drawing without having the exact val-
ues for geometry.

Congratulations! You have completed the introductory section of the our 3D model-
ing products tutorial. The next section will introduce you to wireframe modeling.
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Wireframe Modeling
Just as there are several ways of approaching a design problem, our 3D modeling 
products have different ways of modeling objects based on the software features 
you choose to use in the design environment.

In our 3D modeling products you can create wireframe, surface and solid models. 
This section of the tutorial introduces you to wireframe modeling, the most basic 
modeling type. A wireframe consists of geometry that makes up the edges of an 
object. Wireframe relates to the concept of a wire that is bent to follow an object’s 
edges. A wireframe model is the simplest mathematical representation of an object.

Wireframes in our 3D modeling products consists of points, lines, arcs, circles, 
ellipses, conics, splines or a combination of these. These same wireframes are also 
collectively referred to as curves. Although wireframes are limited in the amount of 
model content they represent, they are powerful building blocks for creating more 
complex surface and solid models.

A wireframe model can often be used in place of a physical prototype for running 
simulations. These digital models also can be used for visual inspection, measuring 
distances between points within the model and observing the visual and real inter-
section of lines.

In this chapter you’ll learn how to:

• Set up your file

• Create wheel axles

• Create the chassis profile
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Now let’s move on to creating a wireframe profile of the in-line skate chassis, as 
shown below.

Exercise 1: Setting Up the File
In this exercise you’re going to set some preferences for the file as well as the view 
scale to fit your geometry.

1. Choose File>New. An untitled file displays on your screen.

If Ashlar’s 3D modeling product is not already running, launch the program. An 
untitled file automatically displays. You do not have to open a new file.

2. Choose File>Preferences to open the Preferences dialog box.

3. Select the Units category and set the units to millimeters.

4. Click Apply to save the setting.



Exercise 1: Setting Up the File
5. Select the Display category.

You have three object types, Curve, Surface and Solid and five resolution settings, 
Coarse, Medium, Fine, Very Fine and Super Fine. You can set the resolution for 
each object type separately.

6. From the Object Type menu, choose Curve, if it is not already selected.

7. From the Resolution menu, choose Medium.

8. Set the resolution for the Surface and Solid object types to medium also.

9. Click Apply to save the setting

10. Click OK to close the dialog box.
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11. Choose Window>Trackball to display the Trackball, if it is not already dis-
played.

12. Click on the Trackball view menu.

13. Choose Front from the list.

The view changes to Front. Notice that the Triad in the upper left corner of your 
drawing area shows the Front plane graphically.

14. From the main tool palette, select the Rectangle tool.

The Message Line includes an additional palette with four types of rectangle tools. 
polygon by center and point on (Center/Corner Rectangle tool), polygon by 
diagonals (Diagonal Rectangle tool), polygon by center/axis (Center/Axis 
Rectangle tool) and polygon by major and minor axis (Major/Minor Axis Rect-
angle tool).



Exercise 1: Setting Up the File
15. Choose the Center/Corner Rectangle tool, the first tool in the subpalette.

16. Move the rectangle pointer to the origin of your drawing located at the intersec-
tion of the X, Y and Z axes.

Notice that the Message Line provides you instructions for using the tool.

17. Click at the origin to place the center point of the rectangle.

18. Move the pointer away from the origin and a rubberband image of the rectangle 
appears.
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19. Click anywhere to place the corner of the rectangle.

The W or width data field is highlighted in the Status Line below your drawing.

20. Type 400 in the data field.

21. Press TAB to activate the H or height data field.

22. Type 140 into that data field.

23. Press ENTER (Windows) or RETURN (Macintosh) and the rectangle resizes to 
these new values.

24. Choose View>Zoom All.



Exercise 2: Creating the Wheel Axles
Your view rescales to fit the rectangle.

25. Delete the rectangle.

• Using the Selection tool, drag a selection fence around the rectangle (hold 
down mouse and drag a selection fence rectangle around the two circles).

• Then press DELETE.

• Close the Trackball if it is taking up too much room in your drawing area.

You’ve now set up your file to begin creating the skate. The rectangle was tempo-
rarily created to set the viewing scale to your monitor’s screen size.

Exercise 2: Creating the Wheel Axles
In this exercise you’ll create the wireframe wheel axles using the Center-Point Cir-
cle tool, construction lines and the Linear Duplicate tool. You’ll start the design in 
2D and move on to 3D in the next chapter. You will also assume that the wheels are 
82 millimeters in diameter, standard for in-line skates. 
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1. Create two concentric circles with diameters of 8 mm and 25 mm to the left of 
the origin.

• From the main tool palette, select the Center-Point Circle tool.

• Move the pointer to the origin to wake up a temporary horizontal construc-
tion line.

• Now move the pointer to the left, along the construction line, as shown 
above.

• Near the left of your drawing area, click the center point of the circle.



Exercise 2: Creating the Wheel Axles
• Move the pointer a small distance away from the first point and click the sec-
ond point. The exact distance does not matter. 

As you move the pointer to place the second point, a rubberband image of 
the circle appears.

• In the highlighted D (diameter) field of the Status Line, type 8 and press 
ENTER (Windows) or RETURN (Macintosh).

This circle represents the first axle hole.

• Move the pointer to the center of the hole (the center notation should appear) 
and click to place the center point for the second circle.

• Move the pointer out some distance and click to place the second point. 
Again, the exact distance does not matter.

• Type 25 in the highlighted D (diameter) field and press ENTER (Windows) or 
RETURN (Macintosh). 

Another circle is created with the same center point and represents the wheel 
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material around the axle hole.

2. Select the two circles.

• Choose the Selection tool

• Drag a selection fence around the two circles.

The two circles are selected.

3. Create three copies of these two circles across your drawing area in the X direc-
tion with a step offset of 90 mm for the four circles.

• Select the Linear Duplicate tool from the Move tool palette.



Exercise 2: Creating the Wheel Axles
The Linear Duplicate dialog box appears.

• In the Number per row field of the Columns section, type 4.

• In the Offset X field, type 90.

• Select the Step offset option, if it is not already selected.

• In the Number of rows field of the Rows section, type 1.
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• Click OK to close the dialog box and create the duplicates. 

Three additional axles appear, lying along the same X axis as the original 
axle.

4. Save the file as Inline Skate Profile.

• Choose File>Save (CTRL+S, Windows or a+S, Macintosh).

• In the dialog box, type Inline Skate Profile.

• Click Save.

Exercise 3: Creating the Chassis Profile
In this exercise, you’ll create the chassis profile using construction lines, the Paral-
lel Line tool, 3-Pt Arc tool, the Mirror tool and the Single Line tool.

1. Create a horizontal stroke construction line through the origin.

• Hold down the SHIFT+CTRL keys (Windows) or the a key (Macintosh). The 
pointer becomes the stroke pointer (a).

• Place the stroke pointer over the origin and drag to the left. 

A horizontal construction is created which will serve as the base construction 
for the inline skate chassis layout.

2. Create a new horizontal construction line offset from the axle center, 15 mm 
above the first construction line. This line will be the actual layout line used for 
the remainder of these exercises.



Exercise 3: Creating the Chassis Profile
• In the Line tool palette, select the Parallel Line tool.

• Place the pointer, shown at the right, over the construction line and 
drag a new line up a short distance from the original line.

• In the Offset data field of the Status Line, type 15 and press ENTER (Win-
dows) or RETURN (Macintosh).

3. Create an arc, tangent to the left-most 25 mm circle, the upper construction line 
and the right-most 25 mm circle. This creates the shape for the bottom of the 
chassis.

• In the Arc tool palette, select the 3-Point Arc tool.

• Hold down the CTRL key (Windows) or the OPTION key (Macintosh).

• Click the left-most 25 mm circle, the upper construction line and the right-
most 25 mm circle.

By holding down the CTRL key (Windows) or OPTION key (Macintosh) you 
create an arc tangent to the circles and construction line.
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4. Create a new horizontal construction line offset from the axle centers, 40 mm 
above the first construction line. You’ll use this line as a reference for setting 
the height of the chassis.

• In the Line tool palette, select the Parallel Line tool.

Notice that you did not have to open the subpalette to select the tool. When 
you select a tool, it becomes the displayed tool in the palette.

• Place the pointer over the first construction line (through the center of the 
axle holes) and drag a new line up a short distance from the original line.

• In the Offset data field of the Status Line, type 40 and press ENTER (Win-
dows) or RETURN (Macintosh).

5. Draw a tangent line from the outer edge of the left-most 25 mm circle to the 
upper construction line at a 45° angle.

• Choose Layout>Construction to display the Construction Line dialog box. 

• Click on the Angle name to activate its data field.

• Type 45.



Exercise 3: Creating the Chassis Profile
• Click on the Offset name to activate its field.

• Move the pointer to the top quadrant of the left outer circle such that a quad-
rant notation appears.

Notice that the pointer has become a target cursor indicating that you can 
click in the drawing area and have the values entered automatically.

• Drag the pointer from this quadrant point to the center point of the circle. 
(12.50 should appear in the offset field).

• Click on the Location X name to activate its field.

• Click on the center of the circle.

• Click Apply in the dialog box and a construction line appears tangent to the 
outer circle and that intersects the upper construction line. 

• Click Cancel to close the Construction Line dialog box.
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• In the Line tool palette, select the Single Line tool.

• Move the pointer to the intersection of the outer circle and the 45° construc-
tion line such that an intersect notation appears. 

• Click to place the beginning point on the circle.

• Move the pointer to the intersection of the 45° construction line and the 
upper construction line such that an intersect notation appears. 

• Click to place the endpoint of the line at the noted intersection.

6. Using the arc’s middle quadrant point as a reference, mirror a copy of the tan-
gent line to the right side. This will create a new tangent line touching the right-
most circle.

• In the Transformation tool palette, select the Mirror tool.



Exercise 3: Creating the Chassis Profile
Make sure that the single line created in the previous step is still selected.

• Move the pointer over the center of the arc such that the quadrant notation 
appears and click to set the beginning of the reference line.

• Hold down the CTRL key (Windows) or OPTION key (Macintosh).

• Move the pointer vertically down from the previous point, such that a perpen-
dicular notation appears.

• Click to set the end of the reference line. (If you have difficulty with this due 
to axis interference, choose Layout>Hide Axis.)

A mirrored copy of the tangent line appears. 

7. Draw a line between the top endpoints of the two tangent lines.

• In the Line tool palette, select the Single Line tool.

• Click the first point of the line at the top endpoint point of the left tangent 
line.
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• Click the endpoint of the line at the top endpoint of the right tangent line. 

8. Delete the construction lines. They are no longer needed.

• Choose Layout>Delete Constructions to delete the construction lines.

9. Save the file.

• Choose File>Save or CTRL+S (Windows) or a+S (Macintosh).

You’ve now created the basic chassis profile.

Exercise 4: Editing the Profile
In this exercise, you’ll edit the profile using the 2-Entity Fillet tool and the Simple 
Trim tool.

1. Fillet the two inner-most 25 mm circles between the circle and the arc with 15 
mm fillets without trimming the circles.

• In the Fillet/Chamfer tool palette, select the 2-Entity Fillet tool.

• In the Radius data field of the Status Line, type 15.

• Hold down the CTRL key (Windows) or the OPTION key (Macintosh) to pre-
vent trimming of the line, as mentioned in the Message Line.



Exercise 4: Editing the Profile
• Click on the left side of the first of 
the two inner-most circles (point 1 in 
the graphic) to select the first fillet 
entity.

• Click on the arc to the left of that 25 
mm circle (point 2 in the graphic) and 
the first fillet is created.

• Fillet the other side of the circle.

• Now fillet both sides of the other 25 
mm circle.

2. Trim the arc between the fillets on the left innermost circle and between the fil-
lets on the right innermost circle.

• Choose the Selection tool.

• Select the four fillets you just created. 
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• Choose the Simple Trim tool from the Curve Extras tool palette. 

• Click on the arc section between the fillets for the left innermost circle and 
the arc section between the fillets for the right innermost circle.

The arcs are trimmed.

3. Now trim the portion of the inner circles between these same fillets.

4. Trim the remaining portion of the left and right outermost circles to complete 
the wireframe.

• Choose the Selection tool.

• Hold down the SHIFT key and select the two tangent lines and the left-most 
and right-most arc segments. 

• Choose the Simple Trim tool again.



Exercise 4: Editing the Profile
• Trim the circle segments.

5. Click away from the geometry to deselect everything.

6. Save the file as, Inline Skate Profile.

• Choose File>Save.

Congratulations! You have now completed the wireframe profile for the inline skate 
chassis. In the next chapter, you’ll turn this 2D geometry into a 3D part.
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Solid Modeling
A solid model is a 3D representation of an object with its inside and outside mate-
rial defined mathematically. Unlike wireframes and surfaces, which define lengths 
and areas, solid models accurately provide physical information about objects. They 
can also generate stereolithography models, useful rapid prototyping concepts, or 
create forms for molds or castings. 

In these exercises, you’ll continue designing the inline skate chassis using the 2D 
profile created in the last chapter to produce the following solid model:

In this chapter you’ll learn how to:

• Extrude a profile
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• Set up a mounting platform on the chassis

• Create a platform and a chassis cutout

• Perform basic and advanced photorealistic rendering

• Calculate the chassis’ physical properties

Exercise 1: Extruding the Chassis Profile
In this exercise you will extrude the profile using the Extrude Solid tool.

1. Open the file, InLine Skate Profile, if it is not already open.

2. Save the file as InLine Skate Solid.

• Choose File>Save As.

• In the Save document as dialog box, type Inline Skate Solid.

• Click Save.

3. Choose Window>Trackball to display the Trackball.

4. Choose Window>Surfaces and Window>Solids if the Surfaces and Solids 
tool palettes are not displayed under the main tool palette.



Exercise 1: Extruding the Chassis Profile
5. From the Trackball menu, 
choose Trimetric.

6. From the Profiles tool palette, 
choose the Extrude Solid tool.

The pointer becomes a 
hollow selection arrow.

7. Drag a selection fence around the entire chassis profile to select it. 

The hollow selection arrow becomes an bulls-eye pointer.

8. Click on a point on the profile.

You are specifying the beginning point of the extrusion.

9. Move the pointer along the Y axis, using the Drafting Assistant as a guide.
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10. Click along the Y axis (it doesn’t matter where) to finish defining the extrusion 
direction and length.

11. In the highlighted Distance data field of the Status Line, type 29.5 and press 
ENTER (Windows) or RETURN (Macintosh).

12. Save the file.

Exercise 2: Setting Up the Mounting Platform
In this exercise you’ll set up the mounting platform for the skate using the Extrude 
Solid tool, the Infinite Plane tool, the Split Solid tool, the Union Solid tool and 
the Show/Hide command.



Exercise 2: Setting Up the Mounting Platform
1. Extrude the top face of the chassis up 8 mm with a 10° draft.

• With the Extrude 
Solid tool still 
active, select the top 
face of the chassis.

• Click a point on the 
edge of a face.

• Move the pointer 
along the Z axis and 
click some distance 
above the first 
point.

The top face extrudes.

• Type 8 in the high-
lighted Distance data 
field of the Status Line 
and 10 in the Draft 
Angle field. (Use the 
TAB key to move 
between fields.)

• Press ENTER (Win-
dows) or RETURN 
(Macintosh) to update 
the extrusion.
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You’ve created an 8 
mm platform.

If you can’t see the 
entire chassis, use the 
scroll bar to adjust the 
drawing area.

2. Trim the 8 mm extrusion 
to share the same plane 
as the sloped face on 
the front and back of the chassis.

• In the Surfaces tool palette, choose the Infinite Plane tool.

• In the Message Line, choose the 3 Pts In Plane option from the pull-down 
menu.



Exercise 2: Setting Up the Mounting Platform
• Click three points on the sloped face to create 
an infinite plane at the same angle as the face.

In the graphic here, the midpoint of the left 
edge, bottom left and bottom right endpoints 
were selected.

The infinite plane is created at the angle of the 
sloped face.

• Using the Trackball, rotate the chassis so that 
the back sloped face is visible.
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• Click three points on this face to create an infinite plane.

3. Split the 8 mm platform using the infinite plane on both sides of the chassis.

• In the Solids Utilities tool palette, choose the Split Solid tool.

• Select the 8 mm platform you created in step 1.

• Select the infinite plane on this back face of the chassis.

The 8 mm platform is split by the plane.

• In the Trackball menu, change the view to Tri-
metric.

• Select the 8 mm platform again.



Exercise 2: Setting Up the Mounting Platform
• Select the infinite plane on this side of the chas-
sis and the 8 mm platform is split by the plane.

4. Hide the two split portions of the platform and the 
two infinite planes.

• Choose Window>Show-Hide.

• Select Hide in the Show-Hide window.

• Select the small split portion of the 
platform.

The split portion hides.

• Select the infinite plane to hide it.

• Rotate the chassis to display the 
back side and hide the split portion 
of the platform and the infinite 
plane.
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• In the Trackball menu, choose Trimetric.

• Close the Show-Hide dialog box by clicking on the close button in its title bar.

5. Union the 8 mm platform with the rest of the chassis.

• In the Solids Utilities palette, choose the Union Solid tool.

• Select the chassis.

• Select the 8 mm plat-
form.

The two objects union 
into one solid.

6. Save the file.



Exercise 3: Creating a Platform Cutout
Exercise 3: Creating a Platform Cutout
In this exercise, you’ll create a cutout through the chassis using the Snap Options 
command, the Parallel Line tool, the 3 Pt Conic tool, the Single Line tool, the 
Sweep Surface tool, the Split Solid tool and the Show/Hide command.

1. Use the Trackball to display the Front view. 

This automatically sets the plane to Front. If the chassis does not completely dis-
play on your screen, choose View>Zoom All.

2. Choose Window>Snaps.

The Snap Options dialog box displays.

3. Select the Project to Work Plane option and a check 
mark appears.

By choosing this option you can create curves in one 
2D plane while using the chassis as a reference.

4. Close the dialog box.

5. Create a horizontal stroke construction line through 
the axle centers.

• Hold down the SHIFT+CTRL keys (Windows) or the 
a key (Macintosh). The pointer becomes the Stroke 
pointer (a).

• Place the Stroke pointer over an axle center and drag to the left. 

• A horizontal construction is created.

6. Create a new horizontal construction line offset from the axle center, 35 mm up.

• In the Line tool palette, select the Parallel Line tool.

• Place the pointer over the construction line and drag a new line up a short 
distance from the original line.
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• Type 35 in the Offset data field of the Status Line and press ENTER (Win-
dows) or RETURN (Macintosh).

7. Create two vertical construction lines through the centers of the two inner 
wheel axles.

• Hold down the SHIFT+CTRL keys (Windows) or the a key (Macintosh).

• Place the Stroke pointer over each axle center for each axle and drag up.

8. Using the Parallel Line tool, create two additional vertical construction lines. 
Place one 25 mm to the right of the left vertical construction line. Place another 
18 mm to the left of the right vertical construction line.

• Place the pointer over the left vertical construction line.

• Drag to the pointer to the right.

• In the Offset data field of the Status Line, type 25 mm and press ENTER (Win-
dows) or RETURN (Macintosh).

• Place the pointer over the right vertical construction line.

• Drag to the pointer to the left.



Exercise 3: Creating a Platform Cutout
• In the Offset data field, type 18 mm and press ENTER (Windows) or RETURN 
(Macintosh).

9. Create two conics using the constructions lines as a guide.

• In the Ellipse/Conic tool palette, choose the 3-Pt Conic tool.

• Click the points for the left conic in 
the order (1, 2, 3) indicated in the 
graphic.

The conic appears.

• Click the points for the right conic in 
the order (1, 2, 3) indicated in the 
graphic.
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A second conic appears.

10. Connect the bottom of the conics with a line.

• In the Line tool palette, select the Single Line tool.

• Place the first point of the line at the lower point of the first conic.

• Place the end point of the line at the bottom of the lower point of the second 
conic.

11. Delete the construction lines.

• Choose Layout>Delete Constructions.

The constructions lines are deleted.

12. Turn off the Snap option, Project to Work Plane.



Exercise 3: Creating a Platform Cutout
• Choose Window>Snaps.

• In the Snap Options dialog box, turn off the Project to Work Plane option by 
clicking in the check box.

• Close the Snap Options dialog box.

13. Now create a surface from the profile along the width of the platform.

• Change your view to Trimetric using the Trackball menu.

• In the Surface tool palette, choose the Sweep Surface tool.

• Hold down the SHIFT key and select the two conics and the line you just cre-
ated.

The pointer becomes a bulls-eye.

• Click on the endpoint of the conic.

• Move the pointer along the Y axis 
beyond the end of the chassis.

• Click to place the second point.
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The surface is generated.

14. Drag your surface along the Y axis so that surface completely covers the top of 
the platform.

• Choose the Selection tool and 
select the surface.

• Place the pointer at an endpoint.

• Drag along the Y axis some dis-
tance with the help of the Drafting 
Assistant’s dynamic construction 
line.

15. Split the chassis with the surface.



Exercise 4: Creating the Chassis Cutout
• In the Solids Utilities tool palette, choose the Split Solid tool.

• Select the chassis.

• Select the surface and the solid is split.

16. Show only the chassis.

• Choose Window>Show-Hide.

• Select the Show Only option.

• Select the chassis.

The curves, surface and split 
solid portion are hidden. 
Only the chassis displays.

Close the Show-Hide win-
dow by clicking on the close 
button in its title bar.

17. Save the file.

Exercise 4: Creating the Chassis Cutout
Now you’re going to create a cutout through the length of the chassis where the 
wheels would be placed. You’ll use the Rectangle tool, the Move tool, the Cutout 
Feature tool and the Constant Blend tool.
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1. Switch the view to Side using the Trackball menu.

2. In the empty space to the left of the chassis, draw a rectangle 
24.5 mm wide by 70 mm high.

• From the main tool palette, select the Rectangle tool.

• Choose the Center/Corner Rectangle tool, the first tool in the subpalette.

• Move the rectangle pointer to the left of the chassis and click to place the 
center point of the rectangle.

• Move the pointer away from the center and click anywhere to place the cor-
ner of the rectangle.

• Type 24.5 in the highlighted W (width) data field of the Status Line.

• TAB once to activate the H or height data field.

• Type 70 into that data field

• Press ENTER (Windows) or RETURN (Macintosh).



Exercise 4: Creating the Chassis Cutout
• The rectangle resizes to these new values.

3. Move the rectangle using the midpoint of the top line and align it 
with the top midpoint of the chassis.

• Select the rectangle with the Selection tool.

• Place the pointer at the midpoint of the top horizontal line such 
that the midpoint notation appears.
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• Drag the rectangle from this midpoint and align it with the 
midpoint of the top of the chassis.

You won’t know which midpoint of chassis the rectangle 
snapped to but that does not matter as you’ll soon see.

4. With the rectangle still selected, use the Move tool to move it -
2.5 mm in the Z direction.

• In the Transformation tool palette, choose the Move tool.

• Type -2.5 in the dZ data field of the Status Line and press ENTER (Windows) 
or RETURN (Macintosh).

The rectangle moves down 2.5 mm.

5. Change the view to Trimetric using the Trackball menu.

6. Use the Move tool to move the rectangle along the X axis out-
side of the chassis.

• Click a point outside the chassis. It doesn’t matter where 
because you are using this point and the next as a reference 
point for setting the move distance.



Exercise 4: Creating the Chassis Cutout
• Using the Drafting Assistant, click the second point far enough along the X 
axis such that the rectangle moves in front of the chassis.

The rectangle moves outside the chassis.

Check the Status Line to see that only the dX field contains a non-zero value. 
If the dY and dZ data fields contain values other than 0, type 0 in them and 
press ENTER (Windows) or RETURN (Macintosh).

If the rectangle is not completely within the drawing area, use the scroll bars 
to correct it.
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7. In the Solids Features tool palette, choose the Cutout Feature tool.

8. Select the solid chassis.

9. Drag a selection fence around the rectangle to 
select it.

10. Click on a top endpoint of the rectangle.

11. Click along the X axis towards the chassis to spec-
ify the direction of the cutout.



Exercise 4: Creating the Chassis Cutout
A cutout appears through the chassis to the depth 
shown in the Status Line.

12. In the highlighted Distance field of the Status Line, 
type 500.

This is a value greater than the length of the chassis 
(300 mm) so that the cutout goes completely 
through the chassis. This value depends on how far 
away from the chassis you moved the rectangle in 
step 6. 500 should be long enough.

Make sure the Draft value is set to 0.

13. Press ENTER (Windows) or RETURN (Macintosh).

The cutout tunnel extends through the chassis and subtracts the intersecting solid 
material.

14. Hide the rectangular profile.

• Choose Window>Show-Hide.

• Select the Hide option.

• Drag a selection fence around the rectangle to hide it.

• Close the Show-Hide window.

15. Place 3 mm blends on each side of the inside of the tunnel at each mounting 
plate.
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• In the Solid Features tool palette, choose the Blend tool.

• In the Message Line, make sure the first tool, Constant Blend, is selected.

• Type 3 in the R (radius) data field of the Status Line.

• Rotate the chassis using the Trackball to 
better see the top right inside edge.

• Click on the right inside top edge of the 
tunnel.



Exercise 4: Creating the Chassis Cutout
• Rotate the chassis so you can clearly see the 
left inside edge.

• Click on the left inside top edge of the tun-
nel.

• Rotate the chassis so that the back mounting 
plate and tunnel display.
4-25



Solid Modeling

4-26
• Click on the inside edges of the tunnel to blend these edges rotating as 
needed.

• Choose the Selection tool. 

You are doing this so you do not inadvertently try to blend something else if 
you click in the drawing area.

• Change the view to Trimetric using the Trackball.

16. Save the file.

Exercise 5: Basic Rendering
You’re now going to render your chassis using Ashlar’s 3D modeling products 
(Cobalt, Xenon or Argon) basic rendering capability.

1. Choose View>Shade Options.



Exercise 5: Basic Rendering
The Shade Options dialog box appears.

2. Use the pull-down menu to set the Static Render, Dynamic Render and Render 
Now options to Phong w/Edges.

3. Click OK to save the settings and close the dialog box.

4. Choose PhotoRender>Preview Render(shadows off).

The chassis renders.

5. Change the color of the chassis using the color palette.

• Select the chassis.
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• Choose Pen>Color and select the desired color.

You can also rotate the chassis to see it from different angles.

Exercise 6: Advanced Rendering
You can create more realistic visual affects by applying a material and displaying 
your model using photorealistic rendering.

1. Choose Window>Render Library.

The Render Library dialog box displays on your screen.

This library is divided into library types, including flooring, glass, masonry, metal 
and the like.



Exercise 6: Advanced Rendering
2. From left most pull-down menu, Library Types, select Materials.

3. From the next pull-down menu, Categories, select Metal for the material.

4. Place the pointer over the third window. The title bar should display Render 
Library -- Metal Aluminum (CBrushed).
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5. Drag the pointer from the Render Library dialog box to the chassis. As you do 
so the pointer becomes an application symbol shown here.

6. Release the mouse button when the chassis becomes selected and the material 
is applied.

Now you want to render the chassis using photorealistic rendering.

7. Choose PhotoRender>Raytrace Render [shadows on, Anti-Alias].



Exercise 6: Advanced Rendering
Ashlar’s 3D modeling product redraws your chassis with the new rendering.

8. Apply different materials and textures to your chassis simply by selecting the 
material and dragging it to your chassis. Then view the effect by using one of 
the advanced rendering commands, Preview Render [shadows off], Preview Ren-
der [shadows on], Raytrace Render [shadows off] and Raytrace Render [shadows 
on, Anti-Alias].

The left graphic here shows the chassis rendered with a bubble wrap miscella-
neous material and the right graphic shows it rendered with a Knurl 2 tiled tex-
ture material.

9. Close the Render Library dialog box.

10. Save the file.
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You’re done. You’ve modeled the basic inline skate chassis in Ashlar’s 3D modeling 
products’ integrated design environment. But you’re not finished yet.

Exercise 7: Calculating the Chassis’ Physical Properties
You can calculate a model’s physical properties using Ashlar’s 3D modeling prod-
ucts, such as Mass Properties, area, interference between parts and other properties.

1. Select the chassis.

2. Choose Verify>Properties.

The Mass Properties dialog box appears displaying the Properties of the chassis.

Click OK to close the dialog box.

3. Choose Verify>Area.

The Verify Area dialog box appears displaying the area of the chassis.

Click OK to close the dialog box. You can explore other physical properties as 
you wish.



Exercise 7: Calculating the Chassis’ Physical Properties
4. Save the file.

You’ve completed the inline skate chassis. In the next chapter you produce a 2D 
drawing, add dimensions and create a section view.
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Detail Drawing
After you’ve created the model, you may want to create production drawings. You 
probably will want to display your model at various angles, place dimensions and 
even create a section cut of the model. In these exercises you’ll do just that for the 
chassis to create the following detail drawing.

In this chapter you’ll learn how to:

• Create a detail drawing
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• Create a section view

• Place dimensions

Exercise 1: Creating a 2D Detail Drawing
In this exercise you’ll generate a 2D detail drawing using the Model to Sheet com-
mand.

1. Open the file, Inline Skate Solid, if it is not already open.

2. Select the inline chassis.

3. Choose Layout>Model to Sheet.

The Model to Sheet dialog box appears.

4. From the Layouts pull-down menu, select D Landscape 4Views.vs.



Exercise 2: Creating a Section View
5. The Edge Display option should be set to Visible Only (Precise).

6. In the Scale data field, accept the defaul of 1.

7. Click OK to close the dialog box and generate the drawing.

The detail drawing displays the chassis in Top, Front, Side and Trimetric views.

If you inadvertently selected the wrong layout, choose Edit>Undo.

8. Save the file as Inline Skate Production.

• Choose File>Save As.

• In the File name data field, type Inline Skate Production.

• Click Save.

Exercise 2: Creating a Section View
The following exercise can be done only in the Cobalt™ Designer Elements pro-
gram. Argon™ and Xenon™ skip ahead to exercise 3.

Now you’ll add a section view to your drawing using the Section tool.

1. Select the Front view of the chassis.

• Move your pointer over the Front view of the chassis.

• Click on the chassis. The Front drawing view of the chassis activates.
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2. Choose Window>Sheet Tools.

The Sheet tool palette displays in the drawing area.

3. Choose the Section tool from the Sheet tool palette.

4. In the Message Line, make sure the Vertical Section tool is selected.

5. Pick the view again.

6. Click on the endpoint indicated 
in the graphic here.

7. Drag the section view to the 
final position, as instructed in 
the Message Line. 

In this case drag it to the right over the title box at the bottom of the drawing. You 



Exercise 2: Creating a Section View
will notice that you only seem to be dragging the view boundary.

8. Click to place the final location of the section view.

The chassis section appears, labeled Section A-A. Notice that the Front view is 
also labeled at the section location.

9. Increase the scale of the section view to 2.

• Choose the Selection tool.

• Select the section view by clicking on it.

• In the upper left corner of the section view, click in 
the box area to display the Drawing View menu.

• Select the Properties command.
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The Draw View Properties dialog box displays.

• Type 2.0 in the Scale data field and click OK to close the dialog box.

Since you now cannot see the section cut because of the scale change, you 
will need to resize the drawing view.

10. Click in the upper left corner of the view to display the Drawing view menu 
again.

11. Choose the Frame to Extents command.

The view resizes to frame the section cut.



Exercise 2: Creating a Section View
12. Click outside of the dotted lines of the drawing to deselect the section view.

13. Close the Sheet tool palette.

14. Save your drawing.
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Exercise 3: Adding Dimensions
In this exercise you’re going to add a few dimensions to your drawing using 
the Horizontal Chain Dimension tool, the Dimension Arrow Out Dimen-
sion tool, the Horizontal Dimension tool and the Vertical Dimension tool.

Tear off the Dimension palette from the main tool palette (to rotate the 
palette to the horizontal position, right click on the palette and chose “Flip 
Horizontal”).

15. Using the Selection tool, select the Front view.

16. In the Dimension palette, choose the Horizontal Chain Dimension tool.

• Move your pointer to the top tool in the Dimension tool palette.

• Drag the pointer to the third tool, the Horizontal Chain Dimension tool, to 
select it.

• The pointer becomes a horizontal dimension tool icon.



Exercise 3: Adding Dimensions
17. Move the hot spot of the pointer over to the left most axle of the chassis such 
that the center point notation appears.

18. Click to place the first point.

19. Move the pointer to the center of the axle hole to the right and click to place 
the next point.

A dimension appears.
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20. Click at the centers of the next two axles to finish placing the horizontal chain 
dimension.

21. Choose the Selection tool.

22. Hold down the SHIFT key and select all three chain dimensions.

23. Drag the dimensions above the chassis.

24. Select the Diameter Arrow Out Dimension tool from the Dimen-
sion tool palette.

The pointer becomes the diameter arrow pointer.



Exercise 3: Adding Dimensions
25. Move the pointer to the edge of the third axle from the left such that an on 
notation appears.

26. Click to place the dimension.

27. Choose the Selection tool and select the chain dimensions and the section 
dimension, in addition to the diameter dimension already selected.

28. Choose Dimension>Size and select 24.
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The dimensions text resizes.

29. Choose the Selection tool and select the Top view.

30. From the Horizontal Dimension tool subpalette, choose the Horizontal 
Dimension tool. (See page 6-8 for graphic illustration.)



Exercise 3: Adding Dimensions
31. Move the pointer to the top left endpoint of the chassis such that an endpoint 
notation appears.

32. Click to place the first point.

33. Move the pointer to the endpoint at the opposite side of the chassis and click to 
place the other point.

34. Choose Dimension>Size and select 24.
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The dimensions text resizes.

35. Choose the Selection tool and select the Right Side view.

36. Select the Horizontal Dimension tool again.



Exercise 3: Adding Dimensions
37. Click the top left endpoint of the chassis.

38. Click the top right endpoint and the dimension appears.

39. Choose the Vertical Dimension tool, as shown here.
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40. Move the pointer to the bottom left endpoint of the chassis and click at the end-
point.

41. Click the second point at the top left endpoint.

42. Place the pointer over the center of the text so that a four way arrow appears.

43. Drag the dimension to the left so 
that it does not cover the part.

44. Choose the Selection tool.

45. Hold down the SHIFT key and 
select the horizontal dimension in 
addition to the vertical dimension 
still selected.

46. Choose Dimension>Size and 
select 24.



Exercise 3: Adding Dimensions
The dimensions text resizes.

47. To complete the tutorial, add view names to the drawing views.

• Click on the top left corner of the drawing view to display the Drawing View 
menu.

• Choose the Properties command and the dialog box displays.

• Select the Draw name option.

• Click OK.
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The dialog box closes and the name, Right Side appears.

• Select the views separately and repeat this procedure to display their respec-
tive view names.

• Click outside of the drawing area to deselect everything.

48. Save the file.



Exercise 3: Adding Dimensions
Congratulations! You’ve generated a 2D detail drawing with a section view and 
dimensions. You’ve also completed the Ashlar’s 3D modeling products tutorial.
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	4. Save the file as Inline Skate Profile.

	Exercise 3: Creating the Chassis Profile
	1. Create a horizontal stroke construction line through the origin.
	2. Create a new horizontal construction line offset from the axle center, 15 mm above the first c...
	3. Create an arc, tangent to the left-most 25 mm circle, the upper construction line and the righ...
	4. Create a new horizontal construction line offset from the axle centers, 40 mm above the first ...
	5. Draw a tangent line from the outer edge of the left-most 25 mm circle to the upper constructio...
	6. Using the arc’s middle quadrant point as a reference, mirror a copy of the tangent line to the...
	7. Draw a line between the top endpoints of the two tangent lines.
	8. Delete the construction lines. They are no longer needed.
	9. Save the file.

	Exercise 4: Editing the Profile
	1. Fillet the two inner-most 25 mm circles between the circle and the arc with 15 mm fillets with...
	2. Trim the arc between the fillets on the left innermost circle and between the fillets on the r...
	3. Now trim the portion of the inner circles between these same fillets.
	4. Trim the remaining portion of the left and right outermost circles to complete the wireframe.
	5. Click away from the geometry to deselect everything.
	6. Save the file as, Inline Skate Profile.


	Solid Modeling
	Exercise 1: Extruding the Chassis Profile
	1. Open the file, InLine Skate Profile, if it is not already open.
	2. Save the file as InLine Skate Solid.
	3. Choose Window>Trackball to display the Trackball.
	4. Choose Window>Surfaces and Window>Solids if the Surfaces and Solids tool palettes are not disp...
	5. From the Trackball menu, choose Trimetric.
	6. From the Profiles tool palette, choose the Extrude Solid tool.
	7. Drag a selection fence around the entire chassis profile to select it.
	8. Click on a point on the profile.
	9. Move the pointer along the Y axis, using the Drafting Assistant as a guide.
	10. Click along the Y axis (it doesn’t matter where) to finish defining the extrusion direction a...
	11. In the highlighted Distance data field of the Status Line, type 29.5 and press ENTER (Windows...
	12. Save the file.

	Exercise 2: Setting Up the Mounting Platform
	1. Extrude the top face of the chassis up 8 mm with a 10° draft.
	2. Trim the 8 mm extrusion to share the same plane as the sloped face on the front and back of th...
	3. Split the 8 mm platform using the infinite plane on both sides of the chassis.
	4. Hide the two split portions of the platform and the two infinite planes.
	5. Union the 8 mm platform with the rest of the chassis.
	6. Save the file.

	Exercise 3: Creating a Platform Cutout
	1. Use the Trackball to display the Front view.
	2. Choose Window>Snaps.
	3. Select the Project to Work Plane option and a check mark appears.
	4. Close the dialog box.
	5. Create a horizontal stroke construction line through the axle centers.
	6. Create a new horizontal construction line offset from the axle center, 35 mm up.
	7. Create two vertical construction lines through the centers of the two inner wheel axles.
	8. Using the Parallel Line tool, create two additional vertical construction lines. Place one 25 ...
	9. Create two conics using the constructions lines as a guide.
	10. Connect the bottom of the conics with a line.
	11. Delete the construction lines.
	12. Turn off the Snap option, Project to Work Plane.
	13. Now create a surface from the profile along the width of the platform.
	14. Drag your surface along the Y axis so that surface completely covers the top of the platform.
	15. Split the chassis with the surface.
	16. Show only the chassis.
	17. Save the file.

	Exercise 4: Creating the Chassis Cutout
	1. Switch the view to Side using the Trackball menu.
	2. In the empty space to the left of the chassis, draw a rectangle 24.5 mm wide by 70 mm high.
	3. Move the rectangle using the midpoint of the top line and align it with the top midpoint of th...
	4. With the rectangle still selected, use the Move tool to move it - 2.5 mm in the Z direction.
	5. Change the view to Trimetric using the Trackball menu.
	6. Use the Move tool to move the rectangle along the X axis outside of the chassis.
	7. In the Solids Features tool palette, choose the Cutout Feature tool.
	8. Select the solid chassis.
	9. Drag a selection fence around the rectangle to select it.
	10. Click on a top endpoint of the rectangle.
	11. Click along the X axis towards the chassis to specify the direction of the cutout.
	12. In the highlighted Distance field of the Status Line, type 500.
	13. Press ENTER (Windows) or RETURN (Macintosh).
	14. Hide the rectangular profile.
	15. Place 3 mm blends on each side of the inside of the tunnel at each mounting plate.
	16. Save the file.

	Exercise 5: Basic Rendering
	1. Choose View>Shade Options.
	2. Use the pull-down menu to set the Static Render, Dynamic Render and Render Now options to Phon...
	3. Click OK to save the settings and close the dialog box.
	4. Choose PhotoRender>Preview Render(shadows off).
	5. Change the color of the chassis using the color palette.

	Exercise 6: Advanced Rendering
	1. Choose Window>Render Library.
	2. From left most pull-down menu, Library Types, select Materials.
	3. From the next pull-down menu, Categories, select Metal for the material.
	4. Place the pointer over the third window. The title bar should display Render Library -- Metal ...
	5. Drag the pointer from the Render Library dialog box to the chassis. As you do so the pointer b...
	6. Release the mouse button when the chassis becomes selected and the material is applied.
	7. Choose PhotoRender>Raytrace Render [shadows on, Anti-Alias].
	8. Apply different materials and textures to your chassis simply by selecting the material and dr...
	9. Close the Render Library dialog box.
	10. Save the file.

	Exercise 7: Calculating the Chassis’ Physical Properties
	1. Select the chassis.
	2. Choose Verify>Properties.
	3. Choose Verify>Area.
	4. Save the file.


	Detail Drawing
	Exercise 1: Creating a 2D Detail Drawing
	1. Open the file, Inline Skate Solid, if it is not already open.
	2. Select the inline chassis.
	3. Choose Layout>Model to Sheet.
	4. From the Layouts pull-down menu, select D Landscape 4Views.vs.
	5. The Edge Display option should be set to Visible Only (Precise).
	6. In the Scale data field, accept the defaul of 1.
	7. Click OK to close the dialog box and generate the drawing.
	8. Save the file as Inline Skate Production.

	Exercise 2: Creating a Section View
	1. Select the Front view of the chassis.
	2. Choose Window>Sheet Tools.
	3. Choose the Section tool from the Sheet tool palette.
	4. In the Message Line, make sure the Vertical Section tool is selected.
	5. Pick the view again.
	6. Click on the endpoint indicated in the graphic here.
	7. Drag the section view to the final position, as instructed in the Message Line.
	8. Click to place the final location of the section view.
	9. Increase the scale of the section view to 2.
	10. Click in the upper left corner of the view to display the Drawing view menu again.
	11. Choose the Frame to Extents command.
	12. Click outside of the dotted lines of the drawing to deselect the section view.
	13. Close the Sheet tool palette.
	14. Save your drawing.

	Exercise 3: Adding Dimensions
	15. Using the Selection tool, select the Front view.
	16. In the Dimension palette, choose the Horizontal Chain Dimension tool.
	17. Move the hot spot of the pointer over to the left most axle of the chassis such that the cent...
	18. Click to place the first point.
	19. Move the pointer to the center of the axle hole to the right and click to place the next point.
	20. Click at the centers of the next two axles to finish placing the horizontal chain dimension.
	21. Choose the Selection tool.
	22. Hold down the SHIFT key and select all three chain dimensions.
	23. Drag the dimensions above the chassis.
	24. Select the Diameter Arrow Out Dimension tool from the Dimension tool palette.
	25. Move the pointer to the edge of the third axle from the left such that an on notation appears.
	26. Click to place the dimension.
	27. Choose the Selection tool and select the chain dimensions and the section dimension, in addit...
	28. Choose Dimension>Size and select 24.
	29. Choose the Selection tool and select the Top view.
	30. From the Horizontal Dimension tool subpalette, choose the Horizontal Dimension tool. (See pag...
	31. Move the pointer to the top left endpoint of the chassis such that an endpoint notation appears.
	32. Click to place the first point.
	33. Move the pointer to the endpoint at the opposite side of the chassis and click to place the o...
	34. Choose Dimension>Size and select 24.
	35. Choose the Selection tool and select the Right Side view.
	36. Select the Horizontal Dimension tool again.
	37. Click the top left endpoint of the chassis.
	38. Click the top right endpoint and the dimension appears.
	39. Choose the Vertical Dimension tool, as shown here.
	40. Move the pointer to the bottom left endpoint of the chassis and click at the endpoint.
	41. Click the second point at the top left endpoint.
	42. Place the pointer over the center of the text so that a four way arrow appears.
	43. Drag the dimension to the left so that it does not cover the part.
	44. Choose the Selection tool.
	45. Hold down the SHIFT key and select the horizontal dimension in addition to the vertical dimen...
	46. Choose Dimension>Size and select 24.
	47. To complete the tutorial, add view names to the drawing views.
	48. Save the file.
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