


Installing & Launching Graphite

Insert the CD and follow the prompts or double click on the installer program on the CD or in the download folder as appropriate.

Serial Number and Registration Code

Graphite program requires a serial number and a registration code. If the registration code is not included with this package, call Ashlar-Vellum's Customer Service at 1 800 966 2349 or send an e-mail to customer.service@ashlar.com to receive the code. Be prepared to provide your serial number when calling. When launching this program for the first time, enter your serial number and registration code in the data fields of the dialog box.

Technical Support

All customers have 90 days of free telephone assistance starting from the date of receiving the Registration Code. Free email support for an existing ticket is available for those with the current version or one version back who have created an existing ticket. To start a technical support ticket, go Help>Submit Support Ticket. An e-mail automatically creates with all the necessary data included. See the picture on the next page of the automatically created email to the technical support.
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Starting Graphite after Installation

1.     Start the computer.

2.     Locate the program icon and double-click it to launch the program.

The Autodetect units window opens. Check the autodetect units at startup option to enable it and the units will be detected while opening Graphite files and importing the third party software files.
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Ending Graphite

1.     Save and close all open files.

2.     Choose File>Exit (Windows) or File>Quit (Macintosh).




Tutorial Introduction

The exercises in the next chapters will familiarize you with the tools, features and commands of Graphite, proving how quickly Graphite can be learned and used for your design needs. The exercises demonstrate Graphite’s most powerful features showing how the patented Drafting Assistant simplifies Computer-Aided Design and Drafting (CADD). Soon your own knowledge about design and drafting will integrate the software making your work faster, more accurate and more creative.

Chapter Layout

The exercises are organized in chapters according to the tools and features used. The chapters are ordered with the most basic exercises in the beginning and proceed to more complex exercises in the later chapters.

Notes provide alternative ways of doing a procedure or may refer to another section or chapter for related information.

Menus and Submenus

Choosing Commands

Proceeding through the exercises, you are directed to choose commands contained in submenus of other menus, like the pull down menu. For example, if asked to select Define in the Color submenu of the Pen menu, that will be displayed as Pen>Color>Define.

Notes

This book includes notes that provide additional information for using this program. There are three types of notes: Tip, Tech Note and Referral. These notes are given special treatment so that their significance is instantly recognizable and they can be located for future reference.

Tip

A tip provides instructions for getting the most out of Graphite. Tips may show how to speed up an operation or how to perform some timesaving drawing technique.

Tech Note

A technical note provides additional technical information that may help when using a tool.

Referral

A referral indicates related information contained somewhere else in the manual for the particular topic being addressed.

Exploring

Some users like to explore on their own while going through the exercises of a tutorial. This is an excellent way to learn more about Graphite. For the adventuresome, open a new document for your explorations and then switch back to the tutorial document to continue with the exercises.

Occasionally, the tutorial may verify a position or entry that seems to be obvious. If the condition is vital to the next step and you might have inadvertently deviated from the tutorial path, verification (for example, “the x,y location is 0,0”) has been added to ensure that you get the correct result from the exercise.

There’s More than One Way

Graphite often provides more than one way to perform a task. This tutorial describes only one method at a time and may show a different way to do the same task later. Feel free to substitute your own method for whatever is suggested here.

Graphics

Most of the graphics in the manuals apply to both Windows and Mac platforms. In those instances that do not require a platform and software reference, a Graphite Windows graphic is used. When necessary, both Windows and Macintosh graphics are included.

Basic Terminology

This manual uses the following terms for mouse activities: 



	
Pointer


	
An arrow or any other graphic symbol that allows selection or creation of an object. Move the pointer to point to a command or an object on the screen. Depending on its location, the pointer is an arrow or may look like the current tool.
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To move the pointer, move the mouse on the mouse pad.





	
Point


	
Move the mouse until the pointer is over the desired item.





	
Press


	
Press and hold down the mouse button.





	
Click


	
Quickly press and release the mouse button once.





	
Double-click


	
Click the mouse button twice, quickly in succession.





	
Drag


	
Press and hold down the mouse button, move the mouse, then release the mouse button.






Parts of the Graphite Window

When Graphite is launched, the following window appears.
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Title Bar


	
Includes the title of the active document and buttons for controlling the window including boxes for minimizing, maximizing and closing the program.   





	
Menu Bar


	
Contains the Graphite menus of commands and settings. Make choices from the menus with the mouse or by using special key combinations.





	
Tool Palette


	
Contains the drawing and editing tool icons to be used for constructing, editing and annotating geometry.





	
Pointer


	
Shows the active position on the screen. If the pointer is in the drawing area, its shape represents the current tool.





	
Pointer Locator


	
Shows the x, y coordinates of the pointer location.





	
Message Line


	
Displays the name of the current tool and step-by-step instructions for using the tool.





	
Status Line


	
Shows the coordinate location and other geometric parameters of the current construction.





	
Scroll Bars


	
Move around a drawing to see different sections of it through the Graphite window. The scroll buttons move one line at a time.





	
Work Layer Indicator


	
Displays the name of the current layer and provides a menu for changing the work layer.






 




Graphite Basics

These exercises construct this part using computerized fillets, chamfers, crosshatching and dimensions to perform the following tasks:
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•     Open Graphite

•     Choose from menus

•     Create geometry

•     Change geometry

•     Use the patented Drafting Assistant

•     Create construction lines

•     Save a document

•     Stroke to create construction lines

•     Stroke to zoom

•     Create chamfers and fillets

•     Construct circles

•     Trim

•     Change the characteristics of lines

•     Dimension

•     Crosshatch

•     Stretch

•     Rotate

•     Print

Exercise 1: Starting Graphite

This exercise starts Graphite.

1.     Start Graphite.

If Graphite is already started, please select File>Exit (Windows) or Quit (Macintosh). This makes sure that there are no unintentional settings that will interfere with this tutorial.

•  Double-click the Graphite icon in the Graphite folder.
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Graphite opens, displaying an untitled document with an empty drawing area.
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2.     Become familiar with the menus and tool palette.

Exercise 2: Drawing a Part

This exercise constructs the basic shape of the part.

[image: 7-1.jpg]

1.     Select the Connected Lines tool.

•  Move the pointer to the Single Line tool icon on the tool palette and press on the small arrowhead in the corner of the Single Line tool.

[image: 1.jpg]

The subpalette appears.
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Tech Note: Notice that the icon on the left of the subpalette is part of the tool palette display and the other icons on the subpalette represent the available choices. The icon on the palette changes to reflect the last tool choice, but the icons in the subpalettes are always in the same order, regardless of which tool is on the palette.

•  Drag across the subpalette until the Connected Lines tool highlights.
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The Message Line indicates that the Connected Lines tool is selected and reads, Connected Lines: Pick beginning point. It remains the active tool until another tool is chosen.

2.     Draw the first vertical line 2.25 inches long.

•  Position the pointer in the lower left of the drawing area.

[image: 4.jpg]

 

•  Click to set the first point.

Tech Note: The Drafting Assistant’s construction lines aid in precise placement. The predefined construction lines are vertical, horizontal and at a 45 degree angle to existing geometry points. When the pointer is near such a location the construction line appears and the word on appears next to the pointer.

•  Move the pointer up until the Drafting Assistant’s vertical construction line appears.
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•  Move the pointer a couple of inches from the last point (exactness is not necessary), and when on appears on the construction line, click to set the new point on the construction line.

Tech Note: Graphite doesn’t require you to be exact, only close enough to display the feedback. Click the mouse and the Drafting Assistant locks onto the exact location.

•     Whatever is typed automatically goes in the Length Status Line field.

At the bottom of the Graphite window, the Status Line displays these data fields. Notice that the Length (L) box is highlighted.                           
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•  The numbers on the screen may not match the numbers in this graphic.

•  Use either the keypad or the numbers at the top of the main keyboard to type 2.25 and press ENTER or RETURN.
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The length (L) goes into the Status Line data field and the line is redrawn to exactly 2.25 inches, beginning at the first position indicated.

3.     Construct the second line 1.25 inches long at a 45° angle from the end of the first line. (Angles are measured from horizontal, not from the previous line.)

[image: Chapter_03.Graphite00002.jpg]

•  Move the cursor up and to the right at a 45° angle using the Drafting Assistant construction line as shown above. Click to set a new point an inch or so from the last point.

•  Type 1.25 and press ENTER (Windows) or RETURN (Macintosh).
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The line segment is constructed at a 45° angle.

4.     Construct a horizontal line 2 inches long.

•  Move the pointer to the right to display on for the horizontal construction line.

•  Click a few inches from the last point.
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•  Type 2 and press ENTER or RETURN.

A 2-inch horizontal line is drawn.

5.     Construct a vertical line that ends on the horizontal construction line through the upper endpoint of the first line.

Tip: Whenever the pointer is moved around the screen, the Drafting Assistant examines the existing geometry and displays relevant information about current position.

•  Move the pointer straight down until intersect appears, then click to set a point at this intersection.
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A vertical line is drawn to the Drafting Assistant’s intersection marker.
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Tech Note: The current tool remains in effect while commands from the menu are chosen.

6.     Use a command from a menu to create a construction line beginning at the endpoint of the last line and at an angle of -55° and then use it to draw a 1-inch line.

•  Choose Layout>Construction.

The dialog box appears.

[image: Construction.jpg]

When the pointer is in the dialog box, the angle data field highlights. Enter an Angle for the construction line or an Offset from the point specified by the coordinates. In this step enter an angle for the construction line.

Tech Note: The X,Y coordinates displayed in the Status Line represent the location of the last position selected, which is the location needed for this step. Change the coordinates whenever necessary and everything on the Construction layer is ignored for the Zoom All command.

•  Enter -55 (be sure to type the minus sign).

•  Click Apply.

[image: 12.jpg]

A permanent construction line appears as a dotted line on the screen.

Tech Note: Construction lines created in this way are removed when Layout>Delete Constructions is chosen. Such construction lines are treated like any other line by the Drafting Assistant, except that they are placed on the Construction layer.

•  Click the Close box of the Construction dialog button in the upper-right corner (Windows) or upper left corner (Macintosh).
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The dialog box closes.

•  Instead of the Layout>Construction command you can use the Construction Line tool [image: 2-6-idle.bmp] from the Line tools palette.

The angle of the construction line is set in the last field of the Status Line.

Note: Classic construction lines are always relative to the zoom level at which they are created. Infinite construction lines pay no attention to zoom level and are infinite in any direction. The construction line is infinite if the Layout>Preferences>Infinite Construction Lines option is checked. If the same option is unchecked, the dotted line appears limited by the endpoints clicked with the mouse while creating it.

•  Select the Connected Line tool again in case you used the Constrution Line tool for the last step.

•  Click on the construction line, about an inch from the last point.

•  Type 1 in the Length field in the Status Line and press ENTER or RETURN.
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The line is constructed at a -55° angle.

7.     Construct a 1.5-inch horizontal line.

•  Move the pointer to the right to display the horizontal construction line through the endpoint of the last line.

•  Click.

Tech Note: The Status Line data fields accept mathematical operators to add, subtract, multiply, divide and group values within parentheses. See Appendix A in the User Guide section for a complete list of mathematical operators.

•  Type (2+1)/2 in the Length Status Line data field and press ENTER or RETURN.
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The 1.5 inch line appears.

8.     Construct an arc from the right endpoint of the last line to a point horizontally aligned with the first point of this exercise.

•  If part of the construction is now off-screen, choose Arrange>Zoom All to display the entire part on the screen or double click the middle mouse button.

Tech note: The Message Line indicates how to modify the behavior of Graphite’s drawing tools. For example, after drawing the first segment using the Connected Lines tool, hold down the CTRL (Windows) or OPTION (Macintosh) key to draw an arc instead of a straight line. The pointer changes into the shape of an arc to signify this optional drawing mode.

•  Hold down the CTRL (Windows) or the OPTION (Macintosh) key, then move the pointer toward the very first point of the this drawing just to evoke the horisontal construction line and then move straight to the right until intersect appears. The pointer changes to an arc.
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•  Click the mouse button.

•  Release the CTRL (Windows) or OPTION (Macintosh) key.
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The arc appears.

9.     Close the figure.

•  Move the pointer horizontally to the left to display the endpoint notation for the first line created.

•  Double-click to set this point and signal that the connected-line figure is complete.

[image: 13-2.FH7.jpg]

The outline of the part is now complete.

10. Save the drawing.

•  Choose File>Save.

A dialog box appears to name the drawing.

•  Type part1 and press ENTER or RETURN.

Tech Note: It is important to save often. Power failures and mistakes can destroy hours of work without saving frequently. It is important to save before trying any new multistep operation to be able to revert to the original if the results are not satisfactory.

Accomplishments

•     Selecting a tool from the tool palette

•     Constructing a part with the Connected Lines tool

•     Using the Drafting Assistant

•     Choosing from a menu

•     Creating a construction line

•     Saving a document

Exercise 3: Stroke Commands

Before proceeding with the drawing, examine the use of Graphite’s stroke commands for creating construction lines, zooming, and displaying points. For stroke commands, hold down the CTRL and SHIFT keys (Windows) or the z key (Macintosh) and drag the z pointer across the screen or click as needed.

Tip: To start a stroke at a precise location, press the z key (Macintosh) or CTRL+SHIFT (Windows) first to wake up the Drafting Assistant if not already in a geometrically precise tool.
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Drag 


	
Construction Lines





	
Vertically


	
Creates a vertical construction line through the first point of the stroke.





	
Horizontally


	
Creates a horizontal construction line through the first point of the stroke.








	
Drag Diagonally


	
Zoom
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Creates a zoomed-in enlargement centered over the stroked area.
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Reverses the zoomed-in stroke to the previous magnification.





	
[image: Reduce.jpg] 


	
Creates a zoomed-out reduction, so that the current screen reduces to the size of the area defined by the stroke.





	
[image: Zoom_Previous.jpg] 


	
Reverses the zoomed-out stroke to the previous magnification.








	
Click


	
Point Display





	
On object


	
The display of the object’s points is turned on or off.






Use stroke commands while using any tool. The possible effects that can be obtained with a stroke command depend on the direction the pointer is moved. Even though it is possible to create construction lines and zoom in other ways, the stroke commands come in handy because they can be used while in the process of using other tools from the palette.

Tech Note: It is also possible to use the Construction Line[image: 2-6-idle00001.bmp] tool from the Line Tools patelle to create construction lines in this exercise.

1.     Create a horizontal construction line.

•  Hold down the CTRL+SHIFT keys (Windows) or the z key (Macintosh).

•  Position the pointer at the lower end of the -55° line so that endpoint or intersect appears.

•  Drag left horizontally. The pointer trails a dotted line while dragging. Don’t worry if the line isn’t straight.
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A horizontal construction line appears. Now, there are two construction lines which remain until deletion.
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2.     Add a vertical construction line.

•  Hold down the CTRL+SHIFT keys (Windows) or the z key (Macintosh).

•  Position the pointer at the midpoint of the uppermost horizontal line.
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•  Drag down vertically. A vertical construction line appears. These two construction lines are used later in the tutorial.

Tech Note: These construction lines are placed on the construction layer and can be removed by choosing Layout>Delete Constructions. Since the work layer is transparent, everything on the construction layer is displayed.

3.     Use the stroke command to zoom in on a corner of the drawing to fillet it in the next exercise.

•  Hold down the CTRL+SHIFT keys (Windows) or the z key (Macintosh).

•  Drag as shown, from above and to the left of the upper-right corner of the drawing across the corner.

[image: 16-2.jpg]

The corner magnifies.

[image: 16-3.jpg]

Tech Note: Since all tools work at any magnification, repeat this action for further magnification. But for now, proceed to the next exercise.

Accomplishments

•     Creating a construction line by using a stroke command

•     Zooming in with a stroke command

Exercise 4: Fillet and Chamfer

In this exercise, fillet one corner of the part and add a chamfer to another.
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1.     Fillet the corner which was zoomed in on in the last exercise.

Tip: If the geometry is large, hold down the SHIFT key and click inside the corner for single-click filleting. Use this technique when creating the chamfer in Step 3.

•  Click the 2-Entity Fillet tool, in the tenth subpalette of the main tool palette. The Message Line reads, 2-Entity Fillet: Pick first entity [Shift = Corner, Ctrl = No trim (Windows) or Option = No trim (Macintosh)].

[image: 10-1-idle.bmp]

•  Click the horizontal and vertical lines that intersect to form the corner.
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The fillet is drawn with a radius of.25 inches, and the corner is automatically trimmed away.
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Tech Note: Fillets are automatically constructed with a.25 radius, but it is possible to change the radius in the Status Line, just as the line length was changed earlier. If you don’t want to trim a fillet hold down the CTRL (Windows) or the OPTION (Macintosh) key while clicking the lines that need not to be trimmed away.

2.     Return the drawing to its original size.

Tip: It doesn’t matter where you start this stroke or how far you drag to restore the original magnification.

•  Hold down the CTRL+SHIFT keys (Windows) or the z key (Macintosh).

•  Drag the pointer from the lower right to the upper left of the drawing area.

•  Release the CTRL and SHIFT keys (Windows) or the z key (Macintosh).

3.     Add a chamfer to the lower-left corner of the part.

•  Press the Fillet tool to display the subpalette.

•  Select the 2-Entity Chamfer tool. The Message Line reads, 2-Entity Chamfer: Pick first entity to chamfer [Shift = Corner, Ctrl = No trim (Windows) or Option = No trim (Macintosh)].   

[image: 10-3-idle.bmp]

   

•  Hold down the SHIFT key.

•  Click inside the lower-left corner of the part.
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The chamfer is drawn .25 inch from the original corner.

4.     Save the work.

•  Choose File>Save.

Since the drawing is already named, the part is saved without displaying the dialog box. The length of time it takes to save depends on the complexity of the part being drawing.

Accomplishments

•     Constructing a fillet

•     Zooming out by using a stroke command

•     Constructing a simple chamfer

Exercise 5: Adding the Holes

In this exercise two holes are added to the part, one of which is offset from a specified location.
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1.     Construct a hole, 1.5 inches in diameter, centered at the intersection of the vertical and horizontal construction lines created in Exercise 2.

•  Click the Center-Point Circle tool. The Message Line reads, Center-Point Circle: Pick center [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].

[image: 4-1-idle.bmp]

•  Click the intersect point of the horizontal and vertical construction lines to indicate the center of the circle.

•  Move the pointer an inch or so in any direction and click.

A circle is drawn with the center point at your specified location.

•  Enter 1.5 in the D (Diameter) data field of the Status Line.

•  Press ENTER or RETURN.

[image: 20-3.jpg]

The circle is redrawn with a diameter of 1.5 inches.

2.     Construct a 1-inch hole that is offset.06 inches in the negative x-direction from the center of the arc of the part.

•  Move the pointer over the arc until the Drafting Assistant displays the + indicating the center of the arc.

•  Move the pointer to the + to display the center feedback.

[image: 04_Move_pointer_to__center_a__Converted_.jpg]

The Center-Point Circle tool is still the current tool.

•  Click to position the center of the circle.

•  Enter 1 in the D (Diameter) data field but do not press ENTER or RETURN.

•  Click in the X data field of the Status Line and place the text cursor at the end of the existing entry.

•  Type –.06 after the value in the X data field (don’t forget the minus, since you are creating an equation from the existing X value) and press ENTER or RETURN.

Tech Note: The cursor must be at the end of the existing entry. Otherwise the circle will not be located properly.
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The circle is drawn with a diameter of 1 inch and its center is offset by –.06 inches.

Tip: The center can be drawn just by clicking the center and entering a value for the diameter.

3.     Save the work.

Accomplishments

•     Constructing circles

•     Using point offsets

Exercise 6: Making Changes

In this exercise the part being constructed is modified. First, add a cut-out section to the bottom edge, and then change the diameter of one of the holes.
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1.     Add the cutout, beginning at the midpoint of the bottom edge and extending to the –55° construction line.

•  Select the Connected Lines tool.

•  Click at the midpoint of the bottom line of the part.
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•  Move the pointer to the arc to display the center point of the arc.

•  Move the pointer along the –55° line until the intersect point of the center point and the –55° line appears.
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•  Click.

•  Move the pointer to the intersect point of the –55° construction line and the bottom line of the drawing.
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•  Double-click.
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The lines are drawn and remain selected. They must be selected to perform the next step.

•  Select the Simple Trim tool from the Trim Tools palette of from the context menu.

[image: 11-1-idle.bmp]

The Message Line reads, Simple Trim: Pick section to trim [Shift = Select boundary, Ctrl = Relimit (Windows) or Option = Relimit (Macintosh)].

•  Position the Trim pointer dot over the line segment to be discarded.

Tech Note: In order to use the Simple Trim tool, first select the lines that define the boundaries of the geometry to trim away, not the line to trim. In this case the lines are already selected.

•     
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•  Click.

The line segment trims.

2.     Delete the construction lines since they are no longer needed.

•  Choose Layout>Delete Constructions.

The visible horizontal, vertical and –55° construction lines created in this tutorial are removed. The Drafting Assistant’s dynamic, on-the-fly construction lines continue to display when the pointer of an appropriate tool is moved near geometry.

3.     Change the diameter of the hole on the right to .75 inch.

Tip: Press ESC twice at any time to change to the Selection tool.

•  Click the Selection tool. The Message Line reads, Select: Select [Shift = Extend, Ctrl = Copy (Windows) or Option = Copy (Macintosh)].

[image: 1-1-idle.bmp]

 

•  Click the smaller circle.

•  Choose Edit>Edit Objects or right click and choose the Edit Objects option from the context menu.

•  Click the word diameter in the Edit Objects dialog box.

•  Type .75 and press ENTER or RETURN.

Tech Note: If only one change is made, press ENTER or RETURN; otherwise, make all the changes, then click the Apply button.

[image: 24.3.jpg]

The original circle is redrawn with a .75-inch diameter.

•  Click the Close button on the Edit Objects dialog box.

4.     Change the Weight and Color of the lines.

•  Double-click the Selection tool.

Everything in the drawing is selected.

•  Choose Pen>Weight or right click and choose the weight option from the context menu.

Tip: The arrow beside the Weight command in the menu indicates a submenu.

•  Choose 0.016 for the pen weight.
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All lines are changed to a medium pen weight.

•  Choose Pen>Color>Green or right click and choose the Color option from the context menu and Green from the Color drop down menu.

Tech Note: The selected lines don’t change to green until they are deselected.

•  Click in the drawing area where there is no geometry, deselecting the lines to see the new color.

The lines in the drawing are displayed in green.

5.     Save the work.

Accomplishments

•     Trimming

•     Deleting construction geometry

•     Editing geometry with the Edit Objects command

•     Selecting all objects

•     Changing the pen weight

•     Changing the pen color

Exercise 7: Dimensions

In this exercise dimensions are added to the drawing.
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Tech Note: Dimensions automatically go on the Dimension layer rather than on the work layer. This is a unique feature of dimensions and the Dimension layer. If the Dimension layer is removed, create a new one to complete this exercise. If the Dimension layer is hidden, then the dimensions will be placed on the current work layer.

1.     Dimension the horizontal length of the 45° line.

•  Choose .Dimension palette from the main tool palette.

[image: 100001.jpg]

Tip: Since the layers are transparent, the geometry and dimensions are displayed on both layers at the same time.

•  Select the Horizontal Dimension tool. The Message Line reads, Horizontal: Pick first dimension point.

[image: 9-2-1-idle.bmp]

•  Select the left end of the line to be dimensioned by clicking the lower endpoint of the 45° line.
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The hot spot on the pointer moves to the right.

Tech Note: Take a moment to examine the pointer that appears. The dot on one leg of the pointer marks the hot spot for the performed action.
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The location of the dot indicates which side of the object to select. The dot changes positions as the dimensioning tool is used. This type of pointer is a smart pointer because it gives important information in a multistep process. Many of Graphite’s tools use the smart pointer.

•  Click the upper endpoint of the 45° line.
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The dimension appears, but the text is in a location that may be changed.

•  Move the pointer to the dimension text to display the 4-way Move symbol.
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•  Drag the text to the left horizontally until it is about .5 inch from the left leg of the dimension.
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The dimension text is repositioned.

2.     Dimension the vertical line on the left.

•  Select the Vertical Dimension tool. The Message Line reads, Vertical: Pick first dimension point.
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•  Click the lowest point of the chamfered corner.
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•  Click the upper endpoint of the vertical line.

[image: Chapter_03.Graphite00013.jpg]

Tech Note: The order of the selection determines the placement of the dimension text. Selecting in the order shown on the smart pointer, the text appears above horizontally dimensioned geometry or to the right of vertically dimensioned geometry. Selecting in the opposite order, the text appears below or to the left of the selected geometry.

The dimension appears. Add tolerances at this point.

•  Choose Dimension>Linear and select yyy/xxx (limits).

[image: Chapter_03.Graphite00014.jpg]

A new group of Status Line data fields appears at the bottom of the screen.

•  Click Upper in the Status Line.

[image: 28-2-E.jpg]

 By clicking on the name, the data field automatically highlights, ready for new data to be entered.

•  Type .003 and press ENTER or RETURN.

The dimension now reflects a .003 upper tolerance and –.001 lower tolerance.

3.     Dimension the angle of the cutout.

•  Select the Angular Dimension tool. The Message Line reads, Angular: Select Line.

[image: 9-10-idle.bmp]

•  Click the arms of the cutout, near the lower (outer) ends of the lines.

[image: Chapter_03.Graphite00015.jpg]

Tech Note: The placement of the angular dimension is controlled by which side of the mid-point is selected on each of the lines. There are four possible combinations.

The angle is measured from the endpoint nearest to the clicked location.

[image: 07_Angle_dimension-a.jpg]

4.     Add a radial dimension to the fillet.

•  Select the Radial Arrow Out Dimension tool. The Message Line reads, Radial Arrow Out: Select arc/circle.

[image: 9-6-idle.bmp]

•  Choose Dimension>Linear and select xxx from the submenu to return to dimensions without tolerance.

•  Click outside (but near) the filleted corner. Make sure the on notation appears on the arc.

[image: 07_Part_with_dimensions-a__Converted_00001.jpg]

[image: Chapter_03.Graphite00016.jpg]

The radial dimension appears on the side of the arc where you clicked.

Tip: Radial dimensions are created with a single click of the mouse. The text appears on the side of the arc that is clicked.

•  Choose Dimension>Hide Palette.

The Dimension tool palette disappears.

5.     Remove the angular dimension.

•  Click the Selection tool.

•  Click the text portion of the angular dimension.

•  Press the DELETE key. The angular dimension deletes.

6.     Save this part with a different name (part1a), to be able to use it later for an advanced exercise.

•  Choose File>Save As.

   The Save File dialog box appears with part1.vc6 listed in the Filename box.

•  Click after the 1 of part1 in the data field.

•  Type a and press ENTER or RETURN. The part saves with the new name, part1a.

Accomplishments

•     Adding dimensions

•     Moving dimension text

•     Adding tolerances

•     Saving a version of a part with a different name

Exercise 8: Crosshatching

Crosshatching can be added with the part fully drawn and dimensioned.

1.     Select the boundaries that define the area to be crosshatched.

•  Double-click the Selection tool.

All geometry is selected.

Tech Note: Graphite automatically excludes dimensions from the crosshatching process.

2.     Crosshatch the part, indicating Steel.

Choose Pen>Crosshatch.

•  Click on the radio button for ISO crosshatching.

•  Select Steel from the list of patterns. The display box shows the crosshatching exactly as it appears in the part.

•  Click Apply.

[image: 31-1-E.jpg]

The part is crosshatched.

Tip: Choose Pen>Hatch to apply the current crosshatch pattern to the selected area.

•  Close the dialog box.

•  Click anywhere in the drawing area to deselect the part.

3.     Save the part once again as part1.

•  Choose File>Save As. The filename listed is part1.vc6.

•  Click after the a in the data field.

•  Press the BACKSPACE (Windows) or DELETE (Macintosh) key once to remove the a and press ENTER or RETURN.

Since two documents can not be saved with the same name in the same directory, the dialogue box asks if you want to overwrite the existing file named part1.vc6.

•  Click OK. The original version of part1.vc6 is replaced with this crosshatched version.

Accomplishments

•     Crosshatching a part

•     Saving and replacing an existing version

•     Renaming a file

Exercise 9: Stretching

In this exercise you will change the basic outline of the part and see how the crosshatching automatically redraws to accommodate the change.

[image: Chapter_03.Graphite00017.jpg]

1.     Drag a selection fence around the point where the left point of the cutout joins the horizontal line.

•  Click the Selection tool.

•  If any part of the drawing is selected, click anywhere in the drawing area to deselect the part.

•  Position the pointer above and to the left of the point.

•  Drag to a location below and to the right of the point.

Tech Note: To drag, press and hold down the mouse button, drag the mouse to the desired location and release the button.

[image: 33-2.jpg]

The point is selected, as shown below. If the square selection point isn’t visible, choose Edit>Selectable Points and select again.

[image: 33-3.jpg]

2.     Stretch the part so that the left side of the cutout is horizontal.

Tech Note: You can also use the Stretch tool found in the Transformation Tools palette or in the context menu. Before using the Stretch tool, the entire object must be selected. Follow the instructions of the Message line to stretch the object correctly.

•  Move the pointer to the selected point until the pointer displays the 4-way Move symbol. [image: 33-4.jpg]

•  Drag the point upward to the top of the –55° line, so that the vertical construction line appears. Do not release the mouse button.

[image: Chapter_03.Graphite00018.jpg]

Tech Note: Moving the pointer over this endpoint activates it so that the Drafting Assistant’s construction line passes through it.

•  With the mouse button still pressed, drag downward to the intersect point of the Drafting Assistant's construction lines as shown below.

[image: Chapter_03.Graphite00019.jpg]

The part is redrawn and the crosshatching is updated, once the mouse button is released.

[image: Chapter_03.Graphite00020.jpg]

3.     Save the work.

Accomplishments

•     Selecting a point

•     Using a selection fence

•     Activating a point

•     Stretching a part

Exercise 10: Rotating

Now that the part is complete, rotate it so that the left line of the newly created cutout is horizontal.

[image: 35-1-L.FH7.jpg]

1.     Specify the rotation.

•  If the part is not selected, double-click the Selection tool.

•  In the Transformation subpalette or from the right click context menu, select the Rotate tool.

[image: 100002.jpg]

The Message Line reads, Rotate: Pick center of rotation [Shift = Select, Ctrl = Copy (Windows) or Option = Copy (Macintosh)].

•  Specify the pivot point (the center of rotation) by clicking the lower endpoint of the left side of the cutout.

[image: 35-3-E.jpg]

•  Specify the beginning reference point (the point that is to move) by clicking at the control point moved in the last exercise.            

[image: 36-1-L.FH7.jpg]

•  Specify the ending reference point by clicking on the horizontal construction line across the bottom of the part.

[image: 36-2-L.FH7.jpg]

The part rotates.

[image: 36-3-L.FH7.jpg]

Tech Note: Notice that the dimensions changed to reflect the new orientation; this is an example of associativity. Graphite maintains an extensive database describing all geometry so that dimensions and locations can be updated quickly.

2.     Reduce the visual display of the part.

•  Select the Zoom Out tool to display the entire part on the

[image: 13-2-idle.bmp]

screen.

Tech Note: Zooming does not change the actual measurements of the part.

The Message Line reads, Zoom Out: Pick area to zoom [Ctrl = Zoom In (Windows) or Option = Zoom In (Macintosh)]. The Scale data field in the Status Line displays the current scale.

Tech Note: To zoom out, click in the location you want to magnify and scroll forward the mouse scroll wheel or double click the scroll wheel to zoom all.

•  Click a location near the larger hole.

The magnification of the part decreases and the location you clicked is in the center of the screen.

3.     Save the work.

Accomplishments

•     Rotating a part

•     Observing associative dimensions

•     Zooming out to a specific location

Exercise 11: Printing the Drawing

For the drawing to be useful, transfer it to paper. If the drawing extends past the boundaries of the paper being used, scale it before printing.

1.     Specify the page orientation and paper size.

•  Choose File>Print Setup.

•  If necessary, specify Portrait orientation.

[image: 18-34.jpg]

•  For plotter, specify the appropriate paper size.

•  Click OK.

2.     Specify the exact area to be printed.

•  Select Layout>Drawing Size.

•  Click Always Display Page Bounds to display the gray box representing the maximum plotable area of the page.

[image: 38-2-E.jpg]

Tech Note: The page outline appears in the drawing area at all times if the Always Display Page Bounds option is on. When this option is off, the page outline appears only when the Drawing Size dialog box is open or when File>Preview Layout is selected.

Tech Note: The drawing may not look like the right graphic because a different printer, plotter, or paper size may have been specified.

•  Click Keep Text Size.

•  Click Keep Dimension Text Size.

•  Click Fit.

[image: 39-1-E.jpg]

This roughly centers the drawing on the page and scales it to fit.

•  Since the scale will be a non-standard value, select the nearest standard size.

•  Use the pan hand to position the page around the object.

•  Click Apply.

The drawing border is scaled and redrawn so that the part fits on the paper size with the orientation specified in Print Setup.

•  Click OK to close the dialog box.

3.     Print the drawing.

•  Choose File>Print.

The drawing is sent to the printer or plotter.

4.     Close the document.

•  Choose File>Close.

The dialogue box asks if you want to save.

•  Click OK.

The document closes.

Accomplishments

•     Displaying the paper size in the drawing area

•     Scaling the drawing

•     Printing the drawing




Additional Features

In this section some of the more advanced Graphite features are introduced. While many features are demonstrated, look through the User Guide chapters for other features which might be useful. In some cases, the exercises do not create a useful part but only show how to use a feature, such as how to trim two lines to make a corner or how to construct a line tangent to a circle. In other cases real parts are created, such as the front and side view of a flange.

[image: 3-1.jpg]

The features covered in this section include:

•     Corner Trim

•     Trim

•     Relimit

•     Text

•     Tangent Lines

•     Perpendicular Lines

•     Origin (0,0)

•     Circle Fillets

•     Polar Duplicate

•     Polygon

•     Parallel Lines

•     Mirror Transformation

•     Bolt Circle

•     Parametrics

•     Splines

•     Smart Walls

Exercise 1: Trimming and Relimiting

In this exercise investigate some advanced construction techniques. Graphite creates corners and trims or relimits lines. When trimming a line it shortens to its intersection with the selected boundary. Relimiting extends or shortens a line to the limiting boundary.

1.     Open a new Graphite document.

•  Choose File>New.

2.     Explore the Simple Trim tool.

•  Create an approximation of the lines here.

[image: Chapter_04.Graphite00001.jpg]

Tip: The exact figure is not important. Learning about how the Trim and Relimit tools function is the objective.

•  Hold down the SHIFT key and select the two lines that appear bold in the graphic.

•  Select the Simple Trim tool from the Trim Tools palette or from the right click context menu. The Message Line reads, Simple Trim: Pick section to trim [Shift = Select boundary, Ctrl = Relimit (Windows) or Option = Relimit (Macintosh)].

[image: 11-1-idle.bmp]

•  Click the locations indicated here.

[image: Chapter_04.Graphite00002.jpg]

Tech Note: When trimming an entire entity, a prompt appears asking if you want to delete the entire item. Graphite is making sure you want to remove that piece of geometry before it performs the trim.

The lines are trimmed.

[image: Chapter_04.Graphite00003.jpg]

3.     Explore the Relimit tool.

Tech Note: For Trim, select what to throw away. For Relimit, select what to keep and it will be trimmed or extended to hit the highlighted boundary.

•  Select Edit>Undo or click CTRL+Z four times so that the lines are restored.

•  Select the Relimit tool from the Trim Tools palette or from the right click context menu. The Message Line reads, Relimit: Pick section to retain [Shift = boundary, Ctrl = Trim (Windows) or Option = Trim (Macintosh)].

[image: 11-2-idle.bmp]

•  Click the same locations with the Relimit tool.

[image: Chapter_04.Graphite00004.jpg]

The lines are extended to the boundaries.

4.     Explore the Corner Trim tool.

•  Create an approximation of the lines below.

[image: 6-3.jpg]

Tech Note: Use Undo and Redo to go back to a previous version to correct mistakes.

•  Select the Corner Trim tool from the Trim subpalette.

[image: 1.jpg]

The Message Line reads, Corner Trim: Pick first entity to trim [Shift = Corner, Ctrl = No Trim (Windows) or Option = No Trim (Macintosh)].

•  Hold down the SHIFT key and click inside the top corners as shown in the following graphic.

[image: Chapter_04.Graphite00005.jpg]

Tip: Either click each line individually or use SHIFT-Click, and click inside the corners.

The lines are trimmed to create corners.

[image: 7-2.jpg]

•  Select the Simple Trim tool from the Trim Tools palette or from the right click context menu.

[image: 11-1-idle00001.bmp]

•  Double-click the Selection tool to select all lines.

•  Click the parts of the lines to be trimmed away (those that extend past the corners) to create the figure below.

[image: 7-4.jpg]

5.     Delete all geometry.

•  Choose Edit>Select All or doudle click the scroll wheel to zoom all.

•  Press the BACKSPACE (Windows) or DELETE (Macintosh) key.

Accomplishments

•     Using the Corner Trim tool

•     Observing the difference between trim and relimit

•     Deleting geometry

Exercise 2: Text

This exercise explores using text.

1.     Create a text block.

•  Choose the Text tool.

[image: 8-1-idle.bmp]

•  Drag a box in the center of the screen. The size isn’t important.

[image: 01_Drag_a_text_box.jpg]

•  Click the Width Status Line data field.

•  Type 3 and press ENTER (Windows) or RETURN (Macintosh).

[image: 02_Type_3_and.jpg]

2.     Change the text characteristics to 10-point Arial.

•  Choose Text>Font>Arial.

•  Choose Text>Size>10.

Tip: Instead of 10-point Arial use any font listed in Text>Font.

3.     Type this text: Submitted by: Ashlar-Vellum. 

•  Press ENTER (Windows) or RETURN (Macintosh).

[image: 03_Submitted_by_Ashlar__Inc.jpg]

Tip: After leaving the Text tool, change the size of the text-entry box by dragging a selection fence around the control points on the right or left side of the box and dragging the points.Draw a box around the text.

Tech Note: Control points are the points defined when the text block is first created and represent the endpoints of the text box.

•  Select the Rectangle tool.

[image: 6-1-idle.bmp]



The text entry box disappears.

Tech Note: The text box appears only when the text is selected. The box being drawn now will always be visible.

•  Drag a box around the text so that the text is centered within the box.

[image: 04_drag_a_box_around_the_type.jpg]

4.     Group the box and the text so that they can be treated as a single unit.

Tech Note: When several entities need to act as one, group them. In that way one won’t be accidentally selected when the components of the group are meant to be selected.

•  Double-click the Selection tool.

•  Choose Arrange>Group or right click and choose the Group option from the context menu.

•  Drag the box around to see that the text and the box act as a single entity.

5.     Type a list of notes.

•  Create another text box 2.5 inches wide.

•  Change the text characteristics to accommodate a plotter:



	
Font:


	
Plotter





	
Size: 


	
.156





	
Style:


	
Normal






•  Type the following without pressing ENTER (Windows) or RETURN (Macintosh).

1. The materials list is included on a separate sheet.

[image: 05_The_materials_list.jpg]



•  Press ENTER (Windows) or RETURN (Macintosh) to begin a new line.

•  Type the following:

2. Tolerances are specified as noted.

[image: 06_Tolerences_are_specified.jpg]



Use the BACKSPACE (Windows) or the DELETE (Macintosh) key to make corrections. Also, notice the word wrap. The text automatically wraps to the next line when a word extends past the right margin.

6.     Change the indentation so that the text aligns under itself rather than under the number.

•  Use the Selection tool to select the note text.

•  Choose Text>Indentation. The Indentation dialog box appears.

[image: 100001.jpg]

•  Click the Left Indent data field to highlight it.

•  Type .35.

•  Click OK.

[image: 07_Indent_the_text.jpg]

The text shows a hanging indent.

7.     Make changes to the text.

•  With the text still selected, click the Text tool.

•  Double-click the word, materials.

The word, materials and the space after it are highlighted.

•  Type specifications and press the SPACEBAR once.

[image: 08_change_Materials_to_Spec.jpg]

•  Click after the period that ends the second sentence.

•  Press the BACKSPACE (Windows) or the DELETE (Macintosh) key.

The period deletes.

•  Press the SPACEBAR once and type the following:         

—see attached sheet.

[image: 09_add__see_attached_sheet.jpg]

8.     Change the size of the text box.

•  Click the Selection tool.

•  Drag a selection fence around the right side of the text box.

[image: 10_select_right_side_of_text.jpg]

The upper and lower corner points of the box are selected.

[image: 11_right-side_selected.jpg]

•  Drag the control points about one inch to the right.

[image: 12_drag_a_handle_to_the_right.jpg]

The area resizes and the text is redraws.

[image: 13_the_text_is_reflowed.jpg]

9.     Explore the text processing functions to become comfortable with the tools, then delete all the text created in this exercise.

•  Choose Edit>Select All.

•  Press the BACKSPACE (Windows) or the DELETE (Macintosh) key to delete all selections.

Accomplishments

•     Entering text

•     Changing text characteristics

•     Grouping entities

•     Specifying a hanging indent

•     Making changes to text

•     Changing the size of the text area

Exercise 3: Tangent and Perpendicular Lines

This exercise explores drawing tangent and perpendicular lines.

[image: Chapter_04.Graphite00006.jpg]

1.     Draw two circles like those shown here using a circle tool.

[image: 13-2.jpg]

2.     Construct a line tangent to the lower edges of both circles.

•  Click the Single Line tool. The Message Line reads, Single Line: Pick beginning point [Ctrl = Copy previous (Windows) or Option = Copy Previous (Macintosh)].

[image: 2-1-idle.bmp]

•  Move the pointer to the circle on the left until the on notation appears.

[image: Chapter_04.Graphite00007.jpg]

Tech Note: The Drafting Assistant must display on and not other circle notations such as quadrant.

•  Drag the pointer away from the circle at approximately a 45° angle until the tangent notation appears as shown in the following graphic. Do not release the mouse button.

[image: Chapter_04.Graphite00008.jpg]

•  Drag the pointer to the lower edge of the large circle until the tangent notation appears.

[image: Chapter_04.Graphite00009.jpg]

Tip: Notice that the dragged line stays tangent to the circle wherever it is dragged.

•  Release the mouse button.

The tangent line is drawn.

[image: 14-3.jpg]

3.     Construct a line perpendicular to both circles.

•  Press the mouse button when on appears on the large circle.

•  Drag directly away from the circle at approximately a 90° angle until the perpendicular notation appears.

[image: Chapter_04.Graphite00010.jpg]

•  Drag to the left circle until the perpendicular notation appears.

[image: 15-2-E.jpg]

Tip: Tangent and perpendicular lines can be pulled off circles and other lines, as well as ellipses, splines and arcs.

•  Release the mouse button.

[image: 15-3.jpg]



The line is drawn perpendicular to both circles.

4.     Construct a line perpendicular to the lower straight line and tangent to the larger circle.

•  Move the pointer to the lower straight line and press the mouse button when on notation appears.

•  Drag at a 90° angle from the line to display the perpendicular notation. Do not release the mouse button.

[image: Chapter_04.Graphite00011.jpg]

•  Drag the new line along the lower straight line to the large circle until tangent appears.

[image: Chapter_04.Graphite00012.jpg]

The line is drawn tangent to the large circle and perpendicular to the lower straight line.

5.     Save the file.

Accomplishments

•     Constructing tangent lines

•     Constructing perpendicular lines

Exercise 4: Rotational Copy

The next four exercises construct a flange with a side view.

[image: 3-100001.jpg]

For this exercise, draw a flange 3 inches in diameter containing four 1-inch lugs each with 0.5-inch holes. Center a 0.5-inch octagonal hole in the .75-inch hub of the flange.

1.     Open a new document.

2.     Choose a different pen style.

•  Choose Pen>Style>Visible or right click to show the context menu and choose Style option and then Visible from the drop down menu.

The pen style is now solid, black lines .02 inches wide.

3.     Draw a 3-inch circle centered at 0,0.

•  Choose Layout>Show Grid or CTRL+G to see the origin.

Tech Note: This step is not necessary. It merely shows the grid and origin point. When the grid is on drawn lines, snap to the divisions on the grid.

The grid appears on the drawing area.

[image: Chapter_04.Graphite00013.jpg]

•  Choose the Center-Point Circle tool.

•  Type 3 in the Status Line and press the TAB key.

•  Type 0 and press TAB.

•  Type 0 and press ENTER (Windows) or RETURN (Macintosh).

   The 3-inch circle is drawn, centered at 0,0.

•  Choose Layout>Hide Grid or CTRL+G.

The grid and coordinate symbol disappear.

4.     Draw a 0.5-inch lug hole centered at the top of the 3-inch circle.

The Center-Point Circle tool is still the current tool.

•  Click on the 12 o’clock quadrant notation.

[image: Chapter_04.Graphite00014.jpg]

•  Type 0.5 in the Status Line and press ENTER (Windows) or RETURN (Macintosh).

A 0.5-inch circle is drawn, centered on the top of the 3-inch circle.

5.     Draw a 1-inch circle with the same center as the .5-inch circle.

•  Type 1.0 and press ENTER (Windows) or RETURN (Macintosh).

Another circle is drawn, centered at the same place and with a diameter of 1 inch.

[image: 18-2.FH7.jpg]

6.     Create fillets with the default .25-inch radius where the lug joins the flange.

Tech Note: The Fillet tool is designed to trim lines, arcs and splines, but not circles as time saving measure.

•  Click the 2-Entity Fillet tool.

[image: 10-1-idle.bmp]

•  Hold down the SHIFT key and click between the two curves, as shown by the x in the graphic below.

[image: 18-4.jpg]

•  Repeat the process on the other side of the lug.

[image: 19-1.jpg]

Tech Note: Tangent and perpendicular lines can be pulled off circles and other lines as well as ellipses, splines and arcs.

The fillets are complete.

7.     Trim the lug.

•  Click the Selection tool.

The last fillet created is still selected.

•  Hold down the SHIFT key and click the other (unselected) fillet.

Both fillets are selected to be used as the boundaries for trimming.

•  Click the Simple Trim tool in the Trim Tools palette or in the right click context menu.

[image: 11-1-idle00002.bmp]

•  Click the bottom of the 1-inch circle and the top of the 3-inch circle.

[image: Chapter_04.Graphite00015.jpg]

The circles are trimmed between the fillets.

[image: 19-4.jpg]

8.     Construct a total of four lugs for the flange.

•  Click the Selection tool.

•  Drag a fence around all entities that make up the lug.

[image: 20-1.jpg]

Tech Note: Only the objects inside the fence are selected.

The lug is selected.

•  Choose Edit>Polar Duplicate from the menu or select the icon from the tool palette or from the right click context menu.

[image: 12-6-idle.bmp]

 

The dialog box should be set to rotate 4 objects, with the Center X, Y coordinates set at 0,0.

[image: 28.01.png]

Tech Note: The asterisks next to the Center X and Center Y data fields indicate that a coordinate may be typed in the field or the locations specified with the mouse. To use the mouse, first click the Center X data field. Then click the location for the center on the drawing area.

Tech Note: For this exercise, the default location is 0,0 so don’t enter any entries in this data field.

•  Click OK.

[image: 20-3.jpg]

The lug is copied, but the 3-inch circle must be trimmed.

9.     Trim the circle inside the copied lugs.

•  Use the Selection tool and the SHIFT key to select the fillets for the three copied lugs.

Tech Note: To deselect something, continue holding down the SHIFT key and click again.

•  Choose the Simple Trim tool from the Trim Tools palette or from the right click context menu and trim the circle between the fillets.

[image: 20-4.jpg]

 

The lugs are complete.

10. Construct a .75-inch circle in the center of the flange.

•  Select the Center-Point Circle tool.

•  Move the pointer to display the horizontal construction line through the left bolt hole.

[image: Chapter_04.Graphite00016.jpg]

•  Display the vertical construction line for the lower bolt hole and click at the intersection of these two construction lines.

[image: Chapter_04.Graphite00017.jpg]

•  Type .75 and press ENTER (Windows) or RETURN (Macintosh).

11. Add the .5-inch (outside measurement) octagonal hole within the .75-inch hub.

•  Select the Inscribed Polygon tool. The Message Line reads, Inscribed Polygon: Pick center of polygon [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].

[image: 100002.jpg]

Confirm that the Status Line shows the X,Y coordinates as 0,0. If this is not the case, enter 0 into each of these data fields.

•  Type .5 in the Diameter data field (do not press ENTER or RETURN).

•  Press the TAB key to select the Sides data field.

•  Type 8 and press ENTER (Windows) or RETURN (Macintosh).

The octagonal hole is drawn and

[image: 21-4.jpg]

the flange is complete.

12. Save the part, naming it flange.

•  Choose File>Save.

•  Type flange and press ENTER (Windows) or RETURN (Macintosh).

Accomplishments

•     Displaying the grid

•     Placing geometry at the origin

•     Filleting circles

•     Making multiple selections

•     Trimming unnecessary geometry

•     Rotating and copying the lug

•     Constructing an inscribed octagon

Exercise 5: Constructing a Side View

Create a side view of the flange that is 1.5 inches thick at the hub and .25 inch thick at the lugs.

[image: 23-1.jpg]

1.     Zoom out from the part.

•  Click the Zoom Out tool or scroll the scroll mouse wheel forward.

[image: 13-2-idle.bmp]

•  Enter .80 in the Status Line.

2.     Construct a vertical line for the side view that is the same length as the distance from the top of the flange to the center.

•  Click the Single Line tool.

•  Move the pointer to the top of the flange to display the construction line and move to the right the approximate distance shown below. Click on the construction line.

[image: Chapter_04.Graphite00018.jpg]

•  Move the pointer to the center of the right bolt hole to “awaken” it, then move to the right to display the horizontal construction line. Click at the intersect point of the horizontal and vertical construction lines.

[image: Chapter_04.Graphite00019.jpg]

The first vertical line for the side view is drawn.

[image: The_first_vertical_line__Converted_.jpg]

3.     Construct the remaining vertical lines of the side view.

•  Click the       Parallel Lines tool. The Message Line reads, Parallel Lines: Drag new line off existing line.

[image: 2-5-idle.bmp]

•  Drag a line to the right of the vertical line in the side view.

•  Type 1.25 and press ENTER (Windows) or RETURN (Macintosh).

The parallel line is drawn 1.25 inches to the right of the original line.

•  Click the original vertical line.

•  Type 1.5 and press ENTER (Windows) or RETURN (Macintosh).

[image: 24-4.jpg]

The vertical lines are complete.

4.     Construct the horizontal lines for the side view.

•  Select the Single Line tool.

•  Draw a horizontal line across the top of the right arm of the side view.

[image: 25-1.jpg]

•  Continue drawing the horizontal lines aligned with these locations and in the order shown below:

[image: 25-2.jpg]



Top of bolt hole

Bottom of bolt hole

Top of hub

Top of octagon

Center of flange

The lines are drawn and the centerline is selected. If it is not, use the Selection tool to select the line from the center of the flange to the side view.

•  Choose Pen>Style>Center or right click to show the context menu and click Style option, then choose Center from the drop down menu.

[image: 25-3.jpg]

•  Choose the Selection tool.

Tip: Use the Stroke commands to zoom. Hold down CTRL+SHIFT keys (Windows) or the z key (Macintosh) and Stroke zoom, drag from the upper left to the lower right across the side view to zoom in. Alternatively select the Zoom In tool and drag a fence around the side view. Also it is possible to scroll backward the mouse scroll wheel to enlarge the view.

Tech Note: If zooming takes you places you didn’t want to go, choose Arrange>Zoom All or double click the mouse scroll wheel and all geometry appears, filling the window.

•  Click outside the flange to deselect everything.

•  Choose Pen>Style>Visible or right click to show the context menu and click Style option, then choose Visible from the drop down menu.

5.     Trim the excess lines.

•  Save the drawing in case things don’t go as expected.

•  Zoom in on the side view only.

•  Select the trim boundary.

[image: Chapter_04.Graphite00020.jpg]

•  Trim the vertical line on the left that extends above the selected horizontal line.

[image: 26-2.jpg]

The vertical line trims.

•  Trim the vertical line that descends from the inside corner to the centerline

[image: 26-3.jpg]

.

The trimming is complete.

•  When the drawing looks right, save it again.

Tech Note: If you have had trouble, and the drawing is not right, close this document without saving it. To close without saving, click the Close box icon, then click No when asked if you want to save. Next, choose File>Open and open the flange document again, and repeat Exercise 5

6.     Create the hub fillet with a radius of .75 inch.

•  Select the 2-Entity Fillet tool.

•  Enter .75 in the Radius data field.

•  Hold the SHIFT key down and click inside of the corner of the side view.

The fillet is redrawn to a .75-inch radius.

[image: 26-4.jpg]

•  Zoom out to see the entire flange.

Accomplishments

•     Constructing a side view

•     Creating parallel lines

•     Creating a centerline

•     Trimming corners

Exercise 6: Advanced Crosshatching

In this exercise crosshatch the side view. Since the side view isn’t a single closed figure, segment some of the lines for the crosshatching to work properly.

[image: 27-1.jpg]

1.     Zoom in on the side view.

•  Scroll backward the mouse scroll wheel.

2.     Select all geometry for the side view by dragging a selection fence around the side view.

3.     Use the Segment tool to break the vertical lines at the intersection of the horizontal lines. This is necessary to define a closed boundary to crosshatch.

Tip: Use the Tracer tool to select these unsegmented boundaries. Practice both methods of selecting lines.

•  In the Trim palette or in the right click context menu, choose the Segment tool. The Message Line reads, Segment: Pick entity [Shift = Select boundary, Ctrl = Current pen (Windows) or Option = Current pen (Macintosh)].

[image: 11-3-idle.bmp]

•  Click the vertical lines to be segmented.

[image: Chapter_04.Graphite00021.jpg]

Tech Note: To understand this process, consider how to create the side view. The right vertical line is a single line which is met by the horizontal lines forming the bolt hole and center hole. Graphite cannot determine the boundary because the horizontal lines touch the vertical lines within the closed figure. In this exercise, segment the boundary lines so they can be selected to form two closed shapes.

•  Click the lines representing the center hole.

[image: Chapter_04.Graphite00022.jpg]

 

Tech Note: Although no visable change has occurred, the vertical lines have been segmented into shorter, connected lines.

4.     Crosshatch the solid sections of the side view.

•  Click the Selection tool.

•  Click anywhere in the drawing area to deselect the side view.

•  Drag a selection fence around the top part of the side view

[image: 28-1.jpg]

.

•  Hold down the SHIFT key and drag a selection fence around the lower solid section of the side view.

[image: 28-2.jpg]

Both sections are selected.

•  Choose Pen>Crosshatch.

•  If the ISO patterns are not already displayed, click the ISO radio button.

The Iron pattern is already selected and displayed in the pattern box.

•  Click the Spacing data field.

•  Enter .1 and click Apply.

•  Close the dialog box.

[image: 28-3.jpg]

The side view is crosshatched.

5.     Save the part.

Accomplishments

•     Segmenting lines

•     Crosshatching complex figures

Exercise 7: Mirror Images and Bolt Circles

This exercise demonstrates how to create the bottom half of the side view and add a bolt circle to the front view of the flange.

1.     Create the bottom half of the side view.

•  Drag a selection fence around the entire side view.

•  Select the Mirror tool in the twelfth sub palette of the main tool palette or in the right click context menu. The Message Line reads, Mirror: Pick beginning of reference line [Shift = Select, Ctrl = Copy (Windows) or Option = Copy (Macintosh)].

[image: 12-4-idle.bmp]

You are asked to specify a reference line.

•  Hold down the CTRL (Windows) or the OPTION (Macintosh) key and click on the centerline at two places in the side view.

[image: 3-100002.jpg]

Tech Note: CTRL (Windows) or OPTION (Macintosh) plus click causes the transformation tool make a copy and transform the geometry.

Tech Note: Crosshatch patterns are mirrored in shape but the pattern orientation remains the same. To change orientation on cross hatching use Edit Objects.

The side view is complete.

2.     Add a bolt circle to the front view.

•  Select the Selection tool and click anywhere to deselect the side view.

•  Choose Pen>Style>Center or right click to show the context menu and click Style, then choose Center from the drop down menu.

•  Select the Center-Point Circle tool.

•  Drag from the center of the flange to the center of one of the four bolt holes.

[image: Chapter_04.Graphite00023.jpg]

•  Use the Selection tool and click in the drawing area to deselect the circle.

•  Choose Pen>Style>Visible or right click to show the context menu and click Style, then choose Visible from the drop down menu.

3.     Save the part and close the document.

•  Close the current Graphite window.

You are asked if you want to save the document.

•  Click Yes.

The document saves and its window closes. Other windows may appear if other Graphite documents are open.

Accomplishments

•     Creating a mirror image

•     Creating a bolt circle

Exercise 8: Parametrics

[image: Finished_part_with_dimensions__Converted_.jpg]



This exercise constructs a side view of the part built previously in the Basic Graphite section, using one of Graphite’s most powerful features, Parametrics. With parametrics, construct geometry in the desired shape and then Graphite automatically redraws the geometry with specific measurements.

1.     Begin by opening the part saved earlier.

•  Choose File>Open.

•  Double-click the filename part1a.

   If the file is saved in a different folder or given a different name, select the filename accordingly.

2.     Zoom the drawing to see the part and have room for the new construction.

•  Choose Arrange>Zoom All or double click the scroll wheel of the mouse.

•  In the tool palette, select the Zoom Out tool or scroll forward the mouse scroll wheel.

•  Click anywhere on the left side of the part.

3.     Hide the dimensions created to make it easier to construct the side view. (Note the placement of the dimensions so that the side view is not built on top of them.)

•  Choose Layout>Layers.

•  Select the Dimension layer.

The Show button toggles to Hide.

•  Click Hide.

The dimensions are no longer visible on the drawing.

•  Close the dialog box.

4.     Construct a side view that represents the final shape; don’t be concerned with proportions or measurements.

•  Choose the Pen>Style>Visible or right click to show the context menu and click Style, then choose Visible from the drop down menu.

•  Select the Connected Lines tool.

•  Drag the pointer over the top endpoint of the 45° line to activate the horizontal construction line from the top of the part, but do not click.

The point on the part activates so that the Drafting Assistant displays a dynamic construction line through it to assist in constructing the side view.

•  Move the pointer to the left a short way along the construction and click the first point. Be sure an on notation appears.

[image: 32-1a.FH7.jpg]

•  Drag a line to the bottom endpoint of the chamfer to “awaken” a horizontal construction and drag to the left along the construction line until an intersect notation appears.

[image: 32-1b.FH7.jpg]

•  Create the shape on the left below, approximating the horizontal measurements.

5.     Save the part.

[image: 32-1.jpg]

6.     Dimension the vertical components of the side view, using baseline dimensions.

•  Choose Layout>Layers.

•  Select Dimension and click Show.

The Dimension layer appears.

•  If necessary, choose Dimension>Show Palette.

[image: 9-3-2-idle.bmp]

•  Select the Vertical Base Line Dimension tool. The Message Line reads, Vertical Base Line: Pick first dimension point.

•  Select the top-left corner then the bottom-left corner of the side view.

Tip: In this case, since everything is measured from the baseline, select the baseline first, regardless of the proper order for displaying the dimension. This means that the dimension is not displayed in the proper location, but the dimension can be dragged once it appears.

•  Drag the dimension to the left so that another dimension can be placed between it and the side view, as shown.

[image: Drag_the_dimension_to_the__Converted_.jpg]

Tech Note: In this example, only the vertical dimension displays its real value—it measures the actual height of the part. Specify the values of the other dimensions.

•  Dimension the depth of the notch. Select the bottom of the left side of the notch. (Remember the baseline is already selected.)

•  Drag the dimension text to the left between the view and the last vertical dimension.

•  Enter .25 in the Status Line and press ENTER (Windows) or RETURN (Macintosh).

[image: Enter___Converted_.jpg]

Tip: This entry goes into the Text data field on the Status Line, specifying the value needed rather than the current value.

7.     Dimension the remaining components of the side view.

•  Select the Horizontal Base Line Dimension tool. The Message Line reads, Horizontal Base Line: Pick first dimension point.

Enter the values as shown. By beginning at the left corner, the dimensions will be properly placed.

[image: Dimension_the_remaining__Converted_.jpg]

Tech Note: To correct mistakes, press the BACKSPACE (Windows) or DELETE (Macintosh) key if the dimension is still selected. If it is not selected, select it with the Selection tool and then press the BACKSPACE (Windows) or DELETE (Macintosh) key.

8.     Save the part.

9.     Resolve the parametrics for the side view.

•  Drag a selection fence around the side view, including the dimensions.

[image: Drag_a_selection_marquee__Converted_.jpg]

•  Choose Edit>Resolve. The Resolve dialog box appears.

•  Click the upper-right corner of the side view so that corner stays aligned with the front view.

•  Click OK. The part redraws using the new measurements.

[image: One_eighth_overlaps_other_lines__Converted_.jpg]

10. Move the .125 dimension text to a better location.

•  Deselect everything by clicking in an empty space with the Selection tool.

•  Select the .125 dimension text.

•  Drag the text to the left so that it is outside the extension lines, as shown below.

[image: Finished_part_with_dimensions__Converted_00001.jpg]

11. Save the part.

Accomplishments

•     Using layers

•     Entering specific dimensions

•     Resolving parametrics

Exercise 9: Variable Parametrics

This exercise uses parametrics with variables. Using variables, draw a part and then assign different values for the dimensions. In this way recreate the part repeatedly with different specifications.

[image: 36-1.jpg]

1.     Open a new document.

•  Choose File>New.

A new Graphite document opens.

2.     Draw the triangle here.

[image: 36-2.jpg]

3.     Fillet the upper corner of the triangle.

[image: 36-3.jpg]

4.     Dimension the triangle using variables.

•  If the Dimension tool palette is not visible, choose Dimension>Show Palette.

Tip: If the palette obscures the construction, move it by dragging the title bar.

•  Select the Horizontal Dimension tool. The Message Line reads, Horizontal: Pick first dimension point.

[image: 9-2-1-idle.bmp]

•  Dimension the horizontal line, clicking the right side first.

•  Type X in the Status Line and press ENTER (Windows) or RETURN (Macintosh).

[image: Chapter_04.Graphite00024.jpg]

•  Select the Vertical Dimension tool. The Message Line reads, Vertical: Pick first dimension point.

[image: 9-3-1-idle.bmp]

•  Dimension the left vertical line, clicking the lower endpoint first.

•  Type Y in the Status Line and press ENTER (Windows) or RETURN (Macintosh).

[image: Chapter_04.Graphite00025.jpg]

•  Using the Radial Arrow Out Dimension tool, dimension the radius, using R as the variable.

[image: Chapter_04.Graphite00026.jpg]

5.     Resolve the geometry to specific dimensions.

•  Double-click the Selection tool to select everything.

Tech Note: The next step won’t work if there is extraneous geometry in the document and everything is selected. If that is the case, instead of double-clicking the Selection tool, drag a selection fence around the triangle and its dimensions.

•  Choose Edit>Resolv

[image: Resolve.jpg]

e.

•  Type .5 for R and press the TAB key.

•  Type 5 for X and press the TAB key.

•  Type 2 for Y and click OK.

[image: Chapter_04.Graphite00027.jpg]

The geometry is redrawn to the specified dimensions.

6.     Save the document in the Symbols folder of Graphite.

•  Choose File>Save As.

•  Display the Symbols folder.

•  Type Test in the Filename data field.

•  Click OK.

The document saves as Test in the Symbols folder.

Tip: With the File>Symbol... menu selection any Graphite document can be brought into a current document as a symbol. Files do not have to be saved in the Symbols folder.

7.     Use a symbol.

•  Choose New from the File menu.

A new Graphite document displays.

•  Choose File>Symbol....

•  The Open dialog box appears.

•  Select the symbol file to use and click Open.

•  The Symbol dialog box appears displaying a preview of the currently selected symbol. All symbol files in that directory appear in the symbols list on the left side of the Symbol Panel.

Tech Note: It is possible to use a text file to fill in parametric dimensions of a symbol. Create a text file with value pairings for each variable and its value. Then load the symbol and click on File in the Symbol Panel. The file automatically fills in the values specified for each dimension.

•  Enter a value for each of the parametric dimensions.

•  Specify the location and orientation for the symbol.

•  In the dialog box, a triangle appears on the geometry to indicate the origin or the located point. Upon clicking, the symbol inserts at the click location, in its original orientation.

•  Drag the mouse to indicate the insertion point for the symbol and the direction of the orientation.

•  If a location is not specified, scroll to see the symbol.

•  Click Place.

•  The geometry resolves and appears in the current drawing at the location clicked, sized as specified.

•  The symbol geometry is selected to move it to a new location.

•  Add regular dimensions if desired.

•  To see an enlargement of any part of the symbol within the viewing window, move the pointer to the area of interest and press the mouse button. The enlargement reduces when the mouse button is released.

Tech Note: It is possible to see an enlargement of any portion of the symbol by moving the pointer to the area to be enlarged and pressing the mouse button.

The Symbol box appears with the shape of the selected symbol.

[image: Symbol.jpg]

8.     Save or discard the documents.

Tech Note: If values cannot be used for the resolution, an error message appears. If this happens, choose Symbol again and enter different values.

Accomplishments

•     Dimensioning with variables

•     Resolving parametrics

•     Creating symbol files

•     Using symbols

Exercise 10: NURB Splines

This exercise creates and edits splines and observes the difference between splines constructed through specific points and those constructed from vectors.

[image: 40-1.jpg]

 

1.     Open a new document.

2.     Select the Through-Points Spline tool. The Message Line reads, Through-Points Spline: Pick control point [Double-click last point].

[image: 7-1-idle.bmp]

3.     Click points such as those shown below, double-clicking the

[image: 40-3.jpg]

last point.

A NURB spline is drawn through the control points specified.

[image: 40-4.jpg]

4.     Select the Vector Spline tool. The Message Line reads, Vector Spline: Pick control point [Double-click last point].

[image: 7-2-idle.bmp]

5.     Click the same points (the vertex notation appears at the points clicked for the first spline). A different curve is constructed using the vectors for calculation.

[image: 40-6.jpg]

6.     Edit the control point in the middle of the original spline.

•  Select the original spline.

•  Choose Layout>Show Points or right click to show the context menu and choose Show Points option.

The control points and the endpoint slope controls are displayed.

[image: 41-1.jpg]

•  Select the Lock Spline Control Point tool. The Message Line reads, Lock Spline Control Point: Pick control point.

[image: 7-4-idle.bmp]

•  Click the control points on both sides of the middle control point, as shown here.

[image: Chapter_04.Graphite00028.jpg]

The points are locked.

•  Deselect the spline.

•  Select the middle control point.

[image: 41-4.jpg]

Tech Note: To select this point, choose Edit>Selectable Points and reselect the control point.

•  Drag the middle control point to new locations and observe how the spline is redrawn.

[image: Chapter_04.Graphite00029.jpg]

Accomplishments

•     Creating a through-points spline

•     Creating a vector spline

•     Editing splines

Exercise 11: Smart Walls

In this exercise use the Smart Wall tool to create a simple architectural drawing, a floor plan with outside measurements of 14 feet by 18 feet.

[image: Chapter_04.Graphite00030.jpg]

1.     Open a new Graphite document.

2.     Set the units to feet.

•  Choose Layout>Preferences>Units.

•  Click Feet and click OK.

Tech Note: Use different units of measure in the Status Line entries. If the selected units are not feet, be sure to specify the unit such as 2’ for two feet or 2 cm for two centimeters.

3.     Create two new layers: one for the interior walls and one for the exterior walls.

•  Select Layout>Layers.

The Layers dialog box appears.

•  Click New to create another layer.

•  Rename the layer by typing Interior walls in the Rename data field and click Rename.

•  Click New to create another layer.

•  In the Rename data field, rename the layer by typing Exterior walls and click Rename.

•  Select Exterior walls and click Set Layer, to make Exterior walls the current layer.

4.     Draw the exterior walls.

•  In the Line subpalette, select the Smart Wall tool. The Message Line reads, Double Line: Pick start point [Shift = Flip].

[image: 2-4-idle.bmp]

•  Enter 4'' in the T Status Line data field to indicate walls that are 4 inches thick.

•  Drag a horizontal line.

•  Enter 14 in the L Status Line data field and press ENTER (Windows) or RETURN (Macintosh).

The line extends off the screen.

Tech Note: Click twice on the down arrow to scroll the horizontal wall downward on the screen.

•  Choose Arrange>Zoom All or double click the mouse scroll wheel.

[image: 44-2.jpg]

The entire line is visible.

•  Press the SHIFT key and drag down vertically from the endpoint of the line at the upper-right corner. (The first graphic below shows the point to select and the second shows what happens while dragging.)

[image: Chapter_04.Graphite00031.jpg]

Tech Note: Selecting Layout>Show Points or Show Points option from the right click context menu helps to align the defining points of a wall precisely to the defining points of the previous wall segment.

It is critical to hold down the SHIFT key and drag to construct the wall so that the wall thickness is not added to the length of the first wall.

•  Enter 18 and press ENTER (Windows) or RETURN (Macintosh).

A corner is made between the first and second lines, and the second line extends off the screen.

•  Choose Arrange>Zoom All or double click the mouse scroll wheel.

[image: 45-1.jpg]

•  Complete the rectangle, using the SHIFT key while dragging the third wall.

[image: 45-2.jpg]

Tech Note: In the Edit Objects dialog box, change the defining axes of selected walls.

5.     Change the current work layer with the Work Layer Indicator box at the lower left of the drawing area.

•  Click anywhere in the drawing area, to deselect all walls.

•  Press the mouse button on the box where the Exterior walls layer is showing and the menu displays.

•  Drag to Interior walls.

Interior walls is now the current work layer.

6.     Create a drawing like the one below with two interior walls (3 inches thick) which don’t merge with the exterior walls.

•  Move the pointer along the inner edge of the upper horizontal wall until the notation midpoint displays.

•  Drag a vertical wall segment down about 10 inches long.

•  Type 12 in the L (length) Status Line data field.

•  Tab to the Thickness Status Line data field and type 3” for the wall thickness and press ENTER (Windows) or RETURN (Macintosh).

The horizontal wall is not merged with the vertical wall segment, since they are not on the same layer.

•  Drag a horizontal wall to connect the vertical wall segment with the right vertical exterior wall.

[image: 46-1.jpg]

Tech Note: Only walls on the same layer merge.

7.     Construct a 2-foot hole through the vertical interior wall, 2 feet distant from the upper horizontal wall.

•  Move the mouse pointer to the inner left corner of the upper horizontal exterior wall.

•  When the endpoint notation displays, hold down the CTRL+SHIFT keys (Windows) or the z key (Macintosh) and drag horizontally toward the center, releasing the mouse button anywhere.

A stroke construction line displays through the inner edge of the upper exterior wall.

•  Select the Parallel Lines tool.

[image: 2-5-idle00001.bmp]

•  Drag the construction line about 2' towards the middle of the room.

•  Enter 2 for the delta distance in the Status Line and press ENTER (Windows) or RETURN (Macintosh).

The parallel line is drawn 2 feet below the upper exterior wall.

•  Drag the new construction line about 2' more towards the middle of the room.

•  Enter 2 for the delta distance in the Status Line and press ENTER (Windows) or RETURN (Macintosh).

The second parallel line is drawn 2' below the second construction line.

•  Select the lower two parallel construction lines with the Selection tool.

•  Select the Simple Trim tool from the tool palette or from the right click context menu.

[image: 11-1-idle00003.bmp]

•  Click the Simple Trim tool on the vertical interior wall between the two construction lines.

The interior wall trims and the wall segment between the two construction lines deletes.

[image: 47-2.jpg]

8.     Add a 3-foot door beginning at the left 10% point of the upper horizontal exterior wall and extending towards the center.

•  Set the layer to Exterior walls by moving the pointer to the Work Layer Indicator box where Interior walls is shown and dragging to the layer.

•  Choose Layout>Preferences>Snap.

•  Enter 10 for the % Point.

•  The Drafting Assistant snaps to 10% points as well as midpoints.

•  Choose File>Symbol....

•  Navigate to the Symbols>Architect>Plandoor folder on your computer’s hard drive.

•  Choose the dsingle.vc6 symbol and click Open.

The Symbol dialog box appears so that the width of the door can be specified.

[image: Symbol1.jpg]

•  Enter 90 for the Angle of the door opening and press the TAB key.

•  Enter 4'' for the Wall thickness and press the TAB key.

•  Enter 3 for the Width of the door.

•  Drag the mouse horizontally, starting at the % point on the left side of the upper inside wall, towards the center, and release the mouse button anywhere. The direction of the drag indicates the orientation of the door.

•  Click Place.

[image: 49-1.jpg]

The wall geometry is redrawn to accommodate the door.

9.     Add a 5 foot window beginning at the 10% point of the right wall and extending toward the center.

•  Choose File>Symbol and navigate to Architect>planwin (Windows) or Plan Window (Macintosh) folder. Open wcasmnt2.vlm (Windows) or Casement 2 (Macintosh).

•  The Symbol dialog box appears to specify the width of the window.

•  Enter 4'' (the Wall thickness) and press TAB.

•  Enter 5 (the Width of the window).

•  Drag the mouse vertically, starting at the % point on the inside wall of the right wall, towards the center, and release the mouse button anywhere.

•  Click OK.

[image: 49-2.jpg]

The wall geometry is redrawn to accommodate the window.

10. Move the window and observe how the walls are automatically reconstructed.

•  Select the window and place the pointer on the top left corner of the window.

•  Using the Drafting Assistant's dynamic construction line, drag it to the opposite wall.

[image: 50-1.jpg]

11. Set the paper size and drawing scale.

•  Choose File>Print Setup.

•  Select paper size A (or 8.5 x 11 for laser printers). Click OK.

Tech Note: The available paper sizes depend on the printer or plotter specified.

•  Choose Layout>Drawing Size.

The Drawing Size dialog box displays.

[image: Drawing_Size.jpg]

•  In the Drawing Scale data field, type 1":2' (this entry is the same as 1:24)

Tech Note: The Scale data field accepts combinations of units of measure.

•  Click OK.

12. Segment the exterior walls.

•  Select the two symbols (door and window).

•  Choose the Segment tool from the tool palette or from the right click context menu.

•  With the Segment tool, click the wall segments near the door and the window symbols.

The walls are segmented.

13. Crosshatch the exterior walls.

•  Select all visible wall segments of the exterior walls by clicking with the Selection tool.

Tech Note: To crosshatch smart walls containing smart symbols, segment the walls first to create hatch boundaries. Since smart symbols cover only wall segments they can’t be used as hatch boundaries.

•  Choose Pen>Hatch.

The exterior walls are crosshatched.

[image: 51-1.jpg]

14. Ungroup the interior walls.

Tech Note: Fillet or chamfer smart walls only if they are ungrouped first. Since smart walls lose their smart features by ungrouping, place all symbols before filleting any smart wall.

•  Select the lower vertical and the horizontal interior wall.

•  Choose Arrange>Ungroup or right click to show the context menu and choose Ungroup.

Both wall segments are ungrouped and lose their smart features.

15. Fillet the corner of the two interior wall segments.

•  Click the 2-Entity Fillet tool.

[image: 10-1-idle00001.bmp]

•  Type 1 in the Status Line for the radius of the fillet.

•  Click on the two interior lines of the walls to fillet the two ungrouped walls.

•  Type 1.2 in the Status Line for the radius of the fillet for the outer two lines.

•  Click on the two exterior lines of the walls to fillet the two ungrouped walls.

The interior walls are filleted.

[image: 52-2.jpg]

16. Crosshatch the interior walls.

•  Select the upper vertical interior wall segment and all lines building the filleted interior walls.

•  Choose Pen>Crosshatch.

The Crosshatch dialog box appears.

•  Enter -45° for the hatch angle.

•  Click OK.

The interior walls are crosshatched.

17. Dimension the sides of the building.

[image: 53-1-E.jpg]

18. Save or discard the file.

Accomplishments

•     Using the Smart Wall tool

•     Using smart window and door symbols

•     Filleting walls

•     Crosshatching walls

•     Scaling a drawing




Drafting Techniques

This section investigates Graphite’s advanced drafting procedures, including detail views, drawing to scale and GD&T. In these exercises you will:

•     Create a detail view

•     Observe dynamic updates in multiple views

•     Scale the drawing

•     Import a drawing format

•     Create a GD&T label

Exercise 1: Creating a Detail View

This exercise create a Detail View. Detail views are additional dynamic cameras showing the same model at either a different angle, or more commonly, at a different scale. Since they are simply a different camera looking at the same model, any changes to a model will show in all detail views.

[image: Chapter_05.Graphite00001.jpg]

1.     Create a detail view of the notch from Exercise 8 in the last chapter of the tutorial, using a 2-to-1 ratio.

•  Open the file named part1a.

•  Click the Detail View tool on the View Control palette. The Message Line reads, Detail View: Enter view scale then pick first corner of viewing frame.

[image: 13-3-idle.bmp]

The Scale data field highlights in the Status Line.

[image: Chapter_05.Graphite00002.jpg]

 

[image: Chapter_05.Graphite00003.jpg]

•  Type 2.

•  Drag a frame around the top of the side view, including the notch.

•  Drag the frame to a new location.

[image: 5-1-EM.FH7.jpg]

The enlarged geometry appears in the detail view frame.

Tech Note: Note that the detail view is not dimensioned. Crosshatching, dimensions and text are view dependent. They appear only in the view in which they were created according to standard drafting practice.

2.     Fillet the right corner of the notch in the detail view and observe that the geometry in the frame is indeed a view of the same part.

•  Click the 2-Entity Fillet tool.

[image: 10-1-idle.bmp]

•  Enter .125.

•  Select the two lines that form the lower right corner of the notch in the detail view.

[image: 5-2-EM.FH7.jpg]

Both the part and the detail view are redrawn with the fillet.

Referral: To know more about working with views, see Chapter 13, “Viewing Geometry,” in the Graphite User Guide.

3.     Crosshatch the side view.

•  Deselect the view by clicking outside the view with the Selection tool.

•  Crosshatch the side view with the Steel crosshatch pattern.

[image: Chapter_05.Graphite00004.jpg]

The side view is crosshatched but the detail view is not.

4.     Save or discard the file.

Accomplishments

•     Creating a detail view

•     Observing dynamic updates in multiple views

Exercise 2: Drawing to Scale

In this exercise, use the Symbol feature to display a full-scale part, then dimension and scale the part for placement on a standard drawing format. This exercise uses a simple part to demonstrate the procedure used to construct more complex full-scale parts. Drawing at full scale has several advantages, the most important of which is that work can begin without having to specify paper formats or other parameters which would only distract from the design task.

Tip: For help finding the exact location of these files, consult  the Knowledgebase in the Support Center of our website at www.ashlar.com. Within the Knowledgebase search specifically for Graphite v10 symbol library locations.

1.     Draw a side view of a Phillips-head screw which is .75 inch long and has a thread diameter of .125 inch.

[image: 7-1-L.FH7.jpg]

•  Choose File>New

•  Choose File>Symbol.

The standard files dialog box appears.

•  Navigate to the Symbols folder.

•  Navigate to the Fasteners folder.

•  Navigate to the Machine screws folder.

•  Open the FLATHDPS.VC6 symbol document.

[image: Simbol.jpg]

The Symbol dialog panel displays the various types of screws until one is chosen and the measurements of the screw specified.

•  Type 0.75 for the Length and press the TAB key.

•  Type 0.125 for the Thread and click OK.

The screw appears.

[image: 8-2-La.FH7.jpg]

2.     Set the specifications for the paper size.

Tip: The margins on Graphite’s standart layouts are appropriate for most printers and plotters. On the Mac OS X, however, the default “Any Printer” margins are very large and our standart layouts are too big.

•  Choose File>Print Setup.

•  Select the paper size, size A for a plotter or US Letter size for a laser printer.

•  Set page orientation to portrait.

3.     Set the visual scale of the geometry.

•  Choose Layout>Drawing Size.

•  Click Fit.

[image: 8-3-La.FH7.jpg]

Tech Note: The scale is approximately 10:1 but the geometry is visually too large for the page, so reduce the scale to 5:1.

•  Enter a scale of 5:1 and click OK.

The size of the geometry is more appropriate for the size of the page boundary.

•  Since the geometry looks like the right size for the page, click OK.

4.     Dimension the screw.

•  Choose Arrange>Zoom All to display the screw at a larger size. This does not effect the actual measurement.

Tip: Zooming a part does not change its measurements, it magnifies or reduces it to display the specified portion on the screen. In this way it is possible to draw a part full scale, whether it is 100 feet long or 5 millimeters wide.

•  Choose the Horizontal Dimension tool.

•  Click the opposite ends of the screw.

The dimension displays

[image: 750.jpg]

•  Dimension the diameter of the thread.

[image: 9-2-La.FH7.jpg]

5.     Place the scaled drawing into a standard A-size drawing format.

•  Choose Arrange>Zoom Out or scroll forward the mouse scroll wheel.

•  Choose File>Import.

•  In the Ashlar-Vellum Graphite file, navigate to A Portrait 1 View.vc6 file and click on open.

Tip: For help finding the exact location of these files, consult  the Knowledgebase in the Support Center of our website at www.ashlar.com. Within the Knowledgebase search specifically for Graphite v10 layout library locations.

•  Be sure to specify Graphite.

[image: 10-1-La.FH7.jpg]

•  Click Unscale and OK to import the unscaled drawing format. Unscale unlocks the normal 1:1 scale  and uses the current scale during import. Unscale is usually only appropriate for importing layouts.

The format is imported to the sheet and is selected.

•  Drag the format until the screw is properly positioned on it.

Tip: These layouts are just Graphite files and can easily be changed.

6.     Use Text>Forms Text... to fill in the drawing layout text. Since the space for the text is quite limited be sure to use initials for names and xx/xx/xx for dates.

[image: 10-2-La.FH7.jpg]

7.     Plot the drawing.

•  If the plotter or printer is set up, to make a copy of this drawing, choose File>Print.

•  The drawing is plotted.

8.     Save or discard the file, as you wish.

Accomplishments

•     Using a symbol

•     Scaling a drawing

•     Importing a drawing format

Exercise 3: GD&T

In this exercise add a GD&T label and feature control frames to the flange construction from Chapter 4, “Additional Features.”

[image: 12-1.FH7.jpg]

1.     Open the flange document showing the flange and the side view.

2.     Create a datum label A for the upper-right corner of the side view.

•  Choose Dimension>GD&T.

Tip: Move the GD&T dialog box if necessary.

•  In the Datum field, type A.

•  Select the Witness Line option.



•  Click the upper-right corner of the side view to indicate the geometry to which to attach the witness line.

•  Click a location on the Drafting Assistant construction line above the corner to place the GD&T label.

[image: 13-1.FH7.jpg]

3.     Create a feature control frame for Perpendicularity for the hub of the side view.

Tech Note: All GD&T text uses the Plotter font so that the sizes meet ANSI standards.

•  On Line 1, in the first field, select the Perpendicularity ([image: Chapter_05.Graphite00005.jpg]) symbol from the pop-up menu.



•  On Line 1, in the second field, select the Diameter (Ø) symbol from the pop-up menu.

[image: 13-3-L.FH7.jpg]

•  On Line 1, in the third field, enter .003.

•  On Line 1, in the fourth field, select the Maximum Material Condition ([image: MatSymb.FH.jpg]) symbol from the menu.

[image: 13-4-L.FH7.jpg]

•  On Line 1, in the fifth field, enter A.

•  Change the entry to B in the Datum line.

•  Specify Witness Line if it is not already specified.

[image: 14-1.FH7.jpg]

•  Click the endpoint of the bottom of the hub in the side view to indicate the position for the witness line.

•  Click on the Drafting Assistant’s horizontal construction line to indicate the position of the feature control frame.

4.     Create a feature control frame for true position for the lower lug of the flange.

•  In the Label line of the GD&T dialog box, enter 4X Ø .50 to show that the diameter applies to four places.

To get the Ø symbol for Windows press the ALT key and type 0216 on the number keypad of the extended 101 keyboard. To get the Ø symbol for the Macintosh, press SHIFT+OPTION+O.

•  On Line 1, in the first field, select the Blank symbol at the bottom-right of the pop-up menu to clear the entries in that line.

•  Select the True Position symbol from the menu.

[image: 14-2.FH7.jpg]

•  On Line 1, in the second field, select the Diameter (Ø) symbol from the menu.

•  On Line 1, in the third field, enter .003.

•  On Line 1, in the fourth field, select the Maximum Material Condition ([image: MatSymb.FH00001.jpg]) symbol from the menu.

•  On Line 1, in the fifth field, enter A.

•  Skip the sixth field.

•  In the seventh field, enter B.

•  In the eighth field, select the Maximum Material Condition ([image: MatSymb.FH00002.jpg]) symbol from the menu.

•  Enter .5 in the PROJ (Projection) field.

•  Delete the entry in the lower Datum line.

•  Specify Arrow Line if it is not already specified.

•  Drag from the hole of the bottom lug on the flange straight down to indicate the position of the arrow and the label.

[image: 15-1.FH7.jpg]

•  Exit GD&T creation by close the GD&T window or selecting the Selection tool.

5.     Edit the second feature control frame.

•  Select the second frame created.

•  Choose Dimension>GD&T.

•  Change the .003 entry to .005.

•  Click Edit. The text changes in the frame.

6.     Save or discard the file.

Accomplishments

•     Creating a GD&T label

•     Editing a feature control frame




Constructing a Wedge Die

Up till now, all the exercises have been two dimensional. This exer­cise introduces the third dimension. Discover how easy it is to use. All of the tools used in 2D space are used in 3D.

This chapter constructs a wedge die part and then creates a 2D drawing with four views (Top, Front, Right and Trimetric).

Since working in Graphite is a smooth transition from 2D to 3D, it is fine to start the drawing in 2D.

Tip: As your need for 3D becomes more serious check out Ashlar-Vellum's products for 3D modeling, including Cobalt, Xenon and Argon.

Creating the Wireframe Geometry

1.     Begin with a new document and draw a rectangle. Make it about three times as tall as it is wide. It should be about 3 inches tall.

•  Select the Connected Lines tool.

[image: 2-3-idle.bmp]

•  Draw the first two lines by clicking at points 1, 2 and 3.

[image: 3-2-E.jpg]

Move up and show the intersect, but don’t click this point yet.

Tip: The Drafting Assistant gives the alignments to complete the shape.

2.     Display the Triad and change to a Trimetric view.

•  Choose 3D>Show Triad.

[image: 3D_Menu.jpg]

This command displays an orientation marker in the corner of the screen.

•  Choose Views>Views>Trimetric.

[image: Views.jpg]

The drawing began in the Top view. Now, the triad has changed to show a new orientation.

[image: 1.jpg]

Tech Note: Upon starting Graphite, the Top view is automatically selected.

The red one of the three lines is the x-axis, the green one is the y-axis and the blue line is the z-axis.

The black arrows show the work plane. The rectangle has tilted down to match the triad.

Now line up the same intersect point as before, while looking at it from a 3D orientation.

[image: Chapter_06.Graphite00001.jpg]

•  Click the final two points, to close out the rectangle and double-click at the last point. Continue with the Connected Lines tool.

•  Now click on the Scroll Up arrow a few times, to move the rectangle near the bottom of the screen.

[image: Scroll_Up_Arrow.jpg]

3.     Use the Z-Drafting Assistant to draw in the Trimetric view.

•  Click on the right-most corner of the rectangle just drawn.

•  Position the cursor above the first point of the rectangle, without clicking, to show the Z-Drafting Assistant.

[image: Chapter_06.Graphite00002.jpg]

•  Move up along the z-construction line and click the end point so the line is about 2/3 as tall as the rectangle is long. Then, without clicking, go down and touch the midpoint of the line, as shown in the graphic on the right.

[image: 6-1-E.jpg]

Tip: Here is the first of many unique features of Graphite. This is the Z-Drafting Assistant. In other words, the Drafting Assistant is working in the third dimension. This provides automatic alignments off the x-axis, the y-axis and the z-axis.

•  Come up the z-construction line, and locate the intersect shown.

[image: Chapter_06.Graphite00003.jpg]

Tip: After the Drafting Assistant displays the intersect, begin moving around in 3D space and create this block by just sketching, and letting the Drafting Assistant find the alignments.

•  Click the intersect shown above. Then, move down along the z-axis, and end this line somewhere inside the rectangle as shown by clicking. Then move to the left along the y-axis. Dip down to hover over, but do not click, the lower corner. Then locate the intersect shown here. Click this point.

[image: Chapter_06.Graphite00004.jpg]

•  Continue with the Connected Lines tool, and pick the five points shown here. Make sure to use the Drafting Assistant construction lines to get the proper alignments. At point 5, double-click to end the line.

[image: 7-1.jpg]

Tip: Picking each of these points, notice how the Drafting Assistant senses where you are and what other geometry is near. It automatically provides all the alignment construction lines necessary to draw this part.

What is shown here is one of the unique features of Graphite; the ability to move around freely in 3D space and pick points, almost like sketching. But having those points end up precisely aligned in all three axes is something that really sets Graphite apart.

4.     Complete the shape of the wedge by moving copies of the selected lines.

•  Select the Single Line tool.

[image: 2-1-idle.bmp]

•  Draw a single line from point 1 to point 2.

[image: Chapter_06.Graphite00005.jpg]

•  Select the Selection tool.

[image: 1-1-idle.bmp]

•  With the line still selected, place the pointer at point 1. Hold down the CTRL (Windows) or OPTION (Macintosh) key and drag a copy of that line to the endpoint of the top line, as shown below.

Notice that the Drafting Assistant automatically snaps to the endpoints at the start and the end of the move.

[image: Chapter_06.Graphite00006.jpg]

Tech Note: Notice that when the pointer gets near the selected line, it changes from the Selection tool to the 4-Way Move symbol. This moves the selected item(s), as well as makes copies while it is moved.

•   With the Selection tool, select the line the line above, perpendicular to the line that was just added.

•   As before, while the line is still selected, place the pointer at one endpoint, hold down the CTRL (Windows) or the OPTION (Macintosh) key and drag a copy of the line in the y-direction, placing it at the corner of the L. Drag another copy in the z-direction and drop it at the top of the block. Select the long vertical line on the far right side of the part and move a copy of it, as shown. Now, all the lines of the L block should be drawn.

[image: 8-3-EM.jpg]

The outline of the Wedge Die is completed. Because of the Drafting Assistant, this process was fast and accurate.

Tip: Do the same thing with some of the other lines. Draw these lines using the Single Line tool, but sometimes it’s easier to copy existing lines.

5.     If there is any doubt if this is truly a 3D object, check it with the Trackball. Choose Views>Show Trackball.

[image: Show_Trackball.jpg]

The Trackball/Trackcube comes up on the left side of the screen. For the purposes of this tutorial, it works best to have it on the right, so grab it by its title bar, and move it over to the right.

Tip: With the Trackball/Trackcube rotate the model just by clicking and rolling the ball. The model rotates in real time. Keep in mind, however, that the point of view is changed; the geometry itself remains fixed in model space.

[image: 2.jpg]

 

•  Rotate the model using the Trackball/Trackcube. Notice that the Triad appears at the center of rotation and displays the orientation of the axes as the model is turning.

[image: 3.jpg]

Tip: The button in the Trackball next to the view name changes its display style to cube and sphere.

6.     Change the view orientation.

[image: Change_Orientation.jpg]

•  Choose any view, such as Right or Top, by selecting each view from the pull-down menu on the bottom panel of the Trackball.

To continue with the tutorial, select Trimetric from the pop-up menu on the Trackball.

7.     Modify the design intuitively in 3D.

•  Hold down the SHIFT key and drag three selection fences around the four points shown to select these points. (The one short line in the big fence will also be selected.)

[image: 10-3.jpg]

•  Release the SHIFT key. Grab one of the points (the pointer will change to the Four Way Move cursor) and drag it vertically. Make sure align:z is seen at the bottom point when starting to move upward.

Tip: One of the great features of Graphite is the ability to modify the design easily in 3D. For example, to make this bottom area about twice as thick as it is now, select these points, and then move this face straight up until it is where it is desired. The Drafting Assistant constrains this movement along the z-axis.

Make the bottom block approximately twice as thick as it was originally.

[image: Chapter_06.Graphite00007.jpg]

•  In each of the examples below, use the SHIFT key and drag the selection fences shown to select the appropriate points. Then drag one of the points to stretch the part. (Skip this exercise if desired.)

[image: 11-2-E.jpg]

•  Choose Undo three times to get the part back to how it looked before the stretch exercises in the previous graphic (skip this if those exercises were skipped). The bottom of the block should be twice as thick as when it was originally drawn.

Tech Note: Graphite has unlimited levels of Undo. To specify the number of Undos when right mouse clicking in empty screen space, select Undo... and specify the number.

•  Regardless of whether the steps on the previous page were done, make sure to do the next one. This step is part of the actual shape of the finished part. Select the two points shown in the graphic and stretch the shelf back along the y-axis (stretch it two-thirds of the way back as pictured here). As part of the design, create a wedge-shaped front.

[image: Chapter_06.Graphite00008.jpg]

8.     Put a molded face on the front.

[image: 12-2.jpg]

•  Do a Stroke-Zoom. Hold down the CTRL+SHIFT keys (Windows) or the z key (Macintosh), and drag the rectangle shown, from upper left to lower right.

•  Pick the Connected Lines tool and draw the line shown, going about two-thirds of the way across the width of the face. Make sure the words align:-45 and on are displayed before the second point is clicked.

[image: Chapter_06.Graphite00009.jpg]

•  Finish the contour by drawing the lines and the arc, as shown. In frame 2, hold down the CTRL (Windows) or OPTION (Macintosh) key to temporarily get the Arc tool. Make sure that the words align:45 and on are displayed before clicking the second point.

Tip: Using the Drafting Assistant, construction lines are easily drawn. Hold the CTRL (Windows) or OPTION (Macintosh) key to get the temporary Arc tool.

[image: 13-2-EM.jpg]

9.     Finish the contour by first extruding it up, then by revolving it around the corner of the block, and finally by extruding it along the top face of the block.

•  Select Arrange>Zoom All.

•  Select Views>Hide Trackball.

•  Select the five just drawn lines of the contour (if they are not already selected).

•  Select 3D>Extrude.

The Extrude dialog box appears

[image: 4.jpg]

.

Tip: The Extrude dialog box can be moved by grabbing its title bar and dragging it to a new location.

The Extrude function is one of the most important features in Graphite. By entering a set of numbers in the three data fields it is possible to extrude along the vertical line of the face, even if it is currently unknown how far it is or in what direction.

With Graphite, this is easy. Notice the asterisk in the dialog box. The asterisk means, “use the cursor to enter values.”

•  Put the bulls-eye cursor on the bottom of the vertical line of the face and drag up to the top of the line, then

[image: 14-1-E.jpg]

release.

Tech Note: One of the important features that is unique to Graphite is the ability to drag from one point to another, and have the values appear in the right data fields.

A number equal to the distance of that drag appears in the dz data field, replacing the –1 that was there.

•  Click OK.

The extruded objects appear.

[image: 14-2.jpg]

•  Now select the same five contour objects, but select the ones at the top of the extrusion. These objects are about to be revolved around the corner of the block.

•  Select 3D>Revolve.

The Revolve dialog box appears.

[image: 5.jpg]

Now take this contour and sweep it 90 degrees, using the corner of the block as the axis of revolution. Knowing this, type 90 into the Sweep Angle data field. Use 4 divisions for the # of Steps. There is an asterisk again in the remaining six data fields, which means, “use the cursor to enter values.” Define the axis of revolution to be from point 1 to point 2.

Tech Note: Indicate how many copies should be placed within the Sweep Angle with the # of Steps.

•  Type 90 in the Sweep Angle data field.   

•  Type 4 in the # of Steps data field.

•  Press TAB to move the cursor into one of the data fields for the Origin.

•  Define the Axis of Revolution by dragging from endpoint 1 to endpoint 2 as illustrated below. Dragging in the opposite direction, the contour sweeps in the opposite direction.

When releasing the mouse, the data fields for Origin and Axis fill with a series of numbers.

[image: 15-2-E.jpg]

Graphite automatically filled in the numbers for the axis and direction of revolution.

•  Click OK.

Graphite builds the sweep.

[image: 16-1.jpg]

•  Select the five contour objects at the end of the sweep.

•  Select 3D>Extrude.

•  To specify the length and direction for the extrusion, drag from endpoint 1 to endpoint 2 as shown below.

[image: 16-2-E.jpg]

•  Click OK.

The contoured face is finished.

[image: 16-3.jpg]

10. The extrude operation has created some geometry that makes some of the old lines inappropriate. Select these lines and delete them to clean up the drawing.

•  Select the three lines shown by SHIFT-clicking on them, and then delete them.

[image: 17-1.jpg]

Tip: At this point get the Trackball out and rotate the part to see it from various angles.

11. The next step is to put a hole on the front face of the wedge and extrude it through the part. By doing so, the concept of Work Planes will be introduced.

Right now, looking at the Triad notice that the Work Plane is parallel to the bottom of the Wedge Die. If you were to draw a circle, it would draw in that orientation. The desired orientation, however, is a circle that stands up along the right face. The work plane must be changed to accomplish this.

•  Select 3D>Planes>Right.

[image: Planes.jpg]

Notice that prior to releasing the mouse button, the current Plane was Top or World (indicated by a check mark). Once the mouse button is released, the Triad changes to reflect the new work plane.

•  Select the Center-Point Circle tool.

[image: 4-1-idle.bmp]

•  Touch the midpoint of both the right side and the top edge of the front face to awaken these points. The Drafting Assistant now offers construction lines off of each point.

[image: 18-3-E.jpg]

Tip: Use the Trackball to rotate the part to make it easier to see the midpoints of the lines on the right side face.

•  Go to where the Drafting Assistant shows the intersect of the two alignments and drag the circle along the face (the center of the circle is placed at the intersect). Release the mouse button when the circle is approximately the size shown.

[image: 18-4-E.jpg]

•  While the circle is still active, select Arrange>Divide.

The Divide dialog box appears.   

•  Make # of pieces equal to 4, and deselect the Show Points option.

•  Click OK.

Tech Note: Dividing the circle results in four extrusion lines (instead of one). The extra extrusion lines make it easier to visualize the extrusion.

The circle is now divided into 4 arcs. The circle flashes to show that the divide operation executed.

•  Select 3D>Extrude.

•  Drag from endpoint 1 to endpoint 2.

This defines the distance and direction the circle to be extruded.

[image: 19-1-E.jpg]

•  Click OK.

The circle extrudes with four extrusion lines.

[image: 19-2.jpg]

12. The next step is to put a hexagon on the sloped face. This is a good exercise because it shows how Graphite deals with non-orthogonal planes. To draw anything directly on a sloped face, it is logical that the work plane should be set to match it, but looking at the 3D>Planes submenu none of the choices are appropriate (Top, Front, Right and World). For this operation it is necessary to define a new plane.

•  Choose 3D>3-Point Plane.

The Message Line asks for three specific things: the origin, the positive x direction, and the positive y-direction.

Tech Note: Use the Define Plane command only if that plane orientation will be used more than once.

•  Click first at endpoint 1 for the origin, then at endpoint 2 for the positive x-direction, and finally at endpoint 3 for the positive y-direction as shown in the drawing below.

[image: 20-1-E.jpg]

The Triad changes to indicate that the current work plane now matches the sloped face.

[image: Chapter_06.Graphite00010.jpg]

Now that the work plane is correctly oriented, draw the hexagon.

•  Select the Circumscribed Polygon tool. The Message Line reads, Circumscribed Polygon: Pick center of polygon [Ctrl = Copy Previous (Windows) or Option = Copy Previous (Macintosh)].

[image: 6-3-idle.bmp]

•  Touch the two midpoints shown to awaken them and let the Drafting Assistant indicate where the intersect is located. This point will be the center of the hexagon. Drag the second point straight up, and the hexagon is placed onto this sloped face. Release the mouse button when the hexagon is similar to the drawing below.

[image: 21-1-E.jpg]

13. Now extrude the hexagon through the part, perpendicular to the face.

•  Select 3D>Extrude.

•  Drag one of the points beyond the bottom of the part along the z-direction. Take the extrusion well below the part and release the mouse button. Make sure align:z is displayed so that the extrusion is perpendicular to the work plane.

[image: 21-2-E.jpg]

•  C   lick OK.

[image: 21-3.jpg]

14. The extrusion is extended beyond the base. Use the Simple Trim tool to cut off the excess.

•  Change the view to Right (either use the pop-up menu on the Trackball or Views>Views>Right).

•  Use the Selection tool to select the bottom line of the part. This acts as a trim boundary.

•  Select the Simple Trim tool.

[image: 11-1-idle.bmp]

•  Click on the extrusion lines that extend below the bottom of the part.

There should be two lines on top of each other in each location, so click twice on each line.

•  Select and delete the lower hexagon.

Tech Note: The Simple Trim tool works exactly as it did in 2D, except now it is working on a 3D part. This is great because it is like trimming to a surface.

[image: 22-2-E.jpg]

The hexagon trims to the bottom edge of the part.

[image: 22-3.jpg]

•  Go back to the Trimetric view.

[image: 22-4.jpg]

15. Draw the projected hexagon on the bottom surface of the wedge.

•  Execute a Stroke-Zoom. Hold down the CTRL+SHIFT keys (Windows) or the z key (Macintosh) and drag a diagonal window from upper left to lower right, as shown.

[image: 23-1.jpg]

•  Using the Connected Lines tool, connect each of the six endpoints to finish the hexagon hole along the bottom of the part. Double-click at the last point (point 7) to end the connected line.

[image: 23-2-E.jpg]

•  Choose Arrange>Zoom Previous to get back to the previous zoom. Hold down the CTRL+SHIFT keys (Windows) or the z key (Macintosh) and drag a diagonal window from lower right to upper left.

[image: 23-3.jpg]

16. Save the view.

•  It is a good exercise to save custom views. Set the view to Isometric. Rotate it slightly using the trackball and then save the new view. To do this, choose Views>Define View. Click New, and then OK. This will create a new view called View 1. Switch back and forth between this and other views. For the purposes of the rest of the tutorial, it is best to switch the work plane back to World and the view back to Trimetric.

The part is finished! But the tutorial is not done yet. So read on.

Creating a 2D Drawing

17. Place this part into a 2D drawing with four views (Top, Front, Right, and Trimetric). In Graphite all it takes is one command.

•  Select Arrange>Zoom All. Leave the part in the Trimetric view.

•  Select Views>Sheet Into View.

The following dialog box appears:

[image: Sheet_into_View.jpg]

Specify a layout and viewing scale for the original model. There are many choices in this menu including different variations of view arrangements, surrounded by a border and title block. These choices are user definable.

•  Select A Landscape 4 View.vc6. Set the Scale to .75.

•  When finished, click OK.

•  Select Arrange>Zoom All.

With just one command the 3D wireframe model becomes a layout for a 2D drawing. It has the four views, a title block, and a border. It doesn’t get any easier than this.

Tip: If all of the wedge die is not visable in each view, don't worry. The next step shows how to modify the scale.

[image: A_Landscape_4_Views.jpg]

18. Edit the view windows.

If a drawing unlike previous illustration appears, such as one where the part is too small or too large in each of the views, modify the scale of each of the four views.

If the drawing looks fine, then skip the next four steps.

•  Activate one of the views by clicking on it.

•  Open the pull-down menu from the upper left corner of the view boundary.

[image: Chapter_06.Graphite00011.jpg]

•  Select Properties from the pull-down menu.

•  Modify the scale to make the part show up in the view more clearly. In this case, since the part is too small at .75 scale, perhaps entering a scale of 1.5 would work better. Find the scale that works well, then make sure to enter the same value for all four of the views.

Use the Trackball to rotate any of the views to a nonstandard orientation.

•  Select Views>Show Trackball.

•  Click in the Top view window to make it active. (Its title bar will display.)

•  Rotate the model in that view by dragging on the Trackball. It is possible to make any of the four views display any custom view. (Rotate the Right view window next.)

[image: SIV_with_Trackball.jpg]

•  While the Right view window is still active, pick Right from the Trackball pull-down menu. Click on the Top view window to activate it, and select Top from the Trackball menu to put it back to its orthogonal projection.

•  Select Arrange>Zoom Out with the SHIFT key (Windows) or CONTROL (Macintosh) pressed down.

•  Select Pan in the pull-down menu for the Top view window. The cursor changes to a mover hand icon.

•  Drag the wedge to the upper left corner of the view window.

[image: Chapter_06.Graphite00012.jpg]

•  To finish, drag the lower right corner of the view.

Drag it up, to reduce the size of the view.

[image: Chapter_06.Graphite00013.jpg]

•  Drag the title bar of the new view and move it into a clean area.

[image: Moving_to_a_Clean_Area.jpg]

Set the right view to its original size and position.

19. Create an unfolded view.

A common drafting operation is to create a view on the drawing that looks straight at a specified face, much like the Projected View problem from high school drafting class.

In Graphite, activate the view, and unfold it.

•  Click on the Right view window to activate it.

•  Choose Views>Unfold View.

The message line reads, “Pick start of fold line.” 

•  Drag the mouse button from endpoint 1 to endpoint 2.

[image: Chapter_06.Graphite00014.jpg]

•  When the mouse button is released, a new view appears on the drawing. (Note: it may appear below the current drawing, requiring you to scroll down, or Zoom All to see it).

[image: A_New_View....jpg]

•  Resize the unfolded view, Drag its title bar and move it to a clean area.

[image: Resize_and_Unfold.jpg]

20. Dimension the part.

•  Select Dimension>Show Palette.

The Dimension tool palette appears.

•  Select the Vertical Dimension tool.

•  Click in the Top view window to activate it.

•  Click on the right side of the part from top to bottom to make the dimension appear. Change its font size to make it readable.

[image: Chapter_06.Graphite00015.jpg]

Tech Note: During dimensioning pay attention to the Triad. The dimensions work only on the current x-y-plane. A good trick is to pick Set Plane to Screen from the 3D menu. The Triad appears flat in all five views now. All dimensions work as if in a 2D-drawing.

The five views that appear here are dynamic. The dimension object that was just placed, however, appears only in the one view, because these views are smart. Dimensions show only in the view in which they are placed. The same is true for Crosshatching and Text.

21. Print the drawing.

•  Hide the Trackball, the Triad and the Dimension palette.

•  Deselect view boundaries (Views>Draw View Boundaries).

•  Select File>Print Setup and prepare the page settings for the paper and printer.

[image: Diminsion_in_the_View.jpg]

This should match the layout chosen.

•  Be sure to set the scale in the Layout>Drawing Size to 1:1.

•  Select File>Print.

Accomplishments

•     Creating a 3D wedge die

•     Creating 2D drawings




More 3D Shapes

The exercises in this chapter will provide greater familiarity and comfort in creating geometry in 3D. They include:

[image: 4-1-L.FH7.jpg]

Tips: If you are left-handed and your mouse has more than one button, you can change the functionality to the right mouse button. Make this change in the Control Panel of Windows.

Exercise 1: Three Ways to Construct a Box

This exercise explores three methods to draw boxes. In each case use the Z-Drafting Assistant to draw the figure.

[image: 5-1.FH7.jpg]

Method 1

1.     Draw a box using the Z-Drafting Assistant.

•  Choose 3D>Show Triad.

[image: Triad.png]

The Triad appears in the upper-left corner of the screen.

Tech Note: The Triad shows the orientation of the work plane, and since the sheet and the work plane are the same, the Triad shows the orientation you are seeing.

In the Trimetric view with the Top work plane, the Drafting Assistant displays the “vertical” align z notation.

•  Choose Views>Views>Trimetric or choose Views option from the right click context menu and then click Trimetric.

[image: Triad1.png]

The view rotates to the trimetric orientation.

•  In the Line tool subpalette, select the Connected Lines tool.

•  Begin the first line, dragging toward the upper right along the y axis as displayed by the Drafting Assistant.

[image: 5-4-L.FH7.jpg]

•  Draw the second line segment on the x-axis.

[image: 6-1-L.FH7.jpg]

The x-axis displays as perpendicular to the y-axis.

•  Draw the next segment to the intersect as shown below.

[image: 6-2-L.FH7.jpg]

•  Complete the rectangle. Don’t double-click when the rectangle is complete.

[image: 6-3.FH7.jpg]

•  Extend the rectangle along the align:z construction line, clicking the lower corner, as shown.

[image: 6-4-L.FH7.jpg]

•  Move the pointer to display the intersect point as shown, and click.

[image: 7-1.FH7.jpg]

•  Click the next intersect point as shown.

[image: 7-2-L.FH7.jpg]

•  Continue drawing, double-clicking when the second rectangle is complete.

[image: 7-3.FH7.jpg]

•  Use the Single Line tool to connect the corners of the rectangles.

[image: 7-4.FH7.jpg]

The Trimetric sketch is complete.

2.     Rotate this box to observe that it is a 3D model.

•  Choose Views>Show Trackball.

The Trackball/Trackcube displays.

[image: Trackball.png]

•  Drag on the Trackball/Trackcube.

The work plane Triad displays in the center of the screen as the Trackball is dragged, and the box being drawn rotates as you drag on the Trackball.

[image: Triad2.png]

Method 2

1.     On the same drawing area, use the Move tool to create a box.

•  Rotate the view to Trimetric, by choosing Trimetric from the Trackball pop-up menu.

•  Create another rectangle.

[image: 8-3.FH7.jpg]

•  If the rectangle is not selected, select it.

•  In the tool palette or in the right click context menu, choose the Move tool. The Message Line reads, Move: Pick beginning reference point [Shift = Select, Ctrl = Copy (Windows) or Option = Copy (Macintosh)].

[image: 12-1-idle.bmp]

•  Hold down the CTRL (Windows) or the OPTION (Macintosh) key.

If the CTRL (Windows) or OPTION (Macintosh) key is not held down, the selected object is simply moved while the next two steps.

•  Click the front corner of the rectangle for the beginning reference point.

Tech Note: By holding down the CTRL (Windows) or the OPTION (Macintosh) key during this operation, a copy moves to the new location.

[image: 9-1-L.FH7.jpg]

•  Indicate the ending reference point by moving the pointer down until the align:z notation appears, and click when the pointer is about an inch from the corner.

[image: 9-2.FH7.jpg]

•  Use the Single Line tool to connect the corners.

[image: 9-3.FH7.jpg]

Method 3

1.     On the same drawing area with the view rotated to Trimetric, use the Extrude command to create a box.

•  Create another rectangle.

[image: 9-4.FH7.jpg]

•  Select the lines of the rectangle, if they are not already selected.

•  Choose 3D>Extrude.

•  Type –2 in the Z data field.

•  Click OK.

[image: 10-1.FH7.jpg]

2.     Manually rotate the view with the Trackball and observe how the models

[image: 10-2.FH7.jpg]

move.

3.     Observe the standard views of the models; Isometric, Right, Front, Top and Trimetric.

•  Select each of the views from the Trackball pop-up menu, one at a time.

4.     Delete all three boxes.

Tip: The three methods used in this exercise are quite simple. While one method may seem to be more appropriate when constructing a particular box, by gaining proficiency in 3D modeling, you’ll find uses for all three methods.

•  In the tool palette, double-click the Selection tool.

All geometry is selected.

•  Press the BACKSPACE (Windows) or DELETE (Macintosh) key or choose the Delete option in the right click context menu.

All geometry is deleted.

Exercise 2: More 3D Drawing

[image: 11-1.FH7.jpg]



This exercise explores the Drafting Assistant, working along the z axis further by drawing the figure below. Observe the snap points and construction lines which aid in creating isometric drawings.

1.     Set the view to Trimetric.

Tech Note: Because isometric views have such a strict angle of view lines often overlap and are difficult to see. We recommend drawing in the trimetric view then changing to isometric as needed.

2.     Draw the rectangular cube shown at the right, using whatever method.

[image: 11-2.FH7.jpg]

3.     Draw the rectangular block adjacent to and aligned at the midpoint of the back face of the first block.

•  Use the Connected Lines tool and begin at the midpoint of the upper line.

•  Observing the align:z and perpendicular notations, begin the construction in the order shown below.

[image: 11-3.FH7.jpg]

•  Double-click at the first location to end this part of the construction.

[image: 12-1.FH7.jpg]

Tech Note: Remember that it’s possible to press the ESC key to backtrack while drawing with the Connected Lines tool.

•  Complete the block using the Connected Lines and the Single Line tools.

[image: 12-2.FH7.jpg]

4.     Construct a ramp at the midpoint of each side of the rectangle at the front of the first block.

•  Use the Connected Lines tool and begin at the midpoint of the left side of the first block.

Tech Note: To snap to a particular point, such as the midpoint shown here, the Z-Drafting Assistant snaps back and forth between snap points in close proximity. To snap to the midpoint, move the pointer until the notations are snapping, and with the mouse button still down, press the m key (for midpoint) on the keyboard.

[image: 12-3-L.FH7.jpg]

•  Draw the lines as shown in the following illustrations.

[image: Extra_Illustration.jpg]
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If it is difficult to get the Drafting Assistant to snap to certain location, it may be because the view orientation puts the geometry too close to other geometry. Try rotating the view slightly with the Trackball.

5.     Save the drawing, and close the document.

•  Choose File>Save.

•  Name the drawing.

•  Choose File>Close.

Exercise 3: Extrusion

[image: Ex3-1.FH7.jpg]



In this exercise, use the Extrude command to draw the bracket below. Extrusions begin by drawing a figure in 2D on the x,y plane and then extruding it in the z-direction. Once an object is created, rotate it or move the work plane to add detail.

1.     Open a new document.

2.     Draw the 2D outline of the L-bracket, as illustrated, using the measurements provided.

To make the arc segment, hold down the CTRL (Windows) or OPTION (Macintosh) key when clicking the location of the endpoint. Hint: Start at the upper-left corner of the bracket.

[image: Ex3-2.FH7.jpg]

This view of the model is considered the Top view.

3.     Extrude the L-shape into a 3D bracket that is 3 inches wide.

Tech Note: If the computer screen represents the x,y plane, then the positive z-direction is coming out towards you. Therefore, to make the apparent depth go into the monitor, enter a negative z-value.

•  Select the geometry if it isn’t already selected.

•  Choose 3D>Extrude.

•  Type –3 for the Z data field and click OK.

The part extrudes, but its depth is not seen because you are looking straight at the x,y plane.

4.     Rotate the view orientation to the Trimetric view.

Tip: It is possible to rotate the view manually so that none of the lines overlap.

[image: Ex3-3.FH7.jpg]



Tech Note: To begin drawing without doing Step 5, the geometry would be drawn on the x,y plane of the Top view. Move the work plane in order to draw on the front face of the bracket.

Display the Triad if to see the orientation of the work plane.

5.     Move the work plane.

[image: Ex3-4.FH7.jpg]

•  Choose 3D>3-Point Plane.

•  As illustrated on the right, click the origin, the x-direction, and the y-direction. The Message Line displays instructions.

6.     Create a one-inch hole at the intersection of the midpoint construction lines of the bracket’s front view. Rotate the bracket to get access to the lines that need to be used.

•  Brush over the midpoints of the two lines to a waken them.

•  Use the Center-Point Circle tool to draw the circle, centered at the middle of the bracket arm.

[image: Ex3-5.FH7.jpg]

•  Type 1.0 and press ENTER (Windows) or RETURN (Macintosh).

[image: Ex3-6.FH7.jpg]

7.     Extrude the circle through the thickness of the bracket.

•  Choose 3D>Extrude.

•  Drag from endpoint 1 to endpoint 2, as noted below, to indicate the direction and length of the extrusion. When releasing the mouse, the values are automatically entered in the data fields.

[image: Ex3-7.FH7.jpg]

•  Click OK. The hole extrudes.

[image: Ex3-8.FH7.jpg]

8.     Add a hole in the center of the other arm of the bracket.

•  Choose 3D>Planes>Right to reset the work plane.

•  Draw the circle using the intersect point of the midpoints.

•  Extrude the circle as in the last step, using the thickness of this bracket arm.

[image: Finished_Bracket.FH7.jpg]

9.     Save the bracket for use in the next exercise.

Exercise 4: Interlocking Parts

This exercise uses layers to construct interlocking parts with precise hole alignment.

[image: Ex4-1.FH7.jpg]

1.     If necessary, open the bracket file saved in the last exercise.

[image: Ex4-2.FH7.jpg]

2.     Enlarge the bracket to fill the screen and select the lines and circles highlighted in bold in the image below. These lines and circles will be used as the basis for building the mating cube.

[image: Ex4-3.FH7.jpg]

Tech Note: This geometry represents the mating surfaces of the two parts.

3.     Move copies of the selected lines and circles to a new layer.

•  Choose Layout>Layers.

•  Click New.

Layer 2 is added to the list.

•  Click Set Layer.

Layer 2 becomes the work layer.

•  In the tool palette or in the right click context menu, click the Move tool.

•  Hold down the CTRL (Windows) or the OPTION (Macintosh) key and click any endpoint on the selected geometry.

•  Click the same endpoint again.

The selected geometry is copied at the same location; two sets of geometry now exist, both on Layer 1, but only one of the copies remains highlighted (selected).

•  Select Edit>Edit Objects or choose the Edit Objects option from the right click context menu.

•  Change the Layer entry from Layer 1 to Layer 2.

•  Click Apply.

The duplicate (selected) geometry is now on Layer 2.

4.     Hide Layer 1.

•  Click Layer 1 in the list box of the Layers dialog box.

•  Click Hide.

The geometry on Layer 1 is hidden, and Layer 2 is still the work layer.

5.     Complete the interlocking piece.

[image: Ex4-4.FH7.jpg]

6.     Use Show and Hide Layers to display these components of the interlocking model.

[image: Ex4-5.FH7.jpg]

Exercise 5: Revolve

This exercise draws a goblet using the Revolve command. Begin by drawing half of a 2D object touching the revolutional axis.

1.     Open a New document.

2.     Draw half of a goblet along the vertical axis.

•  Choose Layout>Show Grid or use the CTRL+G short cut.

•  Draw the outline as shown below.

[image: Ex5-1grid.FH7.jpg]

3.     Rotate the half-object around the vertical axis.

•  If the geometry is not selected, select it.

•  Choose 3D>Revolve.

•  Click the Origin data field.

•  Drag to indicate the beginning and end of the revolutional axis.

[image: Ex5-2.Drag.FH7.jpg]

•  The default number of steps listed is 8.

•  Click OK.

As defined in the Revolve dialog box, the outline revolves 360° through the number of steps entered to make a 3-dimensional goblet.

[image: Ex5-3goblet.FH7.jpg]

4.     Rotate the view to get a better 3D angle.

[image: Ex5-4.rotate.FH7.jpg]

5.     Save the drawing.

Additional Exercise

Using circles and the Revolve command, create images such as those illustrated below.

[image: Ex5-5.additionala.FH7.jpg]

Also practice 180° revolutions to understand how the right hand rule is applied while defining the axis of revolution.

Exercise 6: Pipe Winch

This exercise puts all the 3D modeling methods together to draw a pipe winch for an oil rig.

[image: 23-1.FH7.jpg]

1.     Open a New document.

2.     Draw the basic shape in the Trimetric view.

Tech Note: If you have trouble drawing this part in the Trimetric view, draw it in the Top view as illustrated below and then change it to the trimetric orientation.

[image: 23-3.FH7.jpg]



Then practice drawing in the Trimetric view by imitating the rotated part.

•  In the Trackball menu, choose the Trimetric view.

•  Use the Connected Lines tool to draw the trimetric figure below using the measurements as illustrated.

[image: 23-2.FH7.jpg]

3.     Extrude the part to a z-depth of 2 inches.

[image: 23-4.FH7.jpg]

4.     Add the roller, using Revolve to turn a rectangle on the slanted face.

•  Zoom in on the part.

•  Choose 3D>3-Point Plane to move the work plane.

Click at the three points shown to indicate the new orientation of the x and y axes, and therefore the work plane.

[image: 24-1-L.FH7.jpg]

•  Draw a rectangle, as shown.

Notice that it is possible to add this rectangle while looking at it from any angle.

[image: 24-2.FH7.jpg]

•  With the new rectangle still selected, choose Revolve to revolve the rectangle 315° (using the default 8 steps)

•  Enter 315 for the Sweep Angle and 8 for the # of Steps into the Revolve dialog box. Activate the next data field by hitting the TAB key or clicking in it with the mouse. Then, using the bull’s eye cursor drag from point 1 to point 2 and the six data boxes will receive the proper data.

[image: 25-1-L.FH7.jpg]

Tech Note: Be aware of the right hand rule of revolution. Click the upper point on the axis first to revolve in the proper direction.

The rectangle revolves.

[image: 25-2.FH7.jpg]

5.     Save or delete the part.

Exercise 7: Projecting an Arc on an Angle in 3D

In this exercise, explore 3D drawing further, and construct this model.

[image: 26-1.FH7.jpg]

1.     Open a new document and show the Trimetric view.

2.     Use the Connected Lines tool to follow these steps:

[image: Chapter_07.Graphite00001.jpg]

3.     Draw the single line representing the width of the part.

[image: 26-4.FH7.jpg]

Tip: As your need for 3D becomes more serious check out Ashlar-Vellum's products for 3D modeling, including Cobalt, Xenon and Argon.

With all lines selected, except the last one drawn, use the Mirror tool with the Copy option (CTRL key - Windows, OPTION key - Macin­tosh) to make a mirror copy along the mirror line perpendicular to the midpoint of the width line.

[image: 27-1.FH7.jpg]



Tech Note: The Mirror tool only works in the x,y plane. In this model, mirroring works correctly, but if the work plane is changed, mirroring may not work.

[image: 27-2.FH7.jpg]

4.     Connect the front edges.

[image: 27-3.FH7.jpg]

5.     Use the Connected Lines tool to make the back opening.

Change the work plane to Right to place the arc correctly.

[image: 27-4-L.FH7.jpg]

•  Continue the construction as shown here:

[image: 28-1.FH7.jpg]

6.     Construct the ellipse on the slanted face.

•  Add construction lines as shown in bold below.

[image: 28-2.FH7.jpg]

Tip: Remember when using tools which require specification of three points, the work plane does not need to be moved.

•  Draw another construction line from the midpoint of the arc, as shown.

[image: 28-3.FH7.jpg]

Tech Note: With these construction lines, it is not necessary to specify the center and one point on a 3-point center ellipse. It is still necessary to specify the corner of a box bounding the ellipse.

•  From the Front view, trim this line back to the front face.

[image: 28-4.FH7.jpg]

•  Draw a construction line from the endpoint of the last line, perpendicular to the edge of the slanted face.
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•  Choose the 3-Point Center Ellipse tool. The Message Line reads, 3-Point Center Ellipse: Pick center of ellipse [Ctrl = Copy Previous (Windows) or Option = Copy Previous (Macintosh)].
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Tip: Rotate the part with the Trackball to see the intersections clearly.

Specify the points as shown.

The ellipse appears.
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7.     Delete the construction lines and trim the upper half of the ellipse.

[image: 30-1.FH7.jpg]

The model is complete.

8.     Save or discard the part.

Exercise 8: Three-Corner Fillets

This exercise works with one of the trickiest 3D modeling problems, trimming the corner of a box where three fillets intersect.

[image: 31-1.FH7.jpg]

1.     Begin by drawing a box.

[image: 31-2.FH7.jpg]

2.     Fillet three corners as shown below.

[image: 31-3.FH7.jpg]

Tip: With the 2-Entity Fillet tool do not worry about changing the work plane around. The fillet is automatically placed in the plane based on the two selected lines.

3.     Extrude the fillets.

•  Select the bottom fillet.

•  Choose 3D>Extrude.

•  Drag from one end of the line as shown below to indicate the extrusion distance and click OK.

[image: 32-1-L.FH7.jpg]

The fillet is extruded.

[image: 32-2.FH7.jpg]

•  Extrude the other fillets.

[image: 32-3.FH7.jpg]

4.     Trim the intersecting lines at the corner.

•  Use the Corner Trim tool and trim the corner as shown.

[image: 33-1-L.FH7.jpg]

The corner trims.

[image: 33-2.FH7.jpg]

•  Trim the remaining corners, as illustrated.

[image: 33-3.FH7.jpg]

5.     Delete the lines which made up the edges of the cube before adding the fillets.

[image: 33-4.FH7.jpg]

Tip: Create a new layer and move those lines to that layer, then hide that layer to use them again.

6.     Move the remaining arcs into the proper positions.

[image: 34-1.FH7.jpg]

The cube corners are filleted.

[image: 34-2.FH7.jpg]

7.     Check the Top, Right and Front views to see if they look correct.

8.     Save or discard the drawing.

Exercise 9: Filleting Curves

In this exercise, create a fillet at the bottom of a pocket.

1.     Begin by drawing a model similar to the one below.

[image: 35-1.FH7.jpg]

2.     Draw a line in the plane of the floor, perpendicular to the pocket side.

[image: 35-2.FH7.jpg]

3.     Construct a fillet between the line on the floor and the line on the side.

[image: 36-1.FH7.jpg]

4.     Extrude the fillet arc along the length of the side, from endpoint to endpoint.

[image: 36-2-L.FH7.jpg]

5.     Revolve the fillet arc around the corner radius, the number of degrees of the corner angle, using a vector from the corner radius center and 2 steps.

[image: 37-1-L.FH7.jpg]

6.     Extrude along the next straight line segment.

[image: 37-2.FH7.jpg]

7.     Revolve around the curve, by the degrees of the curve angle, using a vector from the radius center.

[image: 37-3.FH7.jpg]

Tech Note: Use Edit Objects to find the value of the angle of the curve.

8.     Complete the boundary by extruding along the lines and revolving around the arcs.

[image: 38-1.FH7.jpg]

9.     Delete the original boundary and the line added to create the fillet initially.

[image: 38-2.FH7.jpg]

10. Trim the vertical lines to the top of the new boundary.

[image: 39-1.FH7.jpg]

The model is complete.

11. Look at the other views (Front, Top and Right) of the model.

[image: 39-2.FH7.jpg]

Tech Note: Remember to hold down the SHIFT (Windows) or the CONTROL (Macintosh) key when zooming in the active view window.

Exercise 10: Compound Curve

In this exercise, create a compound curve using multiple views.

[image: Ex10-1.FH7.jpg]

1.     Open a new document.

2.     Draw an arc so that the endpoints of the arc lie on a horizontal line.

3.     Set up design views, to see the work from different view points.

•  Choose Views>Sheet Into View.

•  Choose A Landscape 4 Views.vc6 from the pop-up menu.

•  Click OK.

Zoom to see the arc properly.

The arc displays in the views.

[image: Ex10-2.FH7.jpg]

4.     Extrude the arc in the z direction.

[image: Ex10-3.FH7.jpg]

5.     Add lines on the surface of the cylinder.

•  Select the extrusion line at the left end of the arc.

•  Choose Edit>Polar Duplicate.

Specify 8 for the number of duplicates.

Activate the Center X data field with the TAB key. First touch the arc with the bull’s eye cursor to a waken the center point and then click on the center point of the arc.

Make the step angle 2°.

Click OK to finish the operation.

•  Repeat the process for the other end of the cylinder, making the step angle –2°.

[image: Ex10-4.FH7.jpg]

6.     Create the profile of the compound curve.

Use the Selection tool + CTRL (Windows) or OPTION (Macintosh) key to make copies of the original extrusion lines in front of the surface aligned on the y axis.

•  Select the two original extrusion lines that go between the arcs.

•  Move the cursor near an endpoint of one of the lines. Hold down the CTRL (Windows) or OPTION (Macintosh) key and drag a copy of the lines out along the y-axis as shown in the next graphic.

[image: Ex10-5.FH7.jpg]

•  Connect the top and bottom of the lines with the Single Line tool to make a rectangle.

•  Choose 3D>Planes>Front.

•  Fillet the corners as shown.

[image: Ex10-6.FH7.jpg]

Tech Note: If the drawing looks right in the Top and Front views, then the drawing is right.

•  Make sure that the fillets are selected and use them as the boundary of a trim operation. In the Front view, trim off the parts of the surface lines that appear above the fillets.

[image: Ex10-7.FH7.jpg]

7.     Complete the curve.

•  Draw a line from the beginning of the fillet to the cylinder.

[image: Ex10-8.FH7.jpg]

•  Trim the cylinder arc.

•  Delete the construction line marking the end of the fillet.

•  Repeat the process for the other fillet.

•  Delete the profile form.

•  Use the Through-Points Spline tool to connect the endpoints of the cylinder at ends of the surface lines.

[image: Ex10-9.FH7.jpg]

8.     Save or discard the drawing.

[image: Ex10-10.FH7.jpg]

 

Conclusion

These exercises demonstrated many of the techniques for 3D drawing. They showed how to use the Z-Drafting Assistant for isometric drawing and demonstrated the Extrude and Revolve commands.

In addition to those basic construction methods, you learned how to rotate the view orientation and move the work plane. Finally, two of the most complex 3D problems were solved, intersecting multiple fillets and driving a fillet around a boundary.

Combining all these techniques with what you already know using Graphite you can create amazingly complex finished drawings.
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//// Segment Begin -- (JavaScript 1.0)



/// Section Begin - General and relative topics(JavaScript 1.0)



//{{HH_SYMBOL_SECTION

var HH_ChmFilename = "";

var HH_WindowName = "";

var HH_GlossaryFont = "";

var HH_Glossary = "";

var HH_Avenue = "";

var HH_ActiveX = false;

//}}HH_SYMBOL_SECTION



//Begin to support previous generic parameters

//Get the information about the browser.

var gstrBsAgent 	= navigator.userAgent.toLowerCase();
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var gbBsOpera7		= false;



var gbBsKonqueror3	= false;

var gbSafari3 		= false ;

var gbAIR			= (gstrBsAgent.indexOf('adobeair')!=-1);

var gbChrome 		= (gstrBsAgent.indexOf('chrome')!=-1);

var isLocal 		= document.location.protocol.substring(0, 4) == "file";

var gbChromeLocal        = window.chrome && isLocal ;

var gbInsideCHM 	= document.location.href.search("::")>0 && document.location.href.search(/chm/i)>0;

var gbBsIsMobile	= (gstrBsAgent.indexOf("mobile") != -1);

if(gbBsIsMobile == false)

{

	gbBsIsMobile = isTouchDevice();

}

function isTouchDevice() {

	return !!('ontouchstart' in window) ? 1 : 0;

}



gbBsIE = (navigator.appName.indexOf("Microsoft") != -1) && !gbBsOpera && !gbBsKonqueror && !gbBsSafari;;



if (gbBsIE)

{

	if (parseInt(navigator.appVersion) >= 4) {

		gbBsIE4 = true;

		if (gbBsIE4) {

			var nPos = gstrBsAgent.indexOf("msie");

			var strIEversion = gstrBsAgent.substring(nPos + 5);

			var nVersion =  parseFloat(strIEversion);

			if (nVersion >= 5)

				gbBsIE5 = true;

			if (nVersion >= 5.5)

			{

				if(nVersion >= 7)

					gbBsIE7 = true;

				gbBsIE55 = true;

			}

		}

	}

}

var re  = new RegExp("rv:([0-9]{1,}[\.0-9]{0,})");

if (re.exec(navigator.appVersion) != null)

{

	gbBsIE = true;

	gbBsIE4 = true;

	gbBsIE5 = true;

	gbBsIE55 = true;

}



if (gbBsNS6)

{

	var nPos=gstrBsAgent.indexOf("gecko");

	if(nPos!=-1)

	{

		var nPos2=gstrBsAgent.indexOf("/", nPos);

		if(nPos2!=-1)

		{

			var nVersion=parseFloat(gstrBsAgent.substring(nPos2+1));

			if (nVersion>=20020823)

				gbBsNS7=true;

		}

	}	

}

if (gbBsOpera)

{

	var nPos = gstrBsAgent.indexOf("opera");

	if(nPos!=-1)

	{

		var nVersion = parseFloat(gstrBsAgent.substring(nPos+6));

		if (nVersion >= 6)

		{

			gbBsOpera6=true;

			if (nVersion >=7)

				gbBsOpera7=true;	

		}

	}

}

if (gbBsKonqueror)

{

	var nPos = gstrBsAgent.indexOf("konqueror");

	if(nPos!=-1)

	{

		var nVersion = parseFloat(gstrBsAgent.substring(nPos+10));

		if (nVersion >= 3)

		{

			gbBsKonqueror3=true;

		}

	}

}



if(gbBsSafari)

{

	var nPos = gstrBsAgent.indexOf("version/");

	if(nPos!=-1)

	{

		var nVersion = parseFloat(gstrBsAgent.substring(nPos+8,nPos+9));

		if (nVersion >= 3)

		{

			gbSafari3=true;

		}

	}

}



if(gbChrome)

{

	//for the time being use same tests as safari

	gbBsSafari 	= true ;

	gbSafari3	= true;

}



function insertAdjacentHTML(obj, where, htmlStr)

{

	if (gbBsIE || gbBsOpera7)

	{

		obj.insertAdjacentHTML(where, htmlStr);

	}

	else if (gbBsNS6 || gbBsSafari)

	{

		var r = obj.ownerDocument.createRange();

		r.setStartBefore(obj);

		var	parsedHTML = r.createContextualFragment(htmlStr);

		

		switch (where){

		case 'beforeBegin':

			obj.parentNode.insertBefore(parsedHTML,obj);

			break;

		case 'afterBegin':

			obj.insertBefore(parsedHTML,obj.firstChild);

			break;

		case 'beforeEnd':

			obj.appendChild(parsedHTML);

			break;

		case 'afterEnd':

			if (obj.nextSibling){

			obj.parentNode.insertBefore(parsedHTML,obj.nextSibling);

			} else {

			obj.parentNode.appendChild(parsedHTML);

			}

			break;

		}

	}

}





function setAttribute(obj, attr, val)

{

	if (gbBsIE)

	    obj.setAttribute(attr,val);

	else

	{

	    if (obj.setAttribute)

	        obj.setAttribute(attr,val);

	    else

	        obj.setProperty(attr,val,null);

	}       

};



function getAttribute(obj, attr)

{

   if (gbBsIE)

	    return obj.getAttribute(attr);

	else

	{

	    if ((obj.getAttribute)&&(obj.getAttribute(attr)))

	        return obj.getAttribute(attr);	  

	     else if ((obj.getPropertyValue)&&(obj.getPropertyValue(attr)))

	        return obj.getPropertyValue(attr) ;

	     else if ((obj.getPropertyCSSValue)&&(obj.getPropertyCSSValue(attr)))

	        return obj.getPropertyCSSValue(attr) ;

	     else

	        return null ;

	}          

};



// Utilities functions.

function BsscHasExtJs()

{

	if( gbBsIE3Before || gbBsNS3Before)

		return false;

	return true;

}



// Register event handler

var gBsOnLoads 			= new Array();	// An array holds all the onload event handler.

var gBsOnClicks 		= new Array();	// An array holds all the onClick event handler.

var gBsOnUnLoads 		= new Array();	// An array holds all the OnUnLoad event handler.

var gBsOnMouseOvers 	= new Array();	// An array holds all the OnMouseOver event handler.

var gBsOnMouseOuts 		= new Array();	// An array holds all the OnMouseOut event handler.



var gbOrignalOnMouseDown = null;



function BsscRegisterOnLoad(funcHandler)

{

	var nLength = gBsOnLoads.length;

	gBsOnLoads[nLength] = funcHandler;

}



function BsscRegisterOnClick(funcHandler)

{

	var nLength = gBsOnClicks.length;

	gBsOnClicks[nLength] = funcHandler;

}



function BsscRegisterOnUnLoad(funcHandler)

{

	var nLength = gBsOnUnLoads.length;

	gBsOnUnLoads[nLength] = funcHandler;

}



function BsscRegisterOnMouseOver(funcHandler)

{

	var nLength = gBsOnMouseOvers.length;

	gBsOnMouseOvers[nLength] = funcHandler;

}



function BsscRegisterOnMouseOut(funcHandler)

{

	var nLength = gBsOnMouseOuts.length;

	gBsOnMouseOuts[nLength] = funcHandler;

}



function BsGeneralOnLoad()

{

	if (!gbBsIE4 && !gbBsNS4)

		return;



	// Make everything visible in navigator

//	if (gbBsNS4) {

//		// Make some special effects items visible

//		var arr ;

//		if (gbBsNS6)

//		    arr = document.getElementsByTagName('*');

//		else

//		    arr = document.layers ;

//		for (var iLayer = 0; iLayer < arr.length; iLayer++) {

//			arr[iLayer].visibility = "visible";

//			arr[iLayer].left = 0 + 'px';

//		}

//	}	

	

}



// If resize the netscape browser, need to reload it.

function BsReDo()

{

  if (innerWidth != origWidth || innerHeight != origHeight)

     location.reload();

}

// End of the local functions.



// The following functions are used by the html files.

function BSSCOnLoad(event)

{

	if( !BsscHasExtJs() )

		return;

	for (var nElement = gBsOnLoads.length - 1; nElement >= 0; nElement--)

		gBsOnLoads[nElement]();

}



function BSSCOnClick(event)

{

	if (!BsscHasExtJs()) return;

		

	for (var nElement = gBsOnClicks.length - 1; nElement >= 0; nElement--)

		gBsOnClicks[nElement]();

}



function BSSCOnUnload(event)

{

	if (!BsscHasExtJs()) return;

	for (var nElement = gBsOnUnLoads.length - 1; nElement >= 0; nElement--)

		gBsOnUnLoads[nElement]();

}



function BSSCOnMouseOver(event)

{

	if (!BsscHasExtJs()) return;

	for (var nElement = gBsOnMouseOvers.length - 1; nElement >= 0; nElement--)

		gBsOnMouseOvers[nElement]();

}



function BSSCOnMouseOut(event)

{

	if (!BsscHasExtJs()) return;

	for (var nElement = gBsOnMouseOuts.length - 1; nElement >= 0; nElement--)

	{

		gBsOnMouseOuts[nElement]();

	}

}

// End of invocation of the event handle functions.



// Add the GereralOnLoad to the onload array.

if (typeof(BsscRegisterOnLoad) != "undefined")

{

	BsscRegisterOnLoad(BsGeneralOnLoad);

}

if (gbBsNS4&&!gbBsNS6) {

	origWidth = innerWidth;

	origHeight = innerHeight;

	onresize = BsReDo;

}

//End to support previous generic parameters



//Begin to support previous HHActiveX invoking

function BsHHActivateComponents()

{

	if( HH_ActiveX && (HH_ChmFilename != "") && ((self == top) || (self == top.frames[0])))

	{

		var objBody = getElementsByTag(document,"BODY")[0];

		if( typeof(objBody) == "object" )

		{

			insertAdjacentHTML(objBody, "beforeEnd", '<OBJECT ID="HHComponentActivator" CLASSID="CLSID:399CB6C4-7312-11D2-B4D9-00105A0422DF" width=0 height=0></OBJECT>');

			if (HHComponentActivator.object)

				HHComponentActivator.Activate(HH_ChmFilename, HH_WindowName, HH_GlossaryFont, HH_Glossary, HH_Avenue);

		}

	}

}



function BsHHActivXOnLoad()

{	

	if( gbBsIE4 )

		BsHHActivateComponents(); 

}



if( typeof(BsscRegisterOnLoad) != "undefined" )

{

	BsscRegisterOnLoad(BsHHActivXOnLoad);

}

//End to support previous HHActiveX invoking



//Begin to support previous relative topics

//If webHelp needs Related Topics DHTMLcode, it's supposed to add it here

var gbPopupMenuTimeoutExpired = false;

var gbInPopupMenu = false;

var gbPopupMenuTopicList = null;

var gOlddocumentClick = null;



//////////////////////////////////////////////////////////////////////////////////////////

//

// Popup Menu code

//

//////////////////////////////////////////////////////////////////////////////////////////



var g_bIsPopupMenuInit = false;

function _WritePopupMenuLayer()

{

	if (!g_bIsPopupMenuInit)

        {

	  if (gbBsNS4&&!gbBsNS6) {

//Do not try to write ininle styles for NS!  NS can not handle it and will not stop downloading the html page...

	   	document.write("<DIV CLASS='WebHelpPopupMenu' ID='PopupMenu'></DIV>");

	  } else{

	  document.write("<DIV ID='PopupMenu' STYLE='position:absolute; left:0px; top:0px; z-index:4; visibility:hidden;'></DIV>");

	  if (!(gbBsNS4&&!gbBsNS6)) {

		document.write("<STYLE TYPE='text/css'>");

		if (gbBsMac&&gbBsIE4) {

			document.write(".PopupOver {font-family:'Arial'; color:white; background:navy; font-size:10pt; font-style:normal;font-weight:normal;text-decoration:none;}");

			document.write(".PopupNotOver {font-family:'Arial'; color:black; background:#c0c0c0; font-size:10pt; font-style:normal;font-weight:normal;text-decoration:none;}");

		} else {

			document.write(".PopupOver {font-family:'Arial'; color:white; background:navy; font-size:8pt; font-style:normal;font-weight:normal;text-decoration:none;}");

			document.write(".PopupNotOver {font-family:'Arial'; color:black; background:#c0c0c0; font-size:8pt; font-style:normal;font-weight:normal;text-decoration:none;}");

		}

		document.write("</STYLE>");

	   }

          }

	  g_bIsPopupMenuInit = true;

	}

}



//Seek for the bsscright frame 

function _SeekFrameByName( cRoot, strName )

{

	if( cRoot == null )	return null;

	if( cRoot.frames == null )	return null;

	if( cRoot.frames[strName] != null )	return cRoot.frames[strName];

	for (var i=0; i<cRoot.frames.length; i++)

	{

		var cObj = null;

		if (!gbBsNS6) 

			cObj = _SeekFrameByName( cRoot.frames(i).document, strName );

		else

			cObj = _SeekFrameByName( cRoot.frames[i], strName );

		if( cObj != null )		return cObj;

	};

	return null;

}

function _GetFrameByName( cRoot, strName )

{

	if( cRoot == null )	return null;

	var cRet = _SeekFrameByName(cRoot, strName);

	if( cRet != null )	return cRet;

	if (cRoot.parent != cRoot)

		return _GetFrameByName( cRoot.parent, strName );

	else

		return null;

}



var gfn_arguments = null;

function _PopupMenu_Invoke(fn_arguments)

{

	gfn_arguments = fn_arguments;

	if (gbBsOpera6&&gbBsMac)

	{

		var wndOldPopupLinks= window.open(document.location.href, "popuplinks");

		wndOldPopupLinks.close();

		setTimeout("_PopupMenu_Invoke_2();",100);

	}

	else

	{

		_PopupMenu_Invoke_2();

	}

}



function GetXOffset(el) {

    var offX = 0;

    while (el && typeof (el.offsetLeft) != 'undefined' && typeof (el.offsetParent) != 'undefined') 

    {

        offX = offX + el.offsetLeft;

        el = el.offsetParent;

    }

    return offX;

}



function GetYOffset(el) 

{

    var offY = 0;

    while (el && typeof (el.offsetTop) != 'undefined' && typeof (el.offsetParent) != 'undefined') 

    {

        offY = offY + el.offsetTop;

        el = el.offsetParent;

    }

    return offY;

}



function _PopupMenu_Invoke_2()

{

	var fn_arguments = gfn_arguments;

	gfn_arguments = null;

	

	// Make sure we have reasonable arguments

	var argLen = fn_arguments.length;

	if (argLen < 3) {

		return false;

	}



	// Check to see if we only have one target

	var strTarget = "";

	var targetDoc = null;

	if (fn_arguments[1] == '') {

		if (BSSCPopup_IsPopup()) {

			targetDoc = parent;

			strTarget = "TARGET= _parent";

		}

		else

			targetDoc = window.document;

	} else {

		targetDoc = _GetFrameByName( parent, fn_arguments[1] );



		strTarget = "TARGET='" + fn_arguments[1] + "'";

	}



	if ((!gbBsIE4 && !gbBsNS4 && !gbBsOpera7 && !gbBsKonqueror3 &&!gbBsSafari) || ((gbBsMac) && (gbBsIE4) && (window.event.srcElement.tagName == "AREA"))) {

	

		var argLen 	= fn_arguments.length;



		// Create the window that the hyperlinks will go into

		var nHeight = argLen * 15;

		var nWidth = 400;

		var strParam = "titlebar=no,toolbar=no,status=no,location=no,menubar=no,resizable=yes,scrollbars=auto";

		strParam += ",height=" + nHeight + ",width=200";

		strParam += ",resizable";



		var wndTemp=null;

		// Create a temporary window first to ensure the real popup comes up on top

		if (!gbBsOpera)

			wndTemp = window.open("", "temp", strParam);



		// Create the real popup window

		var wndPopupLinks=null;

		if (gbBsOpera&&gbBsMac)

		{

			wndTemp = window.open(document.location.href, "temp", strParam);

			wndPopupLinks= window.open(document.location.href, "popuplinks", strParam);

		}

		else

			wndPopupLinks= window.open("", "popuplinks", strParam);

		wndPopupLinks.document.open("text/html");



		// Close the temporary

		if (wndTemp)

			wndTemp.close();



		var sHTML="<html><head>";

		sHTML += "<";

		sHTML += "/head>";

		sHTML+="<body onBlur=\'self.focus();\'>";

		var strParaLine = "";

		for (var i = 0; i < (argLen - 2) / 2; i++) {

			strParaLine = "";

			strParaLine += "<a href=\"javascript:";

			if (gbBsIE) {

				strParaLine += "onBlur=null; ";

			}

			strParaLine += "opener.location=\'";

			strParaLine += fn_arguments[2 * i + 3];

			strParaLine += "\';close();\"";

			strParaLine += strTarget;



			strParaLine += ">";

			strParaLine += fn_arguments[2 * i + 2];

			strParaLine += "</a>";

			strParaLine += "<br>";

			sHTML+=strParaLine;

		}

		sHTML+="</body></html>";

		wndPopupLinks.document.write(sHTML);

		wndPopupLinks.document.close();

		window.gbInPopupMenu = true;

		if (!gbBsIE) {

			wndPopupLinks.focus();

		}

		return false;

	}



	if (((argLen < 5) && ((isNaN(fn_arguments[2])) || (gbPopupMenuTopicList == null))) ||

		((argLen < 4) && ((!isNaN(fn_arguments[2])) && (gbPopupMenuTopicList != null)))) {

		// Get the place that we will be putting the topic into

		var strURL = "";

		if (isNaN(fn_arguments[2]) ||  (gbPopupMenuTopicList == null)) {

			strURL = fn_arguments[3];

		}

		else 	{

			strURL = gbPopupMenuTopicList[fn_arguments[2]].strURL;

		}



		if (targetDoc != null) {

			targetDoc.location.href = strURL;

		}

		else {

			if (fn_arguments[1] != null && typeof(fn_arguments[1]) != "undefined")

				window.open(strURL, fn_arguments[1]);

			else

				window.open(strURL);

		}		

		window.gbInPopupMenu = true;

		return false;

	}

	

	var strMenu = "";

	if (gbBsNS4&&!gbBsNS6) {

		strMenu = '<TABLE BORDER="1" CELLSPACING=0 CELLPADDING=3 BGCOLOR="#c0c0c0">';

	} else {

		strMenu = '<TABLE STYLE="border:2px outset white;" CELLSPACING=0';

		if (gbBsMac) {

			strMenu += ' CELLPADDING=4';

		} else {

			strMenu += ' CELLPADDING=2';

		}	

		strMenu += ' BGCOLOR=#c0c0c0>';

	}

	// Add each of the items

	var i = 2;

	while (i <= argLen - 1) {

		strMenu += '<TR><TD><NOBR>'

		// If the destination is a number then look it up in the topic list

		if (isNaN(fn_arguments[i]) ||  (gbPopupMenuTopicList == null)) {

			strMenu += '<DIV class="PopupNotOver" STYLE="padding-left:3pt; padding-right:3pt;"><A HREF="' + fn_arguments[i + 1] + '"' + strTarget;

		} else {

			strMenu += '<DIV class="PopupNotOver" STYLE="padding-left:3pt; padding-right:3pt;"><A HREF="' + gbPopupMenuTopicList[fn_arguments[i]].strURL + '"' + strTarget;

		}

		strMenu += ' onclick="PopupMenu_HandleClick(event);"';

		strMenu += ' onmouseover="PopupMenu_Over(event);"';

		strMenu += ' onmouseout="PopupMenu_Out(event);"';

		strMenu += '>';

		if (isNaN(fn_arguments[i]) || (gbPopupMenuTopicList == null)) {

			strMenu += '<SPAN CLASS="PopupNotOver">' + fn_arguments[i] + '</SPAN>';

		} else {

			strMenu += '<SPAN CLASS="PopupNotOver">' + gbPopupMenuTopicList[fn_arguments[i]].strTitle + '</SPAN>';

		}

		strMenu += '</A></DIV></NOBR></TD></TR>';



		if (isNaN(fn_arguments[i]) || (gbPopupMenuTopicList == null)) {

			i += 2;

		} else {

			i += 1;

		}

	}

	strMenu += "</TABLE>";



	if (gbBsMac) {

	// totally hack. because ie5 in mac need something. </TABLE> is one of them. mac is mad.

		strMenu +="<TABLE></TABLE>";

	}



	var layerPopup = null;

	var stylePopup = null;

	var nEventX = 0;

	var nEventY = 0;

	var nWindowWidth = 0;



	var nPopupHeight = 0;

	var nPopupWidth = 0;



	var e = fn_arguments[0];

	if (typeof (window.event) != 'undefined' && typeof (window.event.clientX) != 'undefined' && typeof (window.event.clientX) == 'number') 

    {

	    nEventX = window.event.clientX;

	    nEventY = window.event.clientY;

	}

	else 

    {

        if (typeof (e.clientX) != 'undefined') 

        {

	        nEventX = e.clientX;

	        nEventY = e.clientY;

	    }

	    else if (typeof (e.pageX) != 'undefined') 

        {

	        nEventX = e.pageX;

	        nEventY = e.pageY;



	        nEventX -= getScrollLeft();

	        nEventY -= getScrollTop();



	    }

	}



	_BSPSGetClientSize();



	var bFoundBrowser = true;

	if (gbBsIE4 || gbBsOpera7) 

    {

	    layerPopup = getElement("PopupMenu");

		layerPopup.innerHTML = strMenu;

		stylePopup = layerPopup.style;

	    nPopupHeight = layerPopup.scrollHeight;

	    nPopupWidth = layerPopup.scrollWidth;

	    if (gbBsMac) 

        {

	        nPopupWidth = 80; // we have no idea how to get the dynamic width of the popup.

	    }

	}

	else if (gbBsNS6 || gbBsKonqueror3 || gbBsSafari) 

    {

	    layerPopup = getElement("PopupMenu");

		layerPopup.style.visibility = "hidden";

		layerPopup.innerHTML = strMenu;

	    nPopupHeight = layerPopup.offsetHeight;

	    nPopupWidth = layerPopup.offsetWidth;

	}

	else if (gbBsNS4) 

    {

	    layerPopup = document.layers.PopupMenu;

	    layerPopup.visibility = "hide";

	    stylePopup = layerPopup.document;

	    stylePopup.write(strMenu);

	    stylePopup.close();



	    nPopupHeight = layerPopup.clip.height;

	    nPopupWidth = layerPopup.clip.width;

	}

	else

	    bFoundBrowser = false;



	if (bFoundBrowser)

    {

	    if (nEventY + nPopupHeight + 20 < gBsClientHeight) 

        {

	        nEventY += 20;

	    }

	    else 

        {

            nEventY = gBsClientHeight - nPopupHeight - 20;

	    }



        if (nEventX + nPopupWidth + 20 < gBsClientWidth) 

        {

            nEventX += 20;

        }

        else 

        {

            nEventX = gBsClientWidth - nPopupWidth - 20;

        }



        var par = layerPopup.offsetParent;

        var offX = 0, offY = 0;

        if (typeof(par) != 'undefined' && par) 

        {

            offX = GetXOffset(par);

            offY = GetYOffset(par);

        }



        nEventX += getScrollLeftElement(par);

        nEventX -= offX;

        nEventY += getScrollTopElement(par);

        nEventY -= offY;

    }



	if (gbBsIE4 || gbBsOpera7) 

    {

	    stylePopup.top = nEventY;

	    if (typeof (stylePopup.top) != 'number' ) 

        {

	        stylePopup.top = nEventY + "px";

	    }

	    stylePopup.left = nEventX;

	    if (typeof (stylePopup.left) != 'number' ) 

        {

	        stylePopup.left = nEventX + "px";

	    }



	    stylePopup.visibility = "visible";

	    if (!gOlddocumentClick && document.onclick)

	        gOlddocumentClick = document.onclick;

	    document.onclick = PopupMenu_HandleClick;

	}

	else if (gbBsNS6 || gbBsKonqueror3 || gbBsSafari) 

    {

	    if (gbBsNS6 || gbChrome || gbSafari3)

	        layerPopup.style.top = nEventY + "px";

	    else

	        layerPopup.style.top = nEventY;

	    if (gbBsNS6 || gbChrome || gbSafari3)

	        layerPopup.style.left = nEventX + "px";

	    else

	        layerPopup.style.left = nEventX;

	    // set again to avoid the stupid frash in netscape 6.

	    layerPopup.innerHTML = strMenu;

	    layerPopup.style.visibility = "visible";

	    //window.captureEvents(Event.MOUSEDOWN);

	    if (!gOlddocumentClick && document.onclick)

	        gOlddocumentClick = document.onclick;

	    window.onclick = PopupMenu_HandleClick;

	}

	else if (gbBsNS4) 

    {

	    layerPopup.left = nEventX;

	    layerPopup.top = nEventY;

	    layerPopup.visibility = "visible";

	    window.captureEvents(Event.MOUSEDOWN);

	    if (!gOlddocumentClick && document.onmousedown)

	        gOlddocumentClick = document.onmousedown;

	    window.onmousedown = PopupMenu_HandleClick;

	}



	if(window.addEventListener)

	{

		var popupDivElem = getElement("PopupMenu");

		if(typeof(popupDivElem) != 'undefined')

			popupDivElem.addEventListener("touchstart", onPopupDivTouched, false);



		window.document.addEventListener("touchstart", onPopupParentTouched, false);

	}

	



	window.gbInPopupMenu = true;

	window.gbPopupMenuTimeoutExpired = false;

	setTimeout("PopupMenu_Timeout();", 100);

	return false;

}



function PopupMenu_Timeout()

{

	window.gbPopupMenuTimeoutExpired = true;

}



function PopupMenu_Over(e)

{

    if (gbBsIE4||gbBsOpera7)

		e.srcElement.className = "PopupOver";

    else if (gbBsNS6)

		e.target.parentNode.className = "PopupOver";

	return;

}



function PopupMenu_Out(e)

{

    if (gbBsIE4||gbBsOpera7)

		e.srcElement.className = "PopupNotOver";

    else if (gbBsNS6)

		e.target.parentNode.className = "PopupNotOver";

	return;

}

function onPopupDivTouched(e)

{

	if(typeof(e) != 'undefined' && e)

		e.stopPropagation();

}



function onPopupParentTouched(e)

{

	if(window.removeEventListener)

	{

		var popupDivElem = getElement("PopupMenu");

		if(typeof(popupDivElem) != 'undefined')

			popupDivElem.removeEventListener("touchstart", onPopupDivTouched, false);

		window.removeEventListener("touchstart", onPopupParentTouched, false);

	}



	PopupMenu_HandleClick(e);

}



function PopupMenu_HandleClick(e)

{

	if (window.gbPopupMenuTimeoutExpired) {

		window.gbInPopupMenu = false;

		if (gbBsNS4 && !gbBsNS6) {

			window.releaseEvents(Event.MOUSEDOWN);

		}



		var layerPopup = null;

		if (gbBsNS4&&!gbBsNS6) {

			layerPopup = document.layers.PopupMenu;

			layerPopup.visibility = "hide";

		} else {

			layerPopup = getElement("PopupMenu");

			layerPopup.style.visibility = "hidden";

		}

	

		if (gOlddocumentClick)

		{

			if (gbBsNS4 && !gbBsNS6)

				document.onmousedown = gOlddocumentClick;

			else

				document.onclick = gOlddocumentClick;

		}

	}

	return;

}



function BSSCPopup_ClickMac()

{

	if ((!DHTMLPopupSupport()) && (gbBsIE4 || gbBsOpera7))

	{	

		var bClickOnAnchor = false;

		var el;

		if ((window.event != null) &&

		    (window.event.srcElement != null))

		{

		    el = window.event.srcElement;

			while (el != null)

			{

				if ((el.tagName == "A") || (el.tagName == "AREA")) 	{

					bClickOnAnchor = true;

					break;

				}

				if (el.tagName == "BODY") {

					break;

				}

				el = getParentNode(el);

			}

		}

		if (BSSCPopup_IsPopup())

		{

			if (!bClickOnAnchor) {

				parent.window.gPopupWindow = null;

				self.close();

			}

		}

		else

		{

			bClosePopupWindow = true;

			if ((bClickOnAnchor) &&

				(el.href) &&

			    ((el.href.indexOf("javascript:BSSCPopup") != -1) || (el.href.indexOf("javascript:null") != -1) || (el.href.indexOf("javascript:void(0)") != -1)))

			{

				bClosePopupWindow = false;

			}

			if (bClosePopupWindow)

			{

				if (window.gPopupWindow != null && !window.gPopupWindow.closed )

				{

					window.gPopupWindow.close();

				}

			}

		}

	}

}



function BsPopupOnClick()

{

	if (!gbBsIE4 && !gbBsOpera7)

		return;



	BSSCPopup_ClickMac();

}



function _BSSCOnError(message)

{

	if(-1 != message.indexOf("denied") 

		|| -1 != message.indexOf("Object required"))

	 return true;

}



//End to support previous relative topics



/// Section End - General and relative topics (JavaScript 1.0)



/// Section Begin  - Popup (JavaScript 1.0)

//Begin to support previous popup functions



//variables used to isolate the browser type

var gBsStyVisShow	= null;

var gBsStyVisHide	= null;

var gBsClientWidth	= 640;

var gBsClientHeight = 480;



// here is the varible for judge popup windows size. these parameter is for IE5.0, it may need adjust for others.

var gBRateH_W		= 0.618; // 1.618 Golden cut.

var gBMaxXOfParent	= 0.8; 

var gBMaxYOfParent	= 0.8;

var gBscrollHeight   = 16;

var gBscrollWidth   =  16;

var gBpermitXDelta	= 3;

var gBpermitYDelta	= 3;





var arrayPopupURL = new Array();

var arrayAbsPopupURL = new Array();

var arrayIntervalId = new Array();



var arrayDirty = new Array();



function getBRateH_W()

{

	return 0.618 ;

}



function getBscrollWidth()

{

	return 16 ;

}



function getBscrollHeight()

{

	return 16 ;

}



function getBMaxXOfParent()

{

	return 0.8 ;

}



function getBMaxYOfParent()

{

	return 0.8 ;

}



function setIntervalID(nIndex,id)

{

    arrayIntervalId[nIndex] = id;

}



function getIntervalID(nIndex)

{

	if (nIndex == -1 || arrayIntervalId.length <= nIndex) 

	    return -1;

	else

        return arrayIntervalId[nIndex];

}



function setAbsPopupURL(nIndex, strURL)

{

	arrayAbsPopupURL[nIndex] = strURL;

}



function getAbsPopupURL(nIndex)

{

	if (nIndex == -1 || arrayAbsPopupURL.length <= nIndex) return null;

	else 

		return arrayAbsPopupURL[nIndex];

}



function getPopupURL(nIndex)

{

	if (nIndex == -1 || arrayPopupURL.length <= nIndex) return null;

	else 

		return arrayPopupURL[nIndex];

}



function getPopupID(nIndex)

{

	return gstrPopupID + nIndex;

}



function getPopupShadowID(nIndex)

{

	return gstrPopupShadowID + nIndex;

}



function getPopupTopicID(nIndex)

{

	return gstrPopupTopicID + nIndex;

}



function getPopupIFrameID(nIndex)

{

	return gstrPopupIFrameID + nIndex;

}



function getPopupIFrameName(nIndex)

{

	return gstrPopupIFrameName + nIndex;

}





function getPopupTopicStyle(nIndex)

{

	return getElement(getPopupTopicID(nIndex)).style;

}



function getPopupShadowStyle(nIndex)

{

	return getElement(getPopupShadowID(nIndex)).style;

}



function getPopupIFrame(nIndex)

{

	if(gbAIR)

	{

		return window.frames[getPopupIFrameName(nIndex)];

	}

	else

	{

		if (gbBsNS6||gbSafari3)

			return eval("window.frames['" + getPopupIFrameName(nIndex) + "']");

		else

			return eval("document.frames['" + getPopupIFrameName(nIndex) + "']");

	}

}



function getPopupDivStyle(nIndex)

{

	return getElement(getPopupID(nIndex)).style;

}



function getPopupIFrameStyle(nIndex)

{

	return getElement(getPopupIFrameID(nIndex)).style;

}





function findDiv(strURL)

{

	for (var i = 0; i < arrayPopupURL.length; i ++ ) {

		if (arrayPopupURL[i] == strURL) {

			return i;

		}

	}

	return -1;

}



var gnToken = -1;

function takeToken()

{

	gnToken ++;

	if (gnToken > 10000) gnToken = 0;

	return gnToken;

}



function IsValidToken(nToken)

{

	return (gnToken == nToken);

}



function addDiv(strURL)

{

	for (var i = 0; i < arrayPopupURL.length; i ++) {

		if (arrayPopupURL[i] == null) {

			arrayPopupURL[i] = strURL;

			return i;

		}

	}	

	arrayPopupURL[i] = strURL;

	arrayDirty[i] = true;

	return i;

}



function setDirty()

{

	for (var i = 0; i < arrayPopupURL.length; i ++ )

		arrayDirty[i] = true;

}



function IsDirty(nIndex)

{

	if (nIndex == -1)

		return true;

	else 

		if (arrayDirty.length > nIndex) 

			return arrayDirty[nIndex];

		else

			return true;

}



function hideAll()

{

	for (var i = 0; i < arrayPopupURL.length; i ++ )

	{

		getPopupDivStyle(i).visibility = gBsStyVisHide;

		getPopupIFrameStyle(i).visibility = gBsStyVisHide;

		if(gbBsIE)

		    removeThis(document.all(getPopupID(i)));

	}

	if(gbBsIE)

		arrayPopupURL.length = 0;

}



function getCurrentPopupIFrame()

{

	for (var i = 0; i < arrayPopupURL.length; i ++)

		if (getPopupDivStyle(i).visibility == gBsStyVisShow)

			return getPopupIFrame(i);

	return null;

}



function setClear(nIndex)

{

	if (nIndex != -1)

		arrayDirty[nIndex] = false;

}



function _BSSCCreatePopupDiv(strURL)

{

	var nIndex = findDiv(strURL);

	if (nIndex == -1 ) {

		nIndex = addDiv(strURL);

		BsPopup_CreateDiv(nIndex);

	}

	else {

		if (IsDirty(nIndex)) {

			if("object" == typeof(getPopupIFrame(nIndex).document))

				getPopupIFrame(nIndex).document.location.href = strURL;

		}

	}

	return nIndex;

}



//Here is the browser type 

function _BSPSGetBrowserInfo()

{

	if (gbBsNS4&&!gbBsNS6)

	{

		gBsStyVisShow	= "show";

		gBsStyVisHide	= "hide";

	}

	else

	{

		gBsStyVisShow	= "visible";

		gBsStyVisHide	= "hidden";

	}

}



_BSPSGetBrowserInfo();



//Get client size info

function _BSPSGetClientSize()

{

	if( typeof( window.innerWidth ) == 'number' )

	{

		gBsClientWidth	= innerWidth;

		gBsClientHeight = innerHeight;

	}

	else if( document.documentElement && ( document.documentElement.clientWidth || document.documentElement.clientHeight ) )

	{

		gBsClientWidth = document.documentElement.clientWidth;

		gBsClientHeight = document.documentElement.clientHeight;

	} 

	else if( document.body && ( document.body.clientWidth || document.body.clientHeight ) ) 

	{

		gBsClientWidth = document.body.clientWidth;

		gBsClientHeight = document.body.clientHeight;

	}

}



var gstrPopupID = 'BSSCPopup';

var gstrPopupShadowID = 'BSSCPopupShadow';

var gstrPopupTopicID = 'BSSCPopupTopic';

var gstrPopupIFrameID = 'BSSCPopupIFrame';

var gstrPopupIFrameName = 'BSSCPopupIFrameName';



var gstrPopupSecondWindowName = 'BSSCPopup';



var gPopupWindow = null;

var gnPopupClickX = 0;

var gnPopupClickY = 0;



var gnPopupScreenClickX = 0;

var gnPopupScreenClickY = 0;



var gbPopupTimeoutExpired = false;



function DHTMLPopupSupport()

{

	if (((gbBsIE4) && (!gbBsMac))||gbBsOpera7|| gbBsNS7 || gbSafari3||gbAIR) {

		return true;

	}

	return false;

}



function BSSCPopup_IsPopup()

{

	if (DHTMLPopupSupport() && (this.name.indexOf(gstrPopupIFrameName) != -1)) {

		return true;

	} else if ((gbBsNS4 || gbBsIE4 || gbBsOpera7) && (this.name.indexOf(gstrPopupID) != -1)) {

		return true;

	} else {

		return false;

	}

}



// If there is a hyperlink in a popup window, display the hyperlink in

// the original window. (bsscright)

//commenting this as we are opening popup links in its parent

//also in multiscreen bsscright is not the the name of topic frame, relevant only in webhelp

/*if (BSSCPopup_IsPopup() && !gbBsIE4 && !gbBsOpera7) {

document.write("<base target=\"bsscright\">");

}*/



// Local functions.

function BsPopup_CreateDiv(nIndex)

{

	if(!DHTMLPopupSupport())

		return;

	// DO NOT SET Width and height for the div, otherwize it will make IE4 popup do not work when view the topic alone.

	var strPopupDiv = "<DIV ID='" + getPopupID(nIndex) + "' STYLE='position:absolute; top:-100; left:0; z-index:600; visibility:hidden;'>";

	strPopupDiv += "<DIV ID='" + getPopupShadowID(nIndex) + "' STYLE=\"position:absolute;top:0; left:0;  background-color:#C0C0C0;\"></DIV>";

	strPopupDiv += "<DIV ID='" + getPopupTopicID(nIndex) + "' STYLE=\"position:absolute;top:0; left:0;  background-color:#FFFFFF;border:1px #000000 outset;\">";

	strPopupDiv += "<IFRAME title=\"Popup Window\" ID='" + getPopupIFrameID(nIndex) + "' name='" + getPopupIFrameName(nIndex) + "' src = '" + getPopupURL(nIndex) + "' frameborder=0 scrolling=auto></IFRAME>";

	strPopupDiv += "</DIV></DIV>";



	var objBody = getElementsByTag(document, "BODY")[0];

	if( typeof(objBody) != "object" )

		return;



	insertAdjacentHTML(objBody, "beforeEnd", strPopupDiv);

}



function handleLoadNS()

{

	if (this.id)

	{

		var nIndex = parseInt(this.id.substring(gstrPopupIFrameID.length));

		BSSCPopup_PostWork(nIndex);

	}

}



function BSSCPopup_PostWork(nIndex)

{

	getPopupDivStyle(nIndex).visibility = gBsStyVisShow;

	getPopupIFrameStyle(nIndex).visibility =gBsStyVisShow;



	setClear(nIndex);

	window.gbPopupTimeoutExpired = true;



	try{

		BSSCPopup_ChangeTargettoParent(getPopupIFrame(nIndex).document);

		if (gbBsNS6)

			getPopupIFrame(nIndex).document.body.addEventListener("click",BSSCPopupClicked,false);

		else

			getPopupIFrame(nIndex).document.body.onclick = BSSCPopupClicked;

	}catch(e){}



	if (!gbOrignalOnMouseDown && document.onmousedown)

		gbOrignalOnMouseDown = document.onmousedown;



	if (gbChrome || gbBsNS6)

		document.addEventListener("mousedown", BSSCPopupParentClicked,false);

	else

		document.onmousedown = BSSCPopupParentClicked;

}



function BSSCPopup_Timeout(nIndex, nToken)

{

    if (!IsValidToken(nToken)) return;



	if (gbBsNS6||((getPopupIFrame(nIndex).document.readyState == "complete") &&

		(getPopupIFrame(nIndex).document.body != null))) {

		BSSCPopup_PostWork(nIndex);

	} else {

		setTimeout("BSSCPopup_Timeout(" + nIndex + "," + nToken + ")", 100);

	}

}



// VH 08/10/00 

// do not change target to parent if the href is using javascript

function BSSCPopup_ChangeTargettoParent(tagsObject)

{

	var collA = getElementsByTag(tagsObject, "A");

	BSSCPopup_ChangeTargettoParent2(collA);



	var collIMG = getElementsByTag(tagsObject,"IMG");

	BSSCPopup_ChangeTargettoParent2(collIMG);

}



function BSSCPopup_ChangeTargettoParent2(colls)

{

	if (colls != null)  {

		for (var j = 0; j < colls.length; j ++ )

		{

			var strtemp = colls[j].href;

			if (strtemp)

			{

				strtemp = strtemp.toLowerCase();

				if (strtemp.indexOf("javascript:") == -1)

				if (colls[j].target == "")

					colls[j].target = "_parent";

			}

		}

	}

}



function BSPSPopupTopicWinHelp(strURL)

{

	_BSSCPopup(strURL);

	return;

}



function DelayBSSCPopup_AfterLoad(nIndex ,nToken ,cuswidth ,cusheight )

{

//before doing any thing clear the interval function

    var intervalID = getIntervalID(nIndex);

    if(intervalID!=-1)

        clearInterval(intervalID);

        

    BSSCPopup_AfterLoad(nIndex ,nToken ,cuswidth ,cusheight );

}



function _BSSCPopup(strURL, width, height)

{

	var cuswidth = 0;

	var cusheight = 0;

	if ("undefined" != typeof(width) && "undefined" != typeof(height)) {

		cuswidth = width;

		cusheight= height;

	}

	

	if (DHTMLPopupSupport()) {

		if(!gbAIR && !gbInsideCHM)

			rhPopupEx.createPopup(strURL, width, height);

		else 

		{	

			var nToken = takeToken(); // take  token first.

			var nIndex = _BSSCCreatePopupDiv(strURL, nToken, cuswidth, cusheight);

			window.gbPopupTimeoutExpired = false;

			var ntWidth = gBsClientWidth;

			var ntHeight = gBsClientHeight;

			_BSPSGetClientSize();

			if (ntWidth != gBsClientWidth || ntHeight != gBsClientHeight) {

				setDirty();

			}

	

			if (IsDirty(nIndex)) 

			{

				if(gbAIR)

				{

				    var tempappTimer = setInterval(function(){DelayBSSCPopup_AfterLoad(nIndex ,nToken ,cuswidth ,cusheight )}, 400);

				    setIntervalID(nIndex,tempappTimer);

				}

				else

				{

					if (gbBsMac) {

						setTimeout("BSSCPopup_AfterLoad(" + nIndex + "," + nToken + "," + cuswidth + "," + cusheight  +")", 400);

					} else {

						setTimeout("BSSCPopup_AfterLoad(" + nIndex + "," + nToken + "," + cuswidth + "," + cusheight + ")", 100);

					}

				}

			}

			else {

				MoveDivAndShow(nIndex ,nToken, cuswidth, cusheight);

			}

		}

	} else {

		_BSSCPopup2(strURL, cuswidth, cusheight);

	}

	return;

}



if (gbBsIE55)

{

	var ehlpdhtm_fOldBefureUnload = window.onbeforeunload;

	var gnBsUnload=0;

	window.onbeforeunload = window_BUnload;

}

	

function window_BUnload()

{

	gnBsUnload++;

	if (gnBsUnload>1)

		return;

	for (var i = 0; i < arrayPopupURL.length; i ++)

		removeThis(document.all(getPopupID(i)));

	arrayPopupURL.length = 0;	

	if (ehlpdhtm_fOldBefureUnload)

		ehlpdhtm_fOldBefureUnload();

}



function _BSSCPopup2(strURL, width, height)

{

	if (gbBsOpera6&&gbBsMac)

	{

		var wmTemp = window.open(document.location.href, gstrPopupSecondWindowName);

		wmTemp.close();

		setTimeout("_BSSCPopup3(\""+strURL+"\","+width+","+height+");",100);

	}

	else

		_BSSCPopup3(strURL, width, height);

}

		

function _BSSCPopup3(strURL, width, height)

{

	if (window.name == gstrPopupSecondWindowName) {

		window.location = strURL;

	} else {

		if (!gbBsMac || !gbBsNS4) {

			BSSCHidePopupWindow();

		}

		var nX = 0;

		var nY = 0;

		var nHeight = 300;

		var nWidth = 400;

		if (width > 0 && height > 0) {

			nHeight = height;

			nWidth = width;

		}

		_BSPSGetClientSize();



		nX = window.gnPopupScreenClickX;

		nY = window.gnPopupScreenClickY;



		if (nY + nHeight + 40 > screen.availHeight) {

			nY = screen.availHeight - nHeight - 40;

		}

		if (nX + nWidth + 40 > screen.availWidth) {

			nX = screen.availWidth - nWidth - 40;

		}



		// Launch a separate window

		var strParam="titlebar=no,toolbar=no,status=no,location=no,menubar=no,resizable=yes,scrollbars=yes";

		if (gbBsNS) {

			if (gbBsNS6) {

				strParam += ",Height=" + nHeight + "px,Width=" + nWidth+"px";

				strParam += ",screenX=" + nX + ",screenY=" + nY;

				strParam += ",dependent=yes";

			}

			else {

				strParam += ",OuterHeight=" + nHeight + ",OuterWidth=" + nWidth;

				strParam += ",screenX=" + nX + ",screenY=" + nY;

				strParam += ",dependent=yes";

			}

		}

		else {

			strParam += ",height=" + nHeight + ",width=" + nWidth;

			strParam += ",left=" + nX + ",top=" + nY;

		}

		if (gbBsSafari)

		{

			if (window.gPopupWindow)

				window.gPopupWindow.close();		

			window.gPopupWindow = window.open(strURL, "", strParam);

			window.gPopupWindow.name = gstrPopupSecondWindowName;

			window.gPopupWindow.moveTo(nX, nY);

			window.gPopupWindow.document.location.reload();

		}	

		else

		{

			var wmTemp=null;

			if (gbBsKonqueror3)

			{

				if (window.gPopupWindow)

					window.gPopupWindow.close();

			}

			if (gbBsOpera&&gbBsMac)

			{

				wmTemp= window.open(document.location.href, "Temp", strParam);

			}

			window.gPopupWindow = window.open(strURL, gstrPopupSecondWindowName, strParam);

			if (!gbBsIE)

				window.gPopupWindow.focus();

				

			if (wmTemp)

				wmTemp.close();

		}



		if (gbBsNS4)

			setEventHandle();

		else if (gbBsIE4 || gbBsOpera7||gbBsKonqueror3)

			setTimeout("setPopupFocus();", 100);

	}

	return;

}



function setEventHandle()

{

	window.gPopupWindow.captureEvents(Event.CLICK | Event.BLUR);

	window.gPopupWindow.onclick = NonIEPopup_HandleClick;

	window.gPopupWindow.onblur = NonIEPopup_HandleBlur;

}



function setPopupFocus()

{

	window.gPopupWindow.focus();

}



function NonIEPopup_HandleBlur(e)

{

	window.gPopupWindow.focus();

}



function NonIEPopup_HandleClick(e)

{

	// Because navigator will give the event to the handler before the hyperlink, let's

	// first route the event to see if we are clicking on a Popup menu in a popup.

	document.routeEvent(e);



	// If a popup menu is active then don't do anything with the click

	if (window.gPopupWindow.gbInPopupMenu) {

		window.gPopupWindow.captureEvents(Event.CLICK);

		window.gPopupWindow.onclick = NonIEPopup_HandleClick;

		return false;

	}



	// Close the popup window

	if(e.target.href)

	{

		if(e.target.href.indexOf("javascript:")==-1) 

		{

			if (e.target.target=="")

				window.location.href = e.target.href;

			else

				window.open(e.target.href, e.target.target);

			this.close();

		}

	} 

	else

		this.close();

	return false;

}



function BSSCPopup_AfterLoad(nIndex, nToken, cuswidth, cusheight)

{

	if (!window.getPopupIFrame(nIndex).document) {

		_BSSCPopup2(getPopupURL(nIndex), cuswidth, cusheight);

		return;

	}

	

    if (!IsValidToken(nToken)) return;



	if (gbSafari3||gbAIR)

	{

			setAbsPopupURL(nIndex, window.getPopupIFrame(nIndex).document.location.href); // change URL to abs url.

		BSSCPopup_ResizeAfterLoad(nIndex, nToken, cuswidth, cusheight);

		return;

	}

	

	if (gbBsNS6)

	{

		setAbsPopupURL(nIndex, window.getPopupIFrame(nIndex).document.location.href); // change URL to abs url.

		setTimeout("BSSCPopup_ResizeAfterLoad(" + nIndex + "," + nToken + "," + cuswidth + "," + cusheight + ")", 200);

		return;

	}

	

	if ((window.getPopupIFrame(nIndex).document.readyState == "complete") &&

		(window.getPopupIFrame(nIndex).document.body != null)) {

			if (window.getPopupIFrame(nIndex).document.location.href.indexOf("about:blank") != -1) { // add this check. IE will use about:blank" as the default vaule for Iframe.

				window.getPopupIFrame(nIndex).document.location = getPopupURL(nIndex);

				setTimeout("BSSCPopup_AfterLoad(" + nIndex + "," + nToken + "," + cuswidth + "," + cusheight + ")", 200);

			}

			else

				{

					setAbsPopupURL(nIndex, window.getPopupIFrame(nIndex).document.location.href); // change URL to abs url.

					BSSCPopup_ResizeAfterLoad(nIndex, nToken, cuswidth, cusheight);

				}

	} else {

		setTimeout("BSSCPopup_AfterLoad(" + nIndex + "," + nToken + "," + cuswidth + "," + cusheight + ")", 200);

	}

}



function BSSCPopup_ResizeAfterLoad(nIndex, nToken, cuswidth, cusheight)

{

	if (window.gbPopupTimeoutExpired) return;



    if (!IsValidToken(nToken)) return;



	getPopupDivStyle(nIndex).visibility = gBsStyVisHide;

	getPopupIFrameStyle(nIndex).visibility = gBsStyVisHide;

	if(gbBsIE)

	{

	    //fix for Popup Blank issue

	    getPopupIFrameStyle(nIndex).visibility = gBsStyVisShow;

		getPopupDivStyle(nIndex).visibility = gBsStyVisShow;

	}



	// Determine the width and height for the window

	_BSPSGetClientSize();



	var size = new BSSCSize(0, 0);



	if (cuswidth <= 0 || cusheight <= 0)

				BSSCGetContentSize(window.getPopupIFrame(nIndex), size);

			else {

		size.x = cuswidth;

		size.y = cusheight;

	}



	// Determine the width and height for the window

	var nWidth = size.x;

	var nHeight = size.y;



	// for small popup size, we should allow any size.

	// The popup size should be ok if bigger than 0

	if (nWidth < 0 || nHeight < 0) return; 	// there must be something terribly wrong.		

	

	//make the width and height same for all the browsers now

	nWidth = nWidth + 22;

	nHeight = nHeight + 10;

	

	getPopupDivStyle(nIndex).width = nWidth+ "px" ;

	getPopupDivStyle(nIndex).height = nHeight+ "px" ;

	

	getPopupShadowStyle(nIndex).width = nWidth + "px" ;

	getPopupShadowStyle(nIndex).height = nHeight + "px" ;

	

	

    	getPopupTopicStyle(nIndex).width = nWidth + "px" ;

	getPopupTopicStyle(nIndex).height = nHeight + "px" ;

	

	getPopupIFrameStyle(nIndex).width = nWidth + "px" ;

	getPopupIFrameStyle(nIndex).height = nHeight + "px" ;

		

	if (gbBsIE55 || gbBsNS6 || gbSafari3||gbAIR)

	{

		getPopupIFrameStyle(nIndex).top = 0;

		getPopupIFrameStyle(nIndex).left = 0;

	}

	

	var strURL = getPopupURL(nIndex);

	if (strURL.indexOf("#") != -1&&gbBsNS6)

		getPopupIFrame(nIndex).location.reload();

	else if (strURL.indexOf("#") != -1||gbBsNS6)

		getPopupIFrame(nIndex).location.href = strURL;  // reload again, this will fix the bookmark misunderstand in IE5.

		

	MoveDivAndShow(nIndex, nToken, cuswidth, cusheight);

}



function getScrollLeft()

{

	if( typeof( window.pageXOffset) == 'number' ) 

		return window.pageXOffset ;

	else if( document.body && ( document.body.scrollLeft || document.body.scrollTop ) ) 

		return document.body.scrollLeft ;

	else if( document.documentElement && document.documentElement.scrollLeft  ) 

		return document.documentElement.scrollLeft;

	else

		return 0 ;	

}



function getScrollTop()

{

	if( typeof( window.pageYOffset) == 'number' ) 

		return window.pageYOffset ;

	else if( document.body && document.body.scrollTop ) 

		return document.body.scrollTop ;

	else if( document.documentElement && document.documentElement.scrollTop  ) 

		return document.documentElement.scrollTop;

	else

		return 0 ;	

}



function getScrollLeftElement(el) 

{

    var x = 0;

    while (el && typeof (el.scrollLeft) == 'number') 

    {

        if (el == document.body) 

        {

            var top = document.body.scrollLeft || document.documentElement.scrollLeft;

            x += top;

        }

        else

            x += el.scrollLeft;

        el = el.offsetParent;

    }

    return x;

}



function getScrollTopElement(el) 

{

    var x = 0;

    while (el && typeof (el.scrollTop) == 'number') 

    {

        if (el == document.body) 

        {

            var top = document.body.scrollTop || document.documentElement.scrollTop;

            x += top;

        }

        else

            x += el.scrollTop;

        el = el.offsetParent;

    }

    return x;

}





function MoveDivAndShow(nIndex, nToken, cuswidth, cusheight)

{

	if (window.getPopupIFrame(nIndex).document.location.href != getAbsPopupURL(nIndex)) { // if redirect, reload again.

			window.getPopupIFrame(nIndex).document.location = getPopupURL(nIndex);

			if(gbAIR)

			{

				BSSCPopup_AfterLoad(nIndex ,nToken ,cuswidth ,cusheight );

			}

			else

				setTimeout("BSSCPopup_AfterLoad(" + nIndex + "," + nToken + "," + cuswidth + "," + cusheight + ")", 200);

			return;

	}



	// Determine the position of the window

	var nClickX = window.gnPopupClickX;

	var nClickY = window.gnPopupClickY;

	var nTop = 0;

	var nLeft = 0;

	

	var nWidth = parseInt(getPopupDivStyle(nIndex).width);

	var nHeight = parseInt(getPopupDivStyle(nIndex).height);

	

	if (nClickY + nHeight + 20 < gBsClientHeight + getScrollTop()) {

		nTop = nClickY + 10;

	} else {

		nTop = (getScrollTop() + gBsClientHeight) - nHeight - 20;

	}

	if (nClickX + nWidth < gBsClientWidth + getScrollLeft()) {

		nLeft = nClickX;

	} else {

		nLeft = (getScrollLeft() + gBsClientWidth) - nWidth - 20;

	}



	if(!gbBsIE55)

	{

		if (nTop < getScrollTop()) nTop  = getScrollTop() + nTop;

		if (nLeft< getScrollLeft())  nLeft = getScrollLeft() + nLeft;

		

		if(nTop+nHeight>gBsClientHeight + getScrollTop())

		{

			nTop = (getScrollTop() + gBsClientHeight) - nHeight - 20;

		}

	}

    

   	if (isNaN(nLeft))

		getPopupDivStyle(nIndex).left = nClickX + "px";	

	else

		getPopupDivStyle(nIndex).left = nLeft+ "px";	

	

	if (isNaN(nTop))

		getPopupDivStyle(nIndex).top = nClickY  + "px";

	else

		getPopupDivStyle(nIndex).top = nTop + "px";



	// Set the location of the background blocks

	getPopupShadowStyle(nIndex).left = 6 + "px";

	getPopupShadowStyle(nIndex).top = 6 + "px";

	if (gbBsIE55)

	{

		getPopupShadowStyle(nIndex).left = 4;

		getPopupShadowStyle(nIndex).top = 4;

	}

	

	if (gbBsMac&&gbBsIE4) {

		// Total hack on the iMac to get the IFrame to position properly

		getPopupIFrameStyle(nIndex).pixelLeft = 100;

		getPopupIFrameStyle(nIndex).pixelLeft = 0;

		// Explicitly call BSSCOnLoad because the Mac doesn't seem to do it

		getPopupIFrame(nIndex).window.BSSCOnLoad();

	}



	if(gbChrome)

	{

		BSSCPopup_PostWork(nIndex);	

	}

	else if (gbBsNS6&&IsDirty(nIndex))

		getElement(getPopupIFrameID(nIndex)).addEventListener("load", handleLoadNS, false);

	else

		BSSCPopup_Timeout(nIndex , nToken );

	return;

}



function	BSSCSize(x, y)

{

	this.x = x;

	this.y = y;

}



function BSSCGetContentSize(thisWindow, size)

{

	if (!gbBsIE4 && !gbBsOpera7 && !gbBsNS4 && !gbSafari3 && !gbAIR)

		return;





	if ((gbBsMac&&gbBsIE4)||gbBsOpera7) {

		size.x = 320;

		size.y = 180;

		return;

	}



	// Resize the width until it is wide enough to handle the content

	// The trick is to start wide and determine when the scrollHeight changes

	// because then we know a scrollbar is necessary. We can then go back

	// to the next widest size (for no scrollbar)



	var ClientRate = gBsClientHeight / gBsClientWidth;



	

	var GoldenSize = new BSSCSize(0,0);

	GoldenSize.x = gBsClientWidth * getBMaxXOfParent();

	GoldenSize.y = gBsClientHeight *getBMaxYOfParent() ;



	if (ClientRate > gBRateH_W) {

		GoldenSize.y = GoldenSize.x * gBRateH_W;

	}

	else {

		GoldenSize.x = GoldenSize.y / gBRateH_W;

	}



	// Try to using parent specified max x.

	var x = 0;

	var maxgoldx = GoldenSize.x;

	var maxx = gBsClientWidth * getBMaxXOfParent();

	

	// This double resize causes the document to re-render (and we need it to)

	if (!gbBsIE5 && !gbChrome && !gbAIR)

		thisWindow.moveTo(10000,10000); // this is used to fix the flash on IE4.

	if(!gbAIR)

	{

	thisWindow.resizeTo(1, 1);

	thisWindow.resizeTo(maxgoldx, getScrollHeight(thisWindow) + getBscrollHeight());

	}

		

	var miny = getScrollHeight(thisWindow) + getBscrollHeight();

	

	if (miny > GoldenSize.y) // the popup does not fix in the parent wanted golden area. so try to expand itself as large as it can

	{

		if(gbBsIE55)

		{

			thisWindow.resizeTo(maxx , getScrollHeight(thisWindow) + getBscrollHeight());

		}

		

		miny = 	getScrollHeight(thisWindow) + getBscrollHeight();

		maxy = gBsClientHeight * getBMaxYOfParent();

		

		if (miny > maxy) { // the popup must have a scroll, OK let it be.

			miny = maxy;

			size.x = maxx;

			size.y = maxy;

			thisWindow.document.body.scroll = 'yes'; // At this time we do want to show scroll any more. so it will looks better a little.

		}

		else { // popup still can fit in the parent area by someway. now we choose the same h/w rate as parent.

			size.y = miny;

			

			//  downsize from maxx , now I try to using binary divide.

			x = maxx;

			deltax = -maxx/2;

			//j = 0;

			while (true) {

				x = x + deltax;

				if(!gbAIR)

				thisWindow.resizeTo(x, miny);

				diffy = getScrollHeight(thisWindow) + getBscrollHeight() - x * ClientRate;

				if (diffy >  gBpermitYDelta ) // it is higher than wanted, so x need to be wide a little bitter

					deltax = Math.abs(deltax) /2;

				else if (diffy <  -gBpermitYDelta) // it is shorter than wanted, so x need to be narrow a little bitter

					deltax = -Math.abs(deltax) /2;

				else 

					// the y is close enough to wanted.

					break;

				if (Math.abs(deltax) < gBpermitXDelta) // the next change is too slight and it can be ignore.

					break;

			}

			size.x = getScrollWidth(thisWindow); //+ gBscrollWidth;

			size.y = getScrollHeight(thisWindow);// + gBscrollHeight;	

			thisWindow.document.body.scroll = 'no';

		}

	}

	else {

		if (getScrollWidth(thisWindow) > maxgoldx) {

			size.x = maxx; 

			size.y = miny;	

			thisWindow.document.body.scroll = 'yes';

		}

		else {

			//  downsize from maxgoldx , now I try to using binary divide.			

			x = maxgoldx;

			deltax = -maxgoldx/2;

			while (true) {

				x = x + deltax;

				if(!gbAIR)

				thisWindow.resizeTo(x, miny);

				diffy = getScrollHeight(thisWindow) + getBscrollHeight() - x * getBRateH_W();

				if (diffy >  gBpermitYDelta ) // it is higher than wanted, so x need to be wide a little bitter

					deltax = Math.abs(deltax) /2;

				else if (diffy <  -gBpermitYDelta) // it is shorter than wanted, so x need to be narrow a little bitter

					deltax = -Math.abs(deltax) /2;

				else 

					// the y is close enough to wanted.

					break;

				if (Math.abs(deltax) < gBpermitXDelta) // the next change is too slight and it can be ignore.

					break;

			}

			size.x = getScrollWidth(thisWindow);

			size.y = getScrollHeight(thisWindow) ;

			thisWindow.document.body.scroll = 'no'; // At this time we do not want to show scroll any more. so it will looks better a little.



		}

	}

	if (gbBsNS6)

		size.y = size.y + 20 ;	

	

	if(!gbAIR)

	thisWindow.resizeTo(size.x, size.y);

	return;

}



function getScrollWidth(thisWindow)

{

   var w =  thisWindow.document.body.scrollWidth ? thisWindow.document.body.scrollWidth : thisWindow.window.pageXOffset  ; 

   return w ? w : 0;

} 



function getScrollHeight(thisWindow)

{

   var h = thisWindow.document.body.scrollHeight ? thisWindow.document.body.scrollHeight : thisWindow.window.pageYOffset  ; 

   return h ? h : 0;

}





function BSSCPopupParentClicked()

{

	if (!window.gbPopupTimeoutExpired) {

		return false;

	}

	

	document.onmousedown = gbOrignalOnMouseDown;



	// Simply hide the popup

	hideAll();



	window.gbPopupTimeoutExpired = false;



	return true;

}



function isInsideHyperLink(obj)

{

	if (obj&&obj!=getParentNode(obj))

	{

		if (obj.tagName=="A"||obj.tagName=="IMG" || obj.tagName=="VIDEO")

			return true;

		else

			return isInsideHyperLink(getParentNode(obj));

	}

	else

		return false;

}



function BSSCPopupClicked(e)

{

	if (!window.gbPopupTimeoutExpired) {

		return false;

	}



	var popupIFrame = getCurrentPopupIFrame();

	if (popupIFrame == null) {

		return true;

	}



	if (gbBsIE4 && (!((popupIFrame.window.event != null) &&

		(popupIFrame.window.event.srcElement != null) &&

		isInsideHyperLink(popupIFrame.window.event.srcElement)))) {

		document.onmousedown = gbOrignalOnMouseDown;

		

		// Simply hide the popup

		hideAll();

		window.gbPopupTimeoutExpired = false;

		return true;

	}

	else if (!gbAIR && (gbBsNS6 || gbChrome) && (!((e != null) &&

			(e.target!= null) && isInsideHyperLink(e.target))))

	{

	    document.removeEventListener("mousedown", BSSCPopupParentClicked,false);

	    if(gbOrignalOnMouseDown)

		    document.addEventListener("mousedown", gbOrignalOnMouseDown,false);

		// Simply hide the popup

		hideAll();

		window.gbPopupTimeoutExpired = false;

		return true;		

	}

}



//trace the mouse over's position for hotspot

function  BSPSPopupOnMouseOver(event)

{

	rhPopupEx.setClickPosition(event.clientX, event.clientY);	

	if (gbBsIE4 || gbBsOpera7||gbBsKonqueror3) {

		window.gnPopupClickX = event.clientX + getScrollLeft();

		window.gnPopupClickY = event.clientY + getScrollTop();

		window.gnPopupScreenClickX = event.screenX;

		window.gnPopupScreenClickY = event.screenY;

	} else if (gbBsSafari) {

		window.gnPopupClickX = event.clientX + getScrollLeft();

		window.gnPopupClickY = event.clientY + getScrollTop();

		window.gnPopupScreenClickX = event.screenX + window.screenX;

		window.gnPopupScreenClickY = event.screenY + window.screenY;

	} else if (gbBsNS4) {

		window.gnPopupClickX = event.pageX - window.pageXOffset;

		window.gnPopupClickY = event.pageY - window.pageYOffset;

		window.gnPopupScreenClickX = event.screenX - window.pageXOffset;

		window.gnPopupScreenClickY = event.screenY - window.pageYOffset;

	}

}



function BSSCHidePopupWindow()

{

	if (window.gPopupWindow != null) {

		if (gbBsNS4) {

			if ((typeof window.gPopupWindow != "undefined") && (!window.gPopupWindow.closed)) {

				window.gPopupWindow.close();

				window.gPopupWindow = null;

			}

		}

	}

	return;

}



// Add the PopupOnClick to the onclick array.

if (typeof(BsscRegisterOnClick) != "undefined")

{

	BsscRegisterOnClick(BsPopupOnClick);

}

//End to support previous popup functions



/// Section End  - Popup (JavaScript 1.0)



/// Section Begin - Embedded Stub (JavaScript 1.0)



function BSSCCreatePopupDiv()

{

	return;

}



function WritePopupMenuLayer()

{

	if (BsscHasExtJs()) {_WritePopupMenuLayer();}

}



function BSSCPopup(strURL, width, height)

{

	var re = new RegExp("'", 'g');

	strURL = strURL.replace(re, "%27");



	if (BsscHasExtJs())	{

		_BSSCPopup(strURL, width, height);

	}else{

		//Create a temporary window first to ensure the real popup comes up on top

		var wndTemp = null;

		if (!gbBsNS3) {

			wndTemp = window.open("", "temp", "titlebar=no,toolbar=no,status=no,location=no,menubar=no,resizable=yes,scrollbars=yes,height=3,width=4");

		}

		// Create the real popup window

		var wndPopup = window.open(strURL, "BSSCPopup", "titlebar=no,toolbar=no,status=no,location=no,menubar=no,resizable=yes,scrollbars=yes,height=300,width=400");

		// Close the temporary

		if (!gbBsNS3) {

			wndTemp.close();

		} else {

			wndPopup.focus();

		}

	}

}



var gbWndTemp = null, gbWndPopupLinks = null;

var gbstrParaTotal = "";



function PopupMenu_Invoke()

{

	if (typeof(wfRelatedTopic) == 'function' && typeof(IsFlashSupported) == 'function')

	{

		if (Number(gsSkinVersion) > 2 && IsFlashSupported())

		{

			return wfRelatedTopic(PopupMenu_Invoke.arguments);

		}

	}

	if (BsscHasExtJs()) {

		return _PopupMenu_Invoke(PopupMenu_Invoke.arguments);

	}

	if (gbBsNS3Before || gbBsIE3Before )	{

		var argLen 	= PopupMenu_Invoke.arguments.length;

		if (argLen < 5) {

			window.document.location.href = PopupMenu_Invoke.arguments[3];

			return false;

		}

		gbWndTemp = null;

		gbWndPopupLinks = null;

		gbstrParaTotal = "";

		for (var i = 0; i < (argLen - 2) / 2; i++) {

			var strParaLine = "";

			if (gbBsNS2){

				strParaLine += "<a href=\"";

				strParaLine += PopupMenu_Invoke.arguments[2 * i + 3];

				strParaLine += "\">"

				strParaLine += PopupMenu_Invoke.arguments[2 * i + 2];

				strParaLine += "</a>";

			} else {

				strParaLine += "<a href=\"javascript:";

				strParaLine += "gotoUrl(\'";

				strParaLine += PopupMenu_Invoke.arguments[2 * i + 3];

				strParaLine += "\');\"";

				if (PopupMenu_Invoke.arguments[1] != '') {

					strParaLine += " TARGET='" + PopupMenu_Invoke.arguments[1] + "'";

				}

				strParaLine += ">";

				strParaLine += PopupMenu_Invoke.arguments[2 * i + 2];

				strParaLine += "</a>";

			}

			strParaLine += "<br>";

			gbstrParaTotal += strParaLine;

		}

		var nHeight = argLen * 15;

		var nWidth = 400;

		var strParam = "titlebar=no,toolbar=no,status=no,location=no,menubar=no,resizable=yes,scrollbars=auto";

		strParam += ",height=" + nHeight + ",width=200,resizable";

		

		//Create a temporary window first to ensure the real popup comes up on top

		//var wndTemp = null;

		if (!gbBsNS3) {

			gbWndTemp = window.open("", "temp", "titlebar=no,toolbar=no,status=no,location=no,menubar=no,resizable=yes,scrollbars=yes,height=3,width=4");

		} 

		gbWndPopupLinks = window.open("", "popuplinks", strParam);



		setTimeout("Wait_PopupMenuReady()", 100);

	}

	return true;

}



function Wait_PopupMenuReady() 

{

	if (gbWndPopupLinks != null && "object" == typeof(gbWndPopupLinks.document)) {

		PopupMenu_InvokeReady();

	}

	else 

		setTimeout("Wait_PopupMenuReady()", 100);

}



function PopupMenu_InvokeReady()

{

	if (gbWndPopupLinks != null) {

		gbWndPopupLinks.document.open("text/html");

		gbWndPopupLinks.document.write("<html><head>");

		if (gbBsNS2) {

			gbWndPopupLinks.document.write("<base href=\"" + location +"\">");

		} else {

			//YJ: IE301,302 and NS3.x works fine

			gbWndPopupLinks.document.write("<");

			gbWndPopupLinks.document.write("script>");

			gbWndPopupLinks.document.write("function gotoUrl(aUrl) {opener.window.location=aUrl; close();}");

			gbWndPopupLinks.document.write("<");

			gbWndPopupLinks.document.write("/script>");

		}

		gbWndPopupLinks.document.write("<");

		gbWndPopupLinks.document.write("/head>");

		gbWndPopupLinks.document.write("<body onBlur=\'self.focus();\'>");

		gbWndPopupLinks.document.write(gbstrParaTotal);

		gbWndPopupLinks.document.write("</body></html>");

		gbWndPopupLinks.document.close();



		// Close the temporary

		if (!gbBsNS3 && gbWndTemp != null) {

			gbWndTemp.close();

		}else {

			gbWndPopupLinks.focus();

		}



		return true;

	}

	return false;

}



/// Section End - Embedded Stub (JavaScript 1.0)



//// Segment End -- (JavaScript 1.0)



//// Segment Begin -- (JavaScript 1.2)

/// Section Begin  - DHTM (JavaScript 1.2)



//Begin to support extended and dropdown text effects.

function IsParagraph(el)

{

	return( el.tagName == "P" || el.tagName.indexOf("H") == 0 ) ? true : false;

}



//Begin to support extended and dropdown text effects.

function kadovIsParagraph(el)

{

	return IsParagraph(el);

}





function InitEachChild(el)

{	

	for(var i=0; i<getChildNodes(el).length; i++)

	{

		var child = getChildNodes(el)[i];

		if( child.tagName == "SCRIPT" || child.tagName == "!" )

			continue;



		if( child.id != "" )

		{

			// to wipe out the onload effects

			if (gbBsIE4&&!gbBsMac)

			{

				var onLoadEffect = getAttribute(child.style, "x-on-pageload" );

				if( (onLoadEffect != null) && (onLoadEffect > "") )

					setAttribute(child.style, "x-on-pageload", "" );

			}

			

			var href = getAttribute(child,"href");

			if( href != null && href > "" && href.indexOf( "BSSCPopup" ) >= 0 )

				FilePopupInit(child.id); // Init for Popup

			else if( child.className == "dropspot" || child.className == "expandspot" || 

					 child.className == "glossterm" )

				TextPopupInit(child.id);// Init for Expanding/Glossary or DropDown text

			else if( child.className == "trigger")

				InitTrigger(child.id);// Init for Trigger

			else

			{

				InitEffects(child.id);// Init for DHTML effects

				CEngine.SetOneTargetInitialState( child.id );

			}

		}

		

		if( (child.tagName == "IMG") && (getAttribute(child,"dynsrc") > "") )

			child.start = "mouseover";// to start a AVI file. fileopen doesn't work



		InitEachChild(child);

	}

}



function kadovInitEachChild(el)

{	

	InitEachChild(el);

}



function RetrieveTextInner(el)

{	

	var x = "";

	if( (!el) || (el.tagName == "!") || (el.tagName == "SCRIPT" ))

		return x;



	if( IsParagraph(el) )

	{

		var strNewID = " ";

		if( el.id != "" )

			strNewID += "id=" + el.id + "_NewSpan ";

		x = "<span" + strNewID + "style='" + el.style.cssText + "'>" + el.innerHTML + "</span>";

	}

	else

	{

		for(var i=0; i<getChildNodes(el).length; i++)

			x += RetrieveTextInner( getChildNodes(el)[i] );

	}

	return x;

}



function kadovRetrieveTextInner(el)

{

	return 	RetrieveTextInner(el);

}



function RetrieveCleanHTML( strRawHTML, strTagOpen, strTagClose, nDistance )

{	

	var nTagOpen = strRawHTML.indexOf( strTagOpen, 0 );

	if( nTagOpen < 0 )

		return strRawHTML;



	var nTagClose = strRawHTML.indexOf( strTagClose, nTagOpen);

	if( nTagClose < nTagOpen )

		return strRawHTML;

		

	if( typeof(nDistance) == "number" && nDistance > 0 )

		if( (nTagClose - nTagOpen) != nDistance )

			return strRawHTML;

		

	var strCleanOnce = strRawHTML.substring(0, nTagOpen) + strRawHTML.substr(nTagClose + strTagClose.length) ;

	return 	RetrieveCleanHTML( strCleanOnce, strTagOpen, strTagClose );

}



function kadovRetrieveCleanHTML( strRawHTML, strTagOpen, strTagClose, nDistance )

{	

	return RetrieveCleanHTML( strRawHTML, strTagOpen, strTagClose, nDistance );

}	



function AdjustObjectTag(strRawHTML, nStartPos)

{// adjust object tag for related topics HTML control, because innerHTML misses out the item settings

	

	//Is there any DTC?

	var strDTCTagOpen = '<!--Metadata type="DesignerControl" startspan';

	var strDTCTagClose = '<!--Metadata type="DesignerControl" endspan-->';

	var nDTCTagOpen = strRawHTML.indexOf( strDTCTagOpen, nStartPos );

	if( nDTCTagOpen < 0 )

		return strRawHTML;

	var nDTCTagClose = strRawHTML.indexOf( strDTCTagClose, nDTCTagOpen );

	if( nDTCTagClose < nDTCTagOpen)

		return strRawHTML; // no Design Time Controls;

		

	//Is the DTC HTML Help Control?

	var strRTObjTagOpen = 'classid=clsid:ADB880A6-D8FF-11CF-9377-00AA003B7A11';

	var strRTObjTagClose = '</OBJECT>';

	var nRTObjTagOpen = strRawHTML.indexOf( strRTObjTagOpen, nDTCTagOpen );

	if( nRTObjTagOpen < nDTCTagOpen )

		return strRawHTML;

	var nRTObjTagClose = strRawHTML.indexOf( strRTObjTagClose, nRTObjTagOpen );

	if( nRTObjTagClose < nRTObjTagOpen )

		return strRawHTML; // is not a HTML help control

		

	// Is it a related Topics html help control?

	var strRTObjLabel = '<PARAM NAME=\"Command\" VALUE=\"Related Topics';

	if( strRawHTML.indexOf(strRTObjLabel, nRTObjTagOpen) < 0 )

		return strRawHTML;

	

	// does the commented object tag contain a items parameters		

	var strRTItemsOpen = '<param name="Items" value="';

	var strRTItemsClose = '$$**$$" >';

	var strRTItemsClose2 = '$$**$$">';



	var nRTItemsOpen = strRawHTML.indexOf(strRTItemsOpen, nDTCTagOpen);

	if( nRTItemsOpen < nDTCTagOpen )

		return strRawHTML;

	var nRTItemsClose = strRawHTML.indexOf(strRTItemsClose, nRTItemsOpen);

	if (nRTItemsClose == -1)

		nRTItemsClose = strRawHTML.indexOf(strRTItemsClose2, nRTItemsOpen);

	if( nRTItemsClose < nRTItemsOpen )

		return strRawHTML;

		

	// found a items string

	var strItems = strRawHTML.substring( nRTItemsOpen + strRTItemsOpen.length, nRTItemsClose);

	if( strItems.length < 1 )

		return strRawHTML;

	

	// to reconstruct the item(s) param tag(s)

	var strItemsArray = strItems.split('$$**$$');

	if( strItemsArray.length < 1 )

		return strRawHTML;

	var strRunTimeItemParam = "";

	for( var i = 0; i < strItemsArray.length; i++ )

	{

		strRunTimeItemParam += '<PARAM  NAME="Item' + (i+1);

		strRunTimeItemParam += '"' + '  VALUE="';

		strRunTimeItemParam += strItemsArray[i];

		strRunTimeItemParam += '">';

	}

	

	// to insert the reconstructed item params into runtime object tag

	var strAdjustedHTML = strRawHTML.substring(0,nRTObjTagClose) + strRunTimeItemParam + strRawHTML.substring(nRTObjTagClose, strRawHTML.length);

	return AdjustObjectTag(strAdjustedHTML, nDTCTagClose + strDTCTagClose.length);

}



function kadovAdjustObjectTag(strRawHTML, nStartPos)

{// adjust object tag for related topics HTML control, because innerHTML misses out the item settings

 return AdjustObjectTag(strRawHTML, nStartPos);

}



function TextPopupOnLoad( el )

{

	if( typeof(el) == "string" )

		el = getElement(el);

	var src = null;

	if(el.id)

	{

		for (var i=0;i<gPopupData.length;i++)

			if (gPopupData[i].el==el.id)

			{

				src=gPopupData[i].popupId;

				break;

			}

	}

	if (!src)	

		return 0;



	var name = src;

	if( src.substr(0,1) == "#" ) 

		name = src.substr(1, src.length-1);

	var srcDiv = getElement(name);

	if( !srcDiv )

		return 1;



	//srcDiv.style.display = "none";

	return 0;

}

function kadovTextPopupOnLoad( el )

{

	return TextPopupOnLoad( el );

}

function getElementsByTag(obj,sTagName)

{

	if(obj.getElementsByTagName)

		return obj.getElementsByTagName(sTagName);

	else if(obj.all)

		return obj.all.tags(sTagName);

	return null;

}



function getElement(sID)

{

	if(document.getElementById)

		return document.getElementById(sID);

	else if(document.all)

		return document.all(sID);

	return null;

}



function getParentNode(obj)

{

	if(obj.parentNode)

		return obj.parentNode;

	else if(obj.parentElement)

		return obj.parentElement;

	return null;

}



function getChildNodes(obj)

{

	if(obj.childNodes)

	{

		var children = new Array();

		for (var i = 0; i < obj.childNodes.length; i++)

		{

			if (obj.childNodes[i].nodeType == 1)

				children[children.length] = obj.childNodes[i];

		}

		return children;

	}

	else if(obj.children)

		return obj.children;

	return null;	

}



function removeThis(obj)

{

	if(obj.parentNode)

		obj.parentNode.removeChild(obj);

	else

		obj.outerHTML="";

}



function TextPopup( el )

{

	if (!gbBsIE4 && !gbBsOpera7 && !gbBsSafari && !gbBsNS6 && !gbBsKonqueror3 )

		return;

	

	if (window.event)

		window.event.cancelBubble = true;



	if( typeof(el) == "string" )

		el = getElement(el);



	if (!el||el==window)

		return;



	for(var i=0; i<getChildNodes(el).length; i++)

	{

		var child = getChildNodes(el)[i];

		if( child && (child.tagName == "IMG") )

		{

			if(child.className == "Twisties")

			{

				if( child.style && (child.style.display == "") )

					child.style.display = "none";

				else if(child.style)

					child.style.display = "";

			}

		}



		if( child && (child.tagName == "SPAN") )

		{

			if(child.className == "MTText")

			{

				if( child.style && (child.style.display == "") )

					child.style.display = "none";

				else if(child.style)

					child.style.display = "";

			}

		}

	}

	

	var src = null;	

	if(!src&&el.id)

	{

		for (var i=0;i<gPopupData.length;i++)

			if (gPopupData[i].el==el.id)

			{

				src=gPopupData[i].popupId;

				break;

			}

	}

	if(!src)

		return;

		

	var name = src;

	if( src.substr(0,1) == "#" ) 

	name = src.substr(1, src.length-1);



	var srcDiv = getElement(name);

	if( !srcDiv )

		return;



	if( srcDiv )

	{

		if( srcDiv.style.display == "" )

			srcDiv.style.display = "none";

		else

		{

			if(srcDiv.className == "expandtext")

			{

				var inner = RetrieveTextInner(srcDiv);

				if( inner == "" )

					inner = srcDiv.innerHTML;

				if(inner.indexOf("&nbsp;") != 0 && inner.indexOf(" ") != 0 && inner.indexOf("&#160;"))

				{

					//insertAdjacentHTML(srcDiv, 'afterBegin', "&nbsp");

					try

					{

						if(srcDiv.childNodes)

						{

							var firstChild = srcDiv.childNodes[0];

							var newText = document.createTextNode(" ");

							srcDiv.insertBefore(newText, firstChild);

						}

					}

					catch(e)

					{

					}

				}

			}



			srcDiv.style.display = "";

		}

	}

	if(gbBsIE4)

		event.returnValue=false;

	return;

}



function kadovTextPopup( el )

{

	TextPopup( el );

}



function FindParentParagraph( el )

{

	if( typeof(el) == "string" )

		el = getElement(el);

	if( (!el) || el.tagName == "BODY" )

		return null;

	if( IsParagraph(getParentNode(el)) )

		return getParentNode(el);

	else

		return FindParentParagraph( getParentNode(el) );

}



function kadovFindParentParagraph( el )

{

	return FindParentParagraph( el );

}



//Begin HTML code invoked function

function RegisterEventHandler( obj, strEvent, strEventHandler )

{

	CCSSP.RegisterEventHandler( obj, strEvent, strEventHandler );

}



function kadovRegisterEventHandler( obj, strEvent, strEventHandler )

{

 RegisterEventHandler( obj, strEvent, strEventHandler );

}





function textPopupData(el, popupId)

{

	this.el = el;

	this.popupId = "#"+popupId;

}



var gPopupData = new Array();



function TextPopupInit( el, popupId)

{

	if (!gbBsIE4 && !gbBsOpera7 && !gbBsSafari && !gbBsNS6 && !gbBsKonqueror3)

		return;

		

	if( typeof(el) == "string" )

	{

		if (popupId)

		{

			gPopupData[gPopupData.length]=new textPopupData(el, popupId);

		}

		el = getElement(el);

	}

		

	if( el != null )

	{

		CCSSP.RegisterEventHandler( el, "onclick", "TextPopup(\"" + el.id +"\");" );

		CCSSP.RegisterEventHandler( window, "onload", "TextPopupOnLoad(\"" + el.id +"\");" );

	}

}



function kadovTextPopupInit( el, popupId)

{

	return TextPopupInit( el, popupId);

}

//End HTML code invoked function



//End to support extended and dropdown text effects.



//Begin to convert iWrite format to RoboEditor Format for DHTML effects

function InitTriggersInHead( )

{

  if( Object.xDelayedInitElements )

  {

     var x = Object.xDelayedInitElements;

     for(i=0; i<x.length; i++)

     	InitTrigger( x[i] );

  }

}



function kadovInitTriggersInHead( )

{

	InitTriggersInHead( );

}



//Begin HTML code invoked function

function FilePopupInit( el )

{

	if( typeof(el) == "string" )

		el = getElement(el);



	if( el != null )

		CCSSP.RegisterEventHandler( el, "onmouseover", "BSPSPopupOnMouseOver(event);" );

}

function kadovFilePopupInit( el )

{

	FilePopupInit( el );

}



function InitTrigger( element, a_targets )

{

//	if( !gbBsIE4 )

	//	return;

	var srcElement = element;

	if( typeof(srcElement) == "string" )

	{

		srcElement = getElement(element,0);

		if(srcElement == null)

			return;

	}

	

	//if( !IsParentVisible(srcElement) )

	//	return;

	

	var targets = null;

	if(typeof(a_targets) != "undefined")

		targets = a_targets;

	if(!targets)

		targets = getAttribute(srcElement, "x-targets" );

	if (!targets)

		targets = getAttribute(srcElement.style,"x-targets");

	if (!targets)

		return;	

	var arrOneTarget = targets.split( "," );

	for( var i = 0; i < arrOneTarget.length; i ++ )

		bsscFXInit( element, arrOneTarget[i], null, null, null, null );

}



function kadovInitTrigger( element )

{

	InitTrigger( element )

}



function IsParentVisible( el )

{

	if( typeof(el) == "string" )

		el = getElement(el);

	if( (!el) || el.tagName == "BODY" )

		return true;

	if( el.style.display == 'none' ) //el.visibility == 'hidden' || 

		return false;

	else

		return IsParentVisible( getParentNode(el) );

}



function kadovIsParentVisible( el )

{

	return IsParentVisible( el );

}

function InitEffects( element, effectsList )

{

	//if( !gbBsIE4 )

	//	return;

	var srcElement = element;

	if( typeof(srcElement) == "string" )

	{

		srcElement = getElement(element,0);

		if(srcElement == null)

			return;

	}

	

	//if( !IsParentVisible(srcElement) )

	//	return;



	if(effectsList)

	{

		//srcElement.setAttribute("style", effectsList);

		var str = effectsList;

		var nStart = 0;

		var indx = str.indexOf(":", nStart);

		var effect = null;

		var value = null;

		while(nStart >= 0 && indx > 0 && indx < str.length)

		{

			effect = effectsList.substr(nStart, indx-nStart);

			var indx2 = str.indexOf(";", nStart);

			if(indx2 == -1)

				indx2 = str.length;

			value = effectsList.substr(indx+1, indx2);

			if(effect && value)

			    setAttribute(srcElement,effect, value);

			nStart = effectsList.indexOf("x-on", indx2+1);

			indx = str.indexOf(":", nStart);

		}

		

	}

	

	InitEffect( srcElement, "x-on-hover" );

	InitEffect( srcElement, "x-on-pageclick" );

	InitEffect( srcElement, "x-on-pageload" );

	InitEffect( srcElement, "x-on-trigger-1" );

	InitEffect( srcElement, "x-on-trigger-2" );

}



function kadovInitEffects( element )

{

	InitEffects( element );

}

//End HTML code invoked function



function InitEffect( element, prop )

{

	var values = null;

	if( getAttribute(element,prop))		

		values = getAttribute(element, prop );	

	else if( getAttribute( element, "currentStyle" )  && element.currentStyle.getAttribute)

		values = element.currentStyle.getAttribute( prop );

	else  if (element.style.getAttribute)

		values = element.style.getAttribute( prop );

		

	if( !values )

		return;

    

	var functions = new Array();

	var nIdx = 0, nStart = 0;

	var nNext = values.indexOf( "\)", 0);

	while( nNext >= 0 && nNext < values.length )

	{

		functions[nIdx] = values.substr( nStart, nNext-nStart+1);

		nStart = nNext + 1;

		nIdx++;

		nNext = values.indexOf( "\)", nStart);

	}

		

	for( var i=0; i<functions.length; i++)

	{

		var id = getAttribute(element, "id" );

		var translatedProp = TranslateProp(prop);



		var lp = functions[i].indexOf( "(" );

		var fnname = functions[i].substring(0, lp);

		var srcargs = functions[i].substring(lp+1, functions[i].length-1);

		

		var nClickTimes = 1;

		var arrForClickCount = srcargs.split( "," );

		for( var j = 0; j < arrForClickCount.length; j++ )

		{// to locate and get the "clicks=99" settings

			var nPageClick = arrForClickCount[j].indexOf("clicks");

			if( nPageClick >= 0 )

			{

				nPageClick = arrForClickCount[j].indexOf("=");

				if( nPageClick > 0 )

				{

					nClickTimes = arrForClickCount[j].substring( nPageClick + 1, arrForClickCount[j].length) * 1;

					break;

				}

			}

		}

		var args = srcargs;

		if( j < arrForClickCount.length )

		{// to strip out the "clicks=99" from the arguments string

			args = "";

			for( var k = 0; k < arrForClickCount.length; k ++ )

			{

				if( k != j )

				{

					args += arrForClickCount[k];

					if( k < arrForClickCount.length - 1 )

						args += ",";

				}

			}

		}

		bsscFXInit( null, id, translatedProp, fnname, args, nClickTimes );

	}

}



function kadovInitEffect( element, prop )

{

	InitEffect( element, prop );

}



function TranslateProp( prop )

{

	switch( prop )

	{

	case "x-on-hover" :     return "bsschover";

	case "x-on-pageclick" : return "bsscpageclick";

	case "x-on-pageload" :  return "bsscpageload";

	case "x-on-trigger-1" : return "bssctrigger1";

	case "x-on-trigger-2" : return "bssctrigger2";

	}

	return null;

}



function kadovTranslateProp( prop )

{

	return TranslateProp( prop );

}



//End to convert iWrite format to RoboEditor Format for DHTML effects



//Begin the definition of one entry to DHTML effects

function bsscFXInit( trigger_ID, target_ID, event_type, 

	action_type, action_setting, event_addional )

{

	//if( typeof(target_ID) != "string" )//MUST have a target_ID

	//	return; // we don't support Navigator yet

	

	if( typeof(event_type) == "string" )

		event_type = event_type.toLowerCase();

	if( typeof(action_type) == "string" )

		action_type = action_type.toLowerCase();

	if( typeof(action_setting) == "string" )

		 action_setting = action_setting.toLowerCase();

	

	// to get the target element then add it to the target list

	var eleTarget = CCSSP.GetObject( target_ID );

	if( (eleTarget != null) && (event_type != null) && (action_type != null) )

	{

		

		CEngine.AddOneTarget( target_ID, eleTarget );

		CEngine.BuildTargetObject(target_ID, event_type, action_type, action_setting, event_addional);

	}

	

	// to validate the trigger_ID parameter

	if( typeof(trigger_ID) == "string" && trigger_ID != "" )

		CEngine.BuildTriggerObject( trigger_ID, target_ID );

}	

//End the definition of one entry to DHTML effects



/// Section End  - DHTM (JavaScript 1.2)



/// Section Begin  - CCSSP DHTM (JavaScript 1.2)



//Begin JavaScript libary for cross-platform positioning object.

function CCSSP(){} // constructor of CCSSP class



CCSSP.GetObject = function( obj )

{//convert object name string or reference into a valid object reference

	if( typeof(obj) == "object" )

		return obj;

	else if( typeof(obj) == "string" && obj != "")

	{

		if (gbBsNS6)

		    return getElement(obj);	

		else if( gbBsNS4 )

			return eval("document." + obj);

		else

			return eval("document.all(\"" + obj + "\")");

	}

	else

		return null;

}



CCSSP.MoveObjectTo = function(obj, x, y)

{//positioning an object at a specific pixel coordinate

	if( gbBsNS4 && !gbBsNS6) 

		obj.moveTo(x,y);

	else

	{

		if (x == '')

	        x = 0 ;

	    if (y == '')

	        y = 0 ;

	    obj.style.left = parseInt(x) + 'px';

	    obj.style.top = parseInt(y) + 'px'; 

	}

}



CCSSP.SetTimer = function(obj, timeout)

{

	if( obj.timer == null )

	{

		if(gbAIR)

		{

			obj.timer = setInterval(function(){CEngine.PerformAnimation( obj.aniIndex)}, timeout );

		}

		else

			obj.timer = setInterval("CEngine.PerformAnimation(" + obj.aniIndex + ")", timeout );

	}

}





CCSSP.MoveObjectBy = function(obj, dx, dy)

{//moveing a object by x and/or y pixel

	if (gbBsNS6)

	{

	    var left = parseInt(obj.style.left);

	    obj.style.setProperty('left',(left + dx ) + 'px',0) ;

	    var top =  parseInt(obj.style.top);

	    obj.style.setProperty('top' , (top + dy) + 'px' ,0);

	}

	else if( gbBsNS4 )

		obj.moveBy(dx,dy);

	else

	{

		obj.style.pixelLeft += dx;

		obj.style.pixelTop += dy;

	}

}



CCSSP.SetObjectBGColor = function(obj, color)

{//set the background color of an object

	if  (gbBsNS6)

	    obj.style.setProperty( "background-color" , color , 0);

	else if( gbBsNS4 )

		obj.bgColor = color;

	else

		obj.style.backgroundColor = color;

}



CCSSP.ShowObject = function(obj, bShow)

{// set the object to be visible or invisible

	if (gbBsNS6)

	    obj.style.setProperty('visibility', (bShow == true) ? 'visible' : 'hidden',null);

	else if( gbBsNS4 )

		obj.visibility = (bShow == true) ? 'show' : 'hide';

	else

		obj.style.visibility = (bShow == true) ? 'visible' : 'hidden';// when hidden, it still occupy some space.

}



CCSSP.GetObjectLeft = function(obj)

{// retrieve the x coordinate of a posionable object

	if (gbBsNS6)

	    return obj.style.left ;

	else if( gbBsNS4 )

		return obj.left;

	else

		return obj.style.pixelLeft;

}



CCSSP.GetObjectTop = function(obj)

{// retrieve the y coordinate of a posionable object

	if (gbBsNS6)

	    return obj.style.top ;

	else if( gbBsNS4 )

		return obj.top;

	else

		return obj.style.pixelTop;

}



CCSSP.GetObjectContainLeft = function(obj)

{// retrieve the x coordinate of a posionable object relative to it's parent element

	if( typeof(obj.pageX) != 'undefined')

		return obj.pageX;

	else if( typeof(obj.clientLeft) != 'undefined' )

		return obj.clientLeft;

	else

	    return obj.offsetLeft;	

}



CCSSP.GetObjectWindowLeft = function(obj)

{// retrieve the x coordinate of a posionable object relative to browser window

	if( gbBsNS4 && !gbBsNS6)

		return obj.pageX;

	else

	{

		var nOffsetWindowLeft = 0;

		for(var element = obj; element; element = element.offsetParent)

			nOffsetWindowLeft += CCSSP.GetObjectContainLeft(element);

		return nOffsetWindowLeft;

	}

}



CCSSP.GetObjectContainTop = function(obj)

{// retrieve the y coordinate of a posionable object relative to it's parent element

	if( typeof(obj.pageY) != 'undefined')

		return obj.pageY;

	else if( typeof(obj.clientTop) != 'undefined' && obj == document.body)

		return obj.clientTop;

	else

		return obj.offsetTop;	

}



CCSSP.GetObjectWindowTop = function(obj)

{// retrieve the y coordinate of a posionable object relative to browser window

	if( gbBsNS4 && !gbBsNS6)

		return obj.pageY;

	else

	{

		var nOffsetWindowTop = 0;

		for(var element = obj; element; element = element.offsetParent)

			nOffsetWindowTop += CCSSP.GetObjectContainTop(element);

		return nOffsetWindowTop;

	}

}



CCSSP.GetObjectHeight = function(obj)

{// retrieve the height of a posionable object

	if( gbBsNS4 && !gbBsNS6)

		return obj.clip.height;

	else

		return obj.offsetHeight;

}



CCSSP.GetObjectWidth = function(obj)

{// retrieve the width of a posionable object

	if( gbBsNS4 && !gbBsNS6)

		return obj.clip.width;

	else

		return obj.offsetWidth;

}



CCSSP.RegisterEventHandler = function( srcObj, rawEventName, funcHandler )

{ // to add the "funcHandler" as the "rawEventName" 's handler to the "srcObj" object,the original event handler will be combined



	if( srcObj == window && rawEventName == 'onload' )

	{

		var bSet = false;

		if( window.addEventListener )

		{

			window.addEventListener( 'load', new Function("event", funcHandler ),false);

			bSet = true;

		}

		else if( window.attachEvent )

		{

			window.attachEvent('onload', new Function("event", funcHandler ), false);

			bSet = true;

		}

		

		if( bSet )

			return;

	}

	

	if (gbBsNS4 && !gbBsNS6)

		return ;

		

	var oldHandler = "";



	if (gbBsMac &&gbBsIE4&&!gbBsIE5)

	{

		if (typeof(srcObj[rawEventName.toLowerCase()])=="unknown")

		{ //search for <SCRIPT> tag which define the event handler

			for( var i = 0; i < document.scripts.length; i++ ) 

			{

				var script = document.scripts[i];

				if( (script.htmlFor == srcObj.id || script.htmlFor == srcObj ) && script.event == rawEventName )

				{

					oldHandler = script.innerHTML;

					break;

				}

			}

		}

	}

	else

	{

		var oldInlineHandler = srcObj[rawEventName.toLowerCase()];

		if( oldInlineHandler != null && typeof(oldInlineHandler) != "undefined")

		{

			var functionDefinition = oldInlineHandler.toString();

			var bodyStart = functionDefinition.indexOf( "{" );

			var bodyEnd = functionDefinition.lastIndexOf( "}" );

			if( bodyStart > 0 || bodyEnd > bodyStart )

				oldHandler = functionDefinition.substr( bodyStart + 1, bodyEnd - bodyStart - 2 );

		}

		else if( gbBsIE4 )

		{ //search for <SCRIPT> tag which define the event handler

			for( var i = 0; i < document.scripts.length; i++ ) 

			{

				var script = document.scripts[i];

				if( (script.htmlFor == srcObj.id || script.htmlFor == srcObj ) && script.event == rawEventName )

				{

					oldHandler = script.innerHTML;

					break;

				}

			}

		}

	}

	if( oldHandler.indexOf(funcHandler) >= 0 )

		return;// to prevent register the funtion twice.



	if( gbBsNS4 ) // only "onload, onresize, onfocus" apply to window

	{// other raw events will apply to layer

		var noOn = rawEventName.substring(2, rawEventName.length);

		if( typeof(noOn) == "string" && noOn.length > 3 ) {

			if (srcObj.captureEvents)

				srcObj.captureEvents( Event[noOn.toUpperCase()] );

		}

	}

	

	var newHandler = oldHandler;

	if( newHandler.length == 0 )

		newHandler = funcHandler;

	else

		newHandler += "; " + funcHandler;	

	if ((gbBsNS6)&&(srcObj.addEventListener))

	    srcObj.addEventListener( noOn.toLowerCase(), new Function("event", newHandler ),false);

	else

	    srcObj[rawEventName.toLowerCase()] = new Function( newHandler );	

}



CCSSP.GetWindowHeight = function()

{// retrieve the height of available content in browser window

	if( gbBsNS4 )

		return window.innerHeight;

	else

		return document.body.clientHeight;

}



CCSSP.GetWindowBottom = function()

{// retrieve the bottom postion of browser window

	if( gbBsNS4 )

		return window.outerHeight + window.pageYOffset;

	else

		return document.body.clientHeight + getScrollTop();

}



CCSSP.GetWindowWidth = function()

{// retrieve the width of available content in browser window

	if( gbBsNS4 )

		return window.innerWidth;

	else

		return document.body.clientWidth;

}



CCSSP.GetWindowRight = function()

{// retrieve the right postion of browser window

	if( gbBsNS4 )

		return window.outerWidth + window.pageXOffset;

	else

		return document.body.clientWidth + getScrollLeft();

}



CCSSP.TrimString = function( objString, subtrim )

{// to trim the "subtrim" in the beginning and ending of a string object

	if( typeof(subtrim) != "string" || subtrim == null )

		return objString;

	var strHead = objString.substring(0, 1);

	var strRear = objString.substring(objString.length-1, objString.length);

	if( strHead != subtrim && strRear != subtrim )

		return objString;

	

	var spacePos = objString.indexOf(subtrim);

	if( spacePos < 0 )

		return objString;

	else if( spacePos == objString.length - 1 )

		return objString.substring(0, spacePos);

	else

	{

		var newString = objString.substring( spacePos + 1, objString.length);

		return CCSSP.TrimString( newString, subtrim );

	}

}



CCSSP.TrimSpace = function( objString )

{

	var Trim1 = CCSSP.TrimString( objString, " ");

	if( typeof(Trim1) != "string" || Trim1 == null )

	    return Trim1;

	var strHead = Trim1.substring(0, 1);

	if(strHead == "\"")

	    return CCSSP.TrimString( Trim1, "\"");

	return CCSSP.TrimString( Trim1, "\'");

}



CCSSP.GetEventElement = function( navEventObject )

{// to get the element who fired the current event

	if(gbBsNS4) 

		return navEventObject.target;

	else

		return event.srcElement;

}



CCSSP.PrepareFilter = function( Obj )

{//to prepare for making the filter work

	Obj.style.filter = "";

	if(Obj.style.position == "absolute" )

		return;

	if(gbBsIE7)

	{

		if( Obj.style.zoom != "")

			return;

		Obj.style.zoom = 1;

	}

	else

	{

		if(Obj.style.width != "" || Obj.style.height != "")

			return;

		Obj.style.height = CCSSP.GetObjectHeight(Obj);

	}

}



CCSSP.IsDescendant = function( progenitor, progeny )

{

	if( typeof(progeny) == "undefined" || progeny == null )

		return false;

	else if( progeny == progenitor )

		return true; 

	else if( progeny.id == progenitor.id ) 

		return true; 

	else if( getParentNode(progeny) == getParentNode(progenitor))

		return false;

	else

		return CCSSP.IsDescendant( progenitor, getParentNode(progeny));

}



CCSSP.IsTextTag = function( Obj )

{

	if( typeof( Obj.tagName ) == "undefined" )

		return false;

	return( Obj.tagName.indexOf("H") == 0 || Obj.tagName == "P" || 

			Obj.tagName == "FONT" || Obj.tagName == "SPAN" );

}



//End JavaScript libary for cross-platform positioning object.



/// Section End  - CCSSP DHTM (JavaScript 1.2)



/// Section Begin  - CCSSP DHTM 1 (JavaScript 1.2)



//Begin the definition of class CTrigger

function CTrigger( TriggerElement )

{

	// object : the trigger element. Never be null. 

	this.eleTrigger = TriggerElement;

	

	// number : the click counter number: only 3 values: 0,1,2;

	this.nCounter = 0; 

	

	//object as associative array of string:

	// the associate target ID strings; one element at least.			

	this.objStrTarget = new Object();

	this.eleTrigger.style.cursor = "pointer";

	if( this.eleTrigger.tagName == "AREA" && getAttribute(this.eleTrigger,"href") == "" )

		setAttribute(this.eleTrigger , "href", "#"); // to make a hand cursor for image map

}



CTrigger.prototype.AddTargetID = function( strTargetID )

{// add one target ID string to the objStrTarget

	if( typeof(strTargetID) != "string" )

		return ;

	if( typeof(this.objStrTarget[strTargetID]) != "string" )

		this.objStrTarget[strTargetID] = strTargetID;

}



CTrigger.prototype.OnTriggerClick = function(event)

{// to activate all asociated target

	var strEventType = ( (this.nCounter++)% 2 == 0 ) ? 

		"bssctrigger1" : "bssctrigger2";

		

	// to enumerate associative target element's ID string

	for( var strTargetID in this.objStrTarget ) 

		CEngine.SendEventToOneTarget( strTargetID, strEventType ,event);

}

//End the definition of class CTrigger



//Begin the definition of class CTarget

function CTarget( TargetElement )

{

	// object : the target element. Never be null.

	this.eleTarget = TargetElement;

	this.objManager = new Object(); // object: the event manager

} 



CTarget.nPageClickCounter = 0;// static class property.



CTarget.prototype.GetAgencyObject = function(str_action_type,action_setting )

{// return the action agency ( effect )object's refernece 

	switch( str_action_type )

	{

	case "show":return new CAgencyShow( this.eleTarget, true ) ;

	case "hide":return new CAgencyShow( this.eleTarget, false ) ;



    case "flyin" : 

    	return new CAgencyFly(this.eleTarget, action_setting, true);

    case "flyout" : 

    	return new CAgencyFly(this.eleTarget, action_setting, false);

    case "spiralin" : 

    	return new CAgencySpiral(this.eleTarget, action_setting, true);

    case "spiralout" : 

    	return new CAgencySpiral(this.eleTarget, action_setting, false);

    case "zoomin" :

    	return new CAgencyZoom(this.eleTarget, action_setting, true);

    case "zoomout" : 

    	return new CAgencyZoom(this.eleTarget, action_setting, false);

    case "elastic" : 

		return new CAgencyElastic(this.eleTarget, action_setting);

		

    case "fadein" : 

    	return new CAgencyAlpha(this.eleTarget, action_setting, true) ;

    case "fadeout" :

    	return new CAgencyAlpha(this.eleTarget, action_setting, false) ;

    case "rockrollstatic" :

    case "rockroll" :

    	return  new CAgencyWave(this.eleTarget, action_setting, false) ;

 

    case "glow":

    	return  new CAgencyGlow(this.eleTarget,action_setting);

    case "dropshadow":

    	return new CAgencyDropShadow(this.eleTarget,action_setting);

    case "transition" :

    	return new CAgencyRevealTrans(this.eleTarget,action_setting) ;

    case "blur" :

    	return  new CAgencyBlur(this.eleTarget,action_setting) ;



    case "fliph" : // all these 4 do NOT need any parameters

    case "flipv" :

    case "invert":

    case "gray" :

    	return new CAgencyChangeFilter(this.eleTarget, str_action_type) ;

    

    case "fontchange": // the effects below change the style on the fly, so won't work in Navigator

    	return new CAgencyFontChange(this.eleTarget,action_setting) ;

    case "boderchange": 

    case "stylechange":

    	return new CAgencyChangeStyle(this.eleTarget,action_setting);



	default: return null;

	}

}



CTarget.prototype.SetEventManager = function( 

	one_event_type,str_action_type,action_setting,event_additional)

{// to set the event manager with specified action 

	if( typeof( one_event_type ) != "string" ||	

		typeof( str_action_type ) != "string"||

		typeof( action_setting ) != "string" )

		return false;

	if( typeof(this.objManager[one_event_type]) == "undefined" )

	{

		this.objManager[one_event_type] = new Object();

		this.objManager[one_event_type].length = 0;

	}

	

	var eventAgency = this.GetAgencyObject(str_action_type,action_setting);

	if( eventAgency != null )

	{

		var ct = this.objManager[one_event_type].length ++;

		this.objManager[one_event_type][ct] = eventAgency;

		

		if( one_event_type == "bsscpageclick" )

		{// to deal with the "number of pageclick" stuff

			if( typeof(event_additional) == "number" )

				this.objManager[one_event_type][ct].nPageClick = event_additional;

			else // set the default number 

				this.objManager[one_event_type][ct].nPageClick = 1;

			

			if( (typeof(this.objManager.nMinPageClickIndex) == "undefined") ||

			    (this.objManager[one_event_type][ct].nPageClick < 

					this.objManager[one_event_type][this.objManager.nMinPageClickIndex].nPageClick) )

				this.objManager.nMinPageClickIndex = ct;

		}

		

		//hide the object blindly,SetState function will take care of the final correct state

		if( ((one_event_type == "bsscpageclick") && 

			 (this.objManager[one_event_type][ct].nPageClick == 1)) ||

			one_event_type == "bsscpageload" ||

			one_event_type == "bssctrigger1" )

			CCSSP.ShowObject( this.eleTarget, false );

		

		if( one_event_type == "bssctrigger1" || one_event_type == "bssctrigger2" )

			if( typeof( this.strTriggerEvent ) == "undefined" )

				this.strTriggerEvent = ( one_event_type == "bssctrigger1" ) ? "bssctrigger2" : "bssctrigger1";

			

		return true;

	}

	return false;

}



CTarget.prototype.OnEvent = function( strBsscEvent,event )

{// response to the event ( bssc format )

	if( typeof(this.objManager[strBsscEvent]) == "object" )

	{ // to get the event agency from the event manager

		var eventAgency = this.objManager[strBsscEvent];

		for( var i = 0; i < eventAgency.length; i++ )

		{

			if( strBsscEvent == "bsscpageclick" && 

			 	eventAgency[i].nPageClick != CTarget.nPageClickCounter )

				 continue;

			else if( strBsscEvent == "bsschover" && event.type == "mouseout" )

				eventAgency[i].EndEffect();

			else // to invoke the unified function in effect object	

				eventAgency[i].UpdateEffect(); 

		}

	}

}



CTarget.prototype.SetState = function( strBsscEvent )

{

	if( typeof(this.objManager[strBsscEvent]) != "object" )

		return false;



	// to get the event agency from the event manager

	var eventAgency = this.objManager[strBsscEvent];

	

	if( strBsscEvent == "bsscpageclick" )

	{// we only set the initial state for the minium number of pageclick 

		if (this.objManager.nMinPageClickIndex == 'undefined')

		    this.objManager.nMinPageClickIndex = 0 ;

		eventAgency[this.objManager.nMinPageClickIndex].PrepareEffect();

		return true;

	}

	else

	{

		for( var i = 0; i < eventAgency.length; i++ )

			eventAgency[i].PrepareEffect(); // to invoke the unified function in effect object	 

		if( i > 0 )

			return true;

		else

			return false;

	}

}

//End the definition of class CTarget



//Begin the definition of CEngine class

function CEngine(){}// all properities are going be "class" properities



// object : as associative array of trigger objects

CEngine.objTrigger = new Object();

// object : as associative array of target objects 

CEngine.objTarget = new Object(); 



// Array : each element is a CAgencyXXX animation object

CEngine.arrAnimation = new Array();

CEngine.PerformAnimation = function( nIndex )

{// animation : update effects function

	CEngine.arrAnimation[nIndex].UpdateEffect();

}



CEngine.AddOneTrigger = function(TriggerID,TriggerElement)

{// add one Trigger object into the trigger array

	if( typeof(TriggerID) != "string" || TriggerElement == null ||

	    typeof(TriggerElement) != "object" )

		return;

	if( typeof(CEngine.objTrigger[TriggerID] ) != "object" )

		CEngine.objTrigger[TriggerID] = new CTrigger(TriggerElement);

}

	

CEngine.AddOneTarget = function(TargetID, TargetElement)

{// add one Target object into the target array

	if( typeof(TargetID) != "string" || TargetElement == null ||

		typeof(TargetElement) != "object" )

		return;

	if( typeof(CEngine.objTarget[TargetID]) != "object" )

		CEngine.objTarget[TargetID] = new CTarget( TargetElement );	

}



CEngine.SendEventToOneTarget = function(strTargetID, strBsscEvent,event )

{// to activate one target object

	if( typeof(CEngine.objTarget[strTargetID]) == "object" ) 

	{

		if( strBsscEvent == "bssctrigger1" || strBsscEvent == "bssctrigger2" )

		{//now, the "bssctrigger1" and "bssctrigger2" work like a toggle

			if( strBsscEvent == CEngine.objTarget[strTargetID].strTriggerEvent )

				strBsscEvent = (strBsscEvent == "bssctrigger1") ? "bssctrigger2" : "bssctrigger1";

			CEngine.objTarget[strTargetID].strTriggerEvent = strBsscEvent;

		}

		CEngine.objTarget[strTargetID].OnEvent( strBsscEvent,event );

	}

}



CEngine.SendEventToAllTarget = function( strBsscEvent,event )

{ //to activate all target associative to the BSSC event

	for( var strTargetID in CEngine.objTarget ) //to enumerate all target

		CEngine.SendEventToOneTarget( strTargetID, strBsscEvent,event );

}



CEngine.SetOneTargetInitialState = function( strTargetID )

{// only invoked after ALL effects for the target have been set

	if( typeof(CEngine.objTarget[strTargetID]) == "object" ) 

	{// to get target object

		var objTarget = CEngine.objTarget[strTargetID];

		if( objTarget.SetState( "bsscpageload" ) == false )

		{

			objTarget.SetState( "bsscpageclick" );

			objTarget.SetState( "bssctrigger1" );

		}

	}

}



CEngine.AdjustPageClickCounter = function()

{

	var nAdjustedClickCounter = CTarget.nPageClickCounter;

	var bAdjusted = false;

	for( var strTargetID in CEngine.objTarget ) //to enumerate all target

	{// try to find the minum pageCliclConter greater than CTarget.nPageClickCounter

		var objEventPageClick = CEngine.objTarget[strTargetID].objManager.bsscpageclick;

		if( objEventPageClick != null )

		{

			for( var i = 0; i < objEventPageClick.length; i++ )

			{

				var nOtherPageClick = objEventPageClick[i].nPageClick;

				if( nOtherPageClick == CTarget.nPageClickCounter )

					return;

				if( nOtherPageClick > CTarget.nPageClickCounter )

				{

					if( !bAdjusted )

					{

						nAdjustedClickCounter = nOtherPageClick;

						bAdjusted = true;

					}

					else if( nOtherPageClick < nAdjustedClickCounter )

						nAdjustedClickCounter = nOtherPageClick;

				}

			}

		}

	}

	CTarget.nPageClickCounter = nAdjustedClickCounter;

}



CEngine.OnPageLoad = function(event)

{ 	

	// first, to set all target's initial state

	for( var strTargetID in CEngine.objTarget )

		CEngine.SetOneTargetInitialState( strTargetID );

	

	// to invoke all target's onpageload handler

	CEngine.SendEventToAllTarget( "bsscpageload",event );

}



CEngine.OnPageClick = function(event)

{ // to invoke all target's onpageclick handler

   	var src = CCSSP.GetEventElement( arguments[0] );

   	if( src == null )

		return;

		

	var objClickedTrigger = null;

	for( var strTriggerID in CEngine.objTrigger )

	{ // to detect which trigger is clicked

		if( CCSSP.IsDescendant( CEngine.objTrigger[strTriggerID].eleTrigger,src) )

		{

			objClickedTrigger = CEngine.objTrigger[strTriggerID];

			break;

		}

	}

	

	if( objClickedTrigger != null) // the clicked trigger found

		objClickedTrigger.OnTriggerClick(event);

	else // no trigger is clicked

	{ // to send PageClick event to all target

		CTarget.nPageClickCounter++;

		CEngine.AdjustPageClickCounter();

		CEngine.SendEventToAllTarget( "bsscpageclick" ,event);

	}

}	



CEngine.OnMouseOver = function(event)

{ // to invoke all target's onpageload handler

	var src = CCSSP.GetEventElement( arguments[0] );

	if( src == null )

		return;

		

	var strHoveredTargetID = null;

	for( var strTargetID in CEngine.objTarget )

	{ // to detect which Target is hovering on

		if( CCSSP.IsDescendant( CEngine.objTarget[strTargetID].eleTarget, src ) )

	    {

			strHoveredTargetID = strTargetID;

			break;

	    }

	}

	

	if( strHoveredTargetID != null ) // the hovered target found

		CEngine.SendEventToOneTarget( strHoveredTargetID, "bsschover",event );

}



CEngine.BuildTargetObject = function(target_ID,event_type,action_type,

			action_setting, event_additional)

{// to build target object 

	// to get the target object

	if( typeof( CEngine.objTarget[target_ID] ) != "object" )

		return false;// the engine's AddOneTarget function might have failed.

	var TargetObject = CEngine.objTarget[target_ID];

	

	// to prepare the parameters for the event manager

	var arrEvent = event_type.split("|"); // to split the combined event_type string

	var arrAction = action_type.split("|");//to split the combined action_type string

	for( var trim = 0; trim < arrEvent.length; trim++ )

		arrEvent[trim] = CCSSP.TrimSpace(arrEvent[trim]);

	

	for( trim = 0; trim < arrAction.length; trim++ )

		arrAction[trim] = CCSSP.TrimSpace(arrAction[trim]);

	

	var arrSetting = new Array(); 

	if( typeof(action_setting) == "string" )

		arrSetting = action_setting.split("|");// to split the combined action_setting string

	// to calibrate the arrays

	for( var i = arrSetting.length; i < arrAction.length; i++ )

	{

		if( typeof(arrSetting[i]) != "string" )

			 arrSetting[i] = "";

	}				 



	// to prepare for dealing with the absolute posioning element

	TargetObject.eleTarget.ABSX = CCSSP.GetObjectLeft( TargetObject.eleTarget );

	TargetObject.eleTarget.ABSY = CCSSP.GetObjectTop( TargetObject.eleTarget );



	if( arrEvent.length > 1 )

	{// if event is combined, it must be : "bssctrigger1 | bssctrigger2"

		if( arrAction.length != 2 )

			return false; // if event is combined, there must be 2 actions

		for( i = 0 ; i < 2; i++ )

		{

			if( TargetObject.SetEventManager(arrEvent[i], arrAction[i], 

				arrSetting[i], event_additional) == false )

				return false; // the event manager has not been set up

		}

	}

	else // the event_type string is not combined

	{

		for( i = 0 ; i < arrAction.length; i++ )

		{

			TargetObject.SetEventManager(event_type, arrAction[i], arrSetting[i], event_additional);

			// to validate the event manager

			if( typeof(TargetObject.objManager[event_type]) != "object" ||

					typeof(TargetObject.objManager[event_type][i]) != "object" )

				return false; // the event manager has not been set up

		}

	}

	return true;

}



CEngine.BuildTriggerObject = function(trigger_ID, target_ID)

{// to build the trigger object

	var arrTrigger = trigger_ID.split("|"); // to split the combined trigger_ID string

	for( var i = 0; i < arrTrigger.length; i ++ )

	{// to get the trigger element then add it to the trigger list

		arrTrigger[i] = CCSSP.TrimSpace( arrTrigger[i] );

		var eleTrigger = CCSSP.GetObject( arrTrigger[i] );

		if( eleTrigger == null )

			continue; // the trigger_ID string in the HTML code maybe wrong

		CEngine.AddOneTrigger( arrTrigger[i], eleTrigger );



		// to get the target object

		if( typeof( this.objTrigger[arrTrigger[i]] ) != "object" )

			continue;// the engine's AddOneTarget function might have failed.

		CEngine.objTrigger[arrTrigger[i]].AddTargetID( target_ID );

	}

}

//End the definition of CEngine class



/// Section End  - CCSSP DHTM 1 (JavaScript 1.2)



/// Section Begin  - CCSSP DHTM 2 (JavaScript 1.2)



//Begin the definition of CAgencyXXXX classes



//Begin of the CAgencyShow definition

function CAgencyShow( element, bIsShow )

{

	this.ele = element;

	this.bIsShow = bIsShow;

}



CAgencyShow.prototype.PrepareEffect = function()

{

	CCSSP.ShowObject( this.ele, !this.bIsShow );

}



CAgencyShow.prototype.UpdateEffect = function()

{

	CCSSP.ShowObject( this.ele, this.bIsShow );

}



CAgencyShow.prototype.EndEffect = function()

{

	CCSSP.ShowObject( this.ele, !this.bIsShow );

}

// End of the CAgencyShow definition



// Begin of CAgencyFly definition

function CAgencyFly( element, settings, bIsIn )

{

	this.ele = element;

	this.bIsIn = bIsIn;

	this.duration = 1000; // default

	this.direction = "right";



	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{// to retrieve the setting

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "speed" : this.duration = 100000/arrOneSet[1]; break;

		case "direction" : this.direction = arrOneSet[1]; break;

		}

	}

		

	if( this.ele.style.position != "absolute" )

		this.ele.style.position = "relative";

	this.timer = null;

	this.aniIndex = CEngine.arrAnimation.length;

	CEngine.arrAnimation[this.aniIndex] = this;

}



CAgencyFly.prototype.PrepareEffect = function()

{

	CCSSP.ShowObject(this.ele, !this.bIsIn );

}



CAgencyFly.prototype.UpdateEffect = function()

{

	if( this.timer == null )

		this.ResetParameters();



	var percent = ((new Date()).getTime() - this.startTime)/this.duration;

	if( percent >= 1.0 )

		this.EndEffect();

	else

	{

		var newX = this.startX*(1.0-percent) +  this.finalX*percent;

		var newY = this.startY*(1.0-percent) +  this.finalY*percent;

		CCSSP.MoveObjectTo(this.ele, newX, newY);

		CCSSP.SetTimer(this,20);

	}

}



CAgencyFly.prototype.EndEffect = function()

{

	clearInterval( this.timer );

	this.timer = null;



	if( this.bIsIn ) // FlyIn

		CCSSP.MoveObjectTo(this.ele, this.finalX, this.finalY);

	else // FlyOut

		CCSSP.MoveObjectTo(this.ele, this.startX, this.startY);

	CCSSP.ShowObject(this.ele, this.bIsIn );

}



CAgencyFly.prototype.ResetParameters = function()

{

	this.PrepareEffect();

	CCSSP.ShowObject(this.ele, true );



	this.startX = 0;

	this.startY = 0;

	this.finalX = 0;

	this.finalY = 0; 

	

	var offsetLeft = CCSSP.GetObjectWindowLeft(this.ele) + this.ele.offsetWidth;

	var offsetTop = CCSSP.GetObjectWindowTop(this.ele) + this.ele.offsetHeight;

	var offsetRight = CCSSP.GetWindowRight();

	var offsetBottom = CCSSP.GetWindowBottom();



	if( this.bIsIn )

	{ // FlyIn

		this.finalX = this.ele.ABSX;

		this.finalY = this.ele.ABSY;



		switch( this.direction )

		{

		case "right": this.startX = offsetRight; this.startY = this.finalY; break;

		case "left": this.startX = -offsetLeft;  this.startY = this.finalY; break;

		case "down": this.startY = offsetBottom; this.startX = this.finalX; break;

		case "up":  this.startY = -offsetTop;    this.startX = this.finalX; break;

		case "downright":

  			this.startX = ( offsetBottom < offsetRight) ? offsetBottom : offsetRight;

			this.startY = this.startX;		break;

		case "upright":

  			this.startX = (offsetTop < offsetRight)? offsetTop : offsetRight;

			this.startY = -this.startX;		break;

		case "upleft":

			this.startX = -((offsetTop < offsetRight)? offsetTop : offsetRight);

			this.startY = this.startX;		break;

		case "downleft":

			this.startX = -(( offsetBottom < offsetRight) ? offsetBottom : offsetRight);

			this.startY = -this.startX;     break;

		}

	}

	else

	{ // FlyOut

		this.startX = this.ele.ABSX;

		this.startY = this.ele.ABSY;



		switch( this.direction )

		{

		case "right": this.finalX = offsetRight;  this.finalY = this.startY; break;

		case "left": this.finalX = -offsetLeft;   this.finalY = this.startY;  break;

		case "down": this.finalY = offsetBottom;  this.finalX = this.startX; break;

		case "up":  this.finalY = -offsetTop;     this.finalX = this.startX; break;

		case "downright":

  			this.finalX = ( offsetBottom < offsetRight) ? offsetBottom : offsetRight;

			this.finalY = this.finalX;		break;

		case "upright":

  			this.finalX = (offsetTop < offsetRight)? offsetTop : offsetRight;

			this.finalY = -this.finalX;		break;

		case "upleft":

			this.finalX = -((offsetTop < offsetRight)? offsetTop : offsetRight);

			this.finalY = this.finalX;		break;

		case "downleft":

			this.finalX = -(( offsetBottom < offsetRight) ? offsetBottom : offsetRight);

			this.finalY = -this.finalX;     break;

		}

	}

	CCSSP.MoveObjectTo(this.ele, this.startX, this.startY);

	this.startTime = (new Date()).getTime();

}

// End of the CAgencyFly definition



// Begin of CAgencySpiral

function CAgencySpiral( element, settings, bIsIn )

{

	this.ele = element;

	this.bIsIn = bIsIn;

	this.duration = 1000; // default



	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{// to retrieve the setting

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "speed" : this.duration = 100000/arrOneSet[1]; break;

		}

	}



	if( this.ele.style.position != "absolute" )

		this.ele.style.position = "relative";

	this.timer = null;

	this.aniIndex = CEngine.arrAnimation.length;

	CEngine.arrAnimation[this.aniIndex] = this;

}



CAgencySpiral.prototype.PrepareEffect = function()

{

	CCSSP.ShowObject(this.ele, !this.bIsIn );

}



CAgencySpiral.prototype.UpdateEffect = function()

{

	if( this.timer == null )

		this.ResetParameters();



	var percent = ((new Date()).getTime() - this.startTime)/this.duration;

	if( percent >= 1.0 )

		this.EndEffect();

	else

	{

		var rf = (this.bIsIn)? (1.0 - percent) : percent; 

		var t = (1.0-rf) * 4.0 * Math.PI

		var rxP = (this.bIsIn)? this.startX : this.finalX; 

		var ryP = (this.bIsIn)? this.startY : this.finalY; 

		var rx = (Math.abs(rxP) < 200) ? Math.abs(rxP) : 200;

		var ry = (Math.abs(ryP) < 200) ? Math.abs(ryP) : 200;



		var newX = Math.ceil(-rf*Math.cos(t)*rx) + this.ele.ABSX;

		var newY = Math.ceil(-rf*Math.sin(t)*ry) + this.ele.ABSY;

		CCSSP.MoveObjectTo(this.ele, newX, newY);

		CCSSP.SetTimer(this,20);

	}

}



CAgencySpiral.prototype.EndEffect = function()

{

	clearInterval( this.timer );

	this.timer = null;

	

	if( this.bIsIn ) // In

		CCSSP.MoveObjectTo(this.ele, this.finalX, this.finalY);

	else // Out

		CCSSP.MoveObjectTo(this.ele, this.startX, this.startY);

	CCSSP.ShowObject(this.ele, this.bIsIn );

}



CAgencySpiral.prototype.ResetParameters = function()

{

	this.PrepareEffect();

	CCSSP.ShowObject(this.ele, true );

	this.startX = (this.bIsIn)? CCSSP.GetWindowRight() : this.ele.ABSX;

	this.startY = (this.bIsIn)? CCSSP.GetWindowBottom() : this.ele.ABSY;

	this.finalX = (this.bIsIn)? this.ele.ABSX : CCSSP.GetWindowRight();

	this.finalY = (this.bIsIn)? this.ele.ABSY : CCSSP.GetWindowBottom(); 

	

	CCSSP.MoveObjectTo(this.ele, this.startX, this.startY);

	this.startTime = (new Date()).getTime();

}

// End of CAgencySpiral



// Begin of CAgencyElastic

function CAgencyElastic( element, settings)

{

	this.ele = element;

	this.duration = 1000; // default

	this.direction = "right";



	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{// to retrieve the setting

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "speed" : this.duration = 100000/arrOneSet[1]; break;

		case "direction" : this.direction = arrOneSet[1]; break;

		}

	}

		

	if( this.ele.style.position != "absolute" )

		this.ele.style.position = "relative";

	this.timer = null;

	this.aniIndex = CEngine.arrAnimation.length;

	CEngine.arrAnimation[this.aniIndex] = this;

}



CAgencyElastic.prototype.PrepareEffect = function()

{

	CCSSP.ShowObject(this.ele, false );

}



CAgencyElastic.prototype.UpdateEffect = function()

{

	if( this.timer == null )

		this.ResetParameters();



	var percent = ((new Date()).getTime() - this.startTime)/this.duration;

	if( percent >= 1.0 )

		this.EndEffect();

	else

	{

		var newX = this.startX;

		var newY = this.startY;

		var rf = Math.exp(-percent*3);

		var t = percent * 1.5 * Math.PI

		var rx = (Math.abs(this.startX) > Math.abs(this.startY)) ? this.startX : this.startY;

		switch (this.direction )

		{

		case "left":   

		case "right" : newX = rf*Math.cos(t)*rx + this.ele.ABSX; break;

		case "up":	   

		case "down" :  newY = rf*Math.cos(t)*rx + this.ele.ABSX; break;

		}

		CCSSP.MoveObjectTo(this.ele, newX, newY);

		CCSSP.SetTimer(this,20);

	}

}



CAgencyElastic.prototype.EndEffect = function()

{

	CCSSP.MoveObjectTo(this.ele, this.finalX, this.finalY);

	clearInterval( this.timer );

	this.timer = null;

}



CAgencyElastic.prototype.ResetParameters = function()

{

	CCSSP.ShowObject(this.ele, true );

	this.startX = this.ele.ABSX;

	this.finalX = this.ele.ABSX;

	this.startY = this.ele.ABSY;

	this.finalY = this.ele.ABSY;

	

	switch (this.direction)

	{ 

	case "left":  this.startX = -this.ele.offsetWidth; break;

	case "right": this.startX = this.ele.offsetWidth;  break;

	case "up":    this.startY = -this.ele.offsetHeight;break;

	case "down":  this.startY = this.ele.offsetHeight; break;

	}

	CCSSP.MoveObjectTo(this.ele, this.startX, this.startY);

	this.startTime = (new Date()).getTime();

}

// End of CAgencyElastic



// Begin of CAgencyZoom

function CAgencyZoom( element, settings, bIsIn)

{

	this.ele = element;

	this.duration = 1000; // default

	

	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{// to retrieve the setting

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "speed" : this.duration = 100000/arrOneSet[1]; break;

		}

	}



	this.bIsIn = bIsIn;

	this.timer = null;

	this.aniIndex = CEngine.arrAnimation.length;

	CEngine.arrAnimation[this.aniIndex] = this;

}



CAgencyZoom.prototype.PrepareEffect = function()

{

	CCSSP.ShowObject(this.ele, false);

}



CAgencyZoom.prototype.UpdateEffect = function()

{

	if( this.timer == null )

		this.ResetParameters();



	var percent = ((new Date()).getTime() - this.startTime)/this.duration;

	if( percent >= 1.0 )

		this.EndEffect();

	else

	{

		var nFactorIn = Math.ceil(50+50*percent);

		var nFactorOut = Math.ceil(100+200*(1-percent));

		var AlterFontsize = ((this.bIsIn)? nFactorIn : nFactorOut) + "%";

		var AlterFactor = ((this.bIsIn)? nFactorIn : nFactorOut) / 100;

		

		this.UpdateEffectAllChildren(this.ele, AlterFontsize, AlterFactor);

		var arr ;

		if (this.ele.all)

		    arr = this.ele.all ;

		else

		    arr = this.ele.getElementsByTagName ('*');

		for(var index = 0; index < arr.length; index++)

			this.UpdateEffectAllChildren(arr[index], AlterFontsize, AlterFactor);

			

		CCSSP.SetTimer(this,20);

	}

}



CAgencyZoom.prototype.UpdateEffectAllChildren = function(child, FontSize, Factor)

{

	if( CCSSP.IsTextTag(child) )

		child.style.fontSize = FontSize;

	else

	{

		if( typeof(child.orgWidth) == "number" )

			child.style.width = Factor * child.orgWidth;

		if( typeof(child.orgHeight) == "number" )

			child.style.height = Factor * child.orgHeight;

	}

}



CAgencyZoom.prototype.EndEffect = function()

{

	this.EndEffectAllChildren(this.ele);

	var arr ;

	if(this.ele.all)

	    arr = this.ele.all ;

	else

	    arr = this.ele.getElementsByTagName('*');

	for(var index = 0; index < arr.length; index++)

		this.EndEffectAllChildren(arr[index]);

	

	clearInterval( this.timer );

	this.timer = null;

}



CAgencyZoom.prototype.EndEffectAllChildren = function( child )

{	

	if( CCSSP.IsTextTag(child) )

		child.style.fontSize = child.orgFontSize;

	else

	{

		if( typeof(child.intactWidth) != "undefined" )

		{

			child.width = child.intactWidth;

			child.height = child.intactHeight;

		}

		else if( typeof(child.style.intactPixelWidth) != "undefined" )

		{

			child.style.pixelWidth = child.style.intactPixelWidth;

			child.style.pixelHeight = child.style.intactPixelHeight;

		}

	}

}



CAgencyZoom.prototype.ResetParameters = function()

{

	this.PrepareEffect();

	this.ResetParametersAllChildren( this.ele );

	var arr ;

	if (this.ele.all)

	    arr = this.ele.all ;

	else

	    arr = this.ele.getElementsByTagName('*');

	for(var index = 0; index < arr.length; index++)

		this.ResetParametersAllChildren(arr[index]);

		

	this.startTime = (new Date()).getTime();

}



CAgencyZoom.prototype.ResetParametersAllChildren = function( child )

{

	CCSSP.ShowObject(child, true );

	if( (child.tagName == "DIV") && (getParentNode(child).tagName == "TD") )

		child.width = "100%";// if the div is inside a cell of table, we need the this hack

	

	if( CCSSP.IsTextTag(child) )

		child.orgFontSize = child.style.fontSize;

	else

	{

		if( child.width > "" || child.height > "" )

		{

			child.orgWidth = child.intactWidth = child.width;

			child.orgHeight = child.intactHeight = child.height;

		}

		else if( ( typeof(child.orgWidth) != "number" ) && (typeof(child.orgHeight) != "number") )

		{

			child.orgWidth = child.style.intactPixelWidth = child.style.pixelWidth;

			child.orgHeight = child.style.intactPixelHeight = child.style.pixelHeight;

		}

	}

}

// End of CAgencyZoom



//// the following effects will use IE's exclusive "filter" function ////

// Begin of CAgencyAlpha definition

function CAgencyAlpha( element, settings, bIsIn )

{// because of "visual filter" style, this won't work in Navigator

	this.ele = element;

	this.bIsIn = bIsIn;



	// to set the default value

	this.startOpacity = (this.bIsIn) ? 0 : 100;

	this.endOpacity = (this.bIsIn) ? 100 : 0;

	

	this.duration = 1000; // default

	

	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{// to retrieve the setting

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "speed" : this.duration = 100000/arrOneSet[1]; break;

		}

	}

	

	this.timer = null;

	this.aniIndex = CEngine.arrAnimation.length;

	CEngine.arrAnimation[this.aniIndex] = this;

}



CAgencyAlpha.prototype.PrepareEffect = function()

{// to set the visual filter function

	// the visual filter ONLY work when set by "Width and Height" or

	// absolute position for DIV, SPAN and normal tag ( such as p )

	// but, "absolute" cause the following elements overlap, so:

	CCSSP.PrepareFilter( this.ele );

	CCSSP.ShowObject(this.ele, !this.bIsIn );

}



CAgencyAlpha.prototype.UpdateEffect = function()

{// to set the visual filter function

	if( this.timer == null )

		this.ResetParameters();

	if( typeof(this.ele.filters.alpha) != "object" )

	{

		this.EndEffect();

		return;

	}



	var percent = ((new Date()).getTime() - this.startTime)/this.duration;

	if( percent >= 1.0 )

		this.EndEffect();

	else if( typeof(this.ele.filters.alpha) == "object" )

	{

		this.ele.filters.alpha.opacity = this.startOpacity*(1.0-percent) + this.endOpacity*percent;

		CCSSP.SetTimer(this,20);

	}

}



CAgencyAlpha.prototype.EndEffect = function()

{// to remove the visual filter function

	clearInterval( this.timer );

	this.timer = null;

	this.ele.style.filter = "";

	CCSSP.ShowObject(this.ele, this.bIsIn );

}



CAgencyAlpha.prototype.ResetParameters = function()

{

	this.PrepareEffect();

	CCSSP.ShowObject(this.ele, true );

	this.ele.style.filter = "alpha(opacity=" + this.startOpacity + ")";

	this.startTime = (new Date()).getTime();

}

// End of the CAgencyAlpha definition



// Begin of CAgencyWave definition

function CAgencyWave( element, settings )

{// because of "visual filter" style, this won't work in Navigator

	this.ele = element;



	this.duration = 0; // default

	this.strength = 10;

	this.freq = 1;

	this.lightstrength = 1;

	

	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{// to retrieve the setting

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "duration" : this.duration = 100000/arrOneSet[1]; break;

		case "strength" : this.strength = arrOneSet[1]; break;

		case "freq" : this.freq = arrOneSet[1]; break;

		case "lightstrength" : this.lightstrength = arrOneSet[1]; break;

		}

	}



	this.timer = null;

	this.aniIndex = CEngine.arrAnimation.length;

	CEngine.arrAnimation[this.aniIndex] = this;

}



CAgencyWave.prototype.PrepareEffect = function()

{// to set the visual filter function

	CCSSP.PrepareFilter(this.ele);



	CCSSP.ShowObject(this.ele, true );

}



CAgencyWave.prototype.UpdateEffect = function()

{// to set the visual filter function

	if( this.timer == null )

		this.ResetParameters();

	if( (typeof(this.ele.filters) == "undefined") || (typeof(this.ele.filters.wave) != "object" ) )

	{

		this.EndEffect();

		return;

	}



	if( this.duration > 0 )

	{

		var percent = ((new Date()).getTime() - this.startTime)/this.duration;

		if( percent >= 1.0 )

		{

			this.EndEffect();

			return;

		}

	}

	

	this.ele.filters.wave.phase += 5;

	this.ele.filters.wave.phase %= 100;

	CCSSP.SetTimer(this,50);

}



CAgencyWave.prototype.EndEffect = function()

{// to remove the visual filter function

	this.ele.style.filter = "";

	clearInterval( this.timer );

	this.timer = null;

}



CAgencyWave.prototype.ResetParameters = function()

{

	this.PrepareEffect();

	this.ele.style.filter = "wave(strength=" + this.strength + ",freq=" + 

	 this.freq +", lightstrength=" + this.lightstrength +",phase=0);";

	this.startTime = (new Date()).getTime();

}

// End of the CAgencyWave definition



// Begin of CAgencyGlow definition

function CAgencyGlow( element, settings )

{// because of "visual filter" style, this won't work in Navigator

	this.ele = element;



	// to set the default value

	this.glowColor = "green";

	this.glowStrength = "3";

	

	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "color" : this.glowColor = arrOneSet[1]; break;

		case "strength" : this.glowStrength = arrOneSet[1]; break;

		}

	}

}



CAgencyGlow.prototype.PrepareEffect = function()

{

	CCSSP.PrepareFilter(this.ele);

	CCSSP.ShowObject(this.ele, true );

	if( this.ele.style.backgroundColor != "" )

	{//style.backgroundColor somehow stop the visual filter

		this.ele.intactBackgroundColor = this.ele.style.backgroundColor;

		this.ele.style.backgroundColor = "";

	}

}



CAgencyGlow.prototype.UpdateEffect = function()

{// to set the visual filter function

	this.PrepareEffect();

	this.ele.style.filter = "glow(Color=" + this.glowColor + ", Strength=" + 

		this.glowStrength + ", enabled=true" +")";

}



CAgencyGlow.prototype.EndEffect = function()

{// to remove the visual filter function

	this.ele.style.filter = "";

	if( typeof(this.ele.intactBackgroundColor) != "undefined" )

		this.ele.style.backgroundColor = this.ele.intactBackgroundColor;

}

// End of the CAgencyGlow definition



// Begin of CAgencyDropShadow definition

function CAgencyDropShadow( element, settings )

{// because of "visual filter" style, this won't work in Navigator

	this.ele = element;



	// to set the default value

	this.shadowColor = "black"; 

	this.shadowOffx = "1";

	this.shadowOffy = "1";

	

	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "color" : this.shadowColor = arrOneSet[1]; break;

		case "offx" : this.shadowOffx = arrOneSet[1]; break;

		case "offy" : this.shadowOffy = arrOneSet[1]; break;

		}

	}

}



CAgencyDropShadow.prototype.PrepareEffect = function()

{

	CCSSP.PrepareFilter(this.ele);

	CCSSP.ShowObject(this.ele, true );

	

	if( this.ele.style.backgroundColor != "" )

	{//style.backgroundColor somehow stop the visual filter

		this.ele.intactBackgroundColor = this.ele.style.backgroundColor;

		this.ele.style.backgroundColor = "";

	}

}



CAgencyDropShadow.prototype.UpdateEffect = function()

{// to set the visual filter function

	this.PrepareEffect();

	this.ele.style.filter = "dropshadow(color=" + this.shadowColor + ", offx=" + 

		this.shadowOffx + ", offy=" + this.shadowOffy + ")";

}



CAgencyDropShadow.prototype.EndEffect = function()

{// to remove the visual filter function

	this.ele.style.filter = "";

	if( typeof(this.ele.intactBackgroundColor) != "undefined" )

		this.ele.style.backgroundColor = this.ele.intactBackgroundColor;

}

// End of the CAgencyDropShadow definition



// Begin of CAgencyRevealTrans definition

function CAgencyRevealTrans( element, settings )

{// because of "visual filter" style, this won't work in Navigator

	this.ele = element;



	// to set the default value

	this.duration = 1.0; //The value is specified in seconds.milliseconds format (0.0000).

	this.transition = 0;

	

	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "type" : this.transition = arrOneSet[1]; break;

		case "duration" : this.duration = 100/arrOneSet[1];	break;

		}

	}

}



CAgencyRevealTrans.prototype.PrepareEffect = function()

{

	CCSSP.PrepareFilter(this.ele);

	CCSSP.ShowObject( this.ele, false);

}



CAgencyRevealTrans.prototype.UpdateEffect = function()

{// to set the visual filter function

	if( typeof( this.ele.filters.RevealTrans ) == "object" )

	{

		if( this.ele.filters.RevealTrans.status == 2 )

			this.ele.filters.RevealTrans.stop();  

	}



	this.PrepareEffect();

	

	this.ele.style.filter = "RevealTrans(duration=" + this.duration + 

		", transition=" + this.transition + ")";

	

    if( typeof( this.ele.filters.RevealTrans ) == "object" )

    {

		this.ele.filters.RevealTrans.apply();

		CCSSP.ShowObject( this.ele, true);

		this.ele.filters.RevealTrans.play();  

	}

	else

		CCSSP.ShowObject( this.ele, true);

}



CAgencyRevealTrans.prototype.EndEffect = function()

{

    if( typeof( this.ele.filters.RevealTrans ) == "object" )

		this.ele.filters.RevealTrans.stop();  

	this.ele.style.filter = "";

}

// End of the CAgencyRevealTrans definition



// Begin of CAgencyBlur definition

function CAgencyBlur( element, settings )

{// because of "visual filter" style, this won't work in Navigator

	this.ele = element;



	// to set the default value

	this.strength = "5";

	this.direction = "90";

	

	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "strength" : this.strength = arrOneSet[1]; break;

		case "direction" : this.direction = arrOneSet[1]; break;

		}

	}

}



CAgencyBlur.prototype.PrepareEffect = function()

{

	CCSSP.PrepareFilter(this.ele);

	CCSSP.ShowObject(this.ele, true );

}



CAgencyBlur.prototype.UpdateEffect = function()

{// to set the visual filter function

	CCSSP.PrepareFilter(this.ele);

	this.ele.style.filter = "blur(strength=" + this.strength + 

		", direction=" + this.direction + ")";

}



CAgencyBlur.prototype.EndEffect = function()

{// to remove the visual filter function

	this.ele.style.filter = "";

}

// End of the CAgencyBlur definition



// Begin of CAgencyChangeFilter definition

function CAgencyChangeFilter( element, settings ) // flipH, flipV, invert, grey,

{// because of "visual filter" style, this won't work in Navigator

	this.ele = element;



	// to set the default value

	this.filterFunction = settings;

}



CAgencyChangeFilter.prototype.PrepareEffect = function()

{

	CCSSP.PrepareFilter(this.ele);

	CCSSP.ShowObject(this.ele, true );

}



CAgencyChangeFilter.prototype.UpdateEffect = function()

{// to set the visual filter function

	CCSSP.PrepareFilter(this.ele);

	this.ele.style.filter = this.filterFunction;

}



CAgencyChangeFilter.prototype.EndEffect = function()

{// to remove the visual filter function

	this.ele.style.filter = "";

}

// End of the CAgencyChangeFilter definition



// The effects below change the style on the fly, so they won't work in Navigator



// Begin of CAgencyFontChange definition, 

function CAgencyFontChange( element, settings )

{//this class can be replace by CAgencyChangeStyle,provided the "settings" is standard CSS string.

	this.ele = element;

	

	// to retrieve the original font style

	this.RetrieveOldFont( this.ele );

	

	// to set the default font to change

	this.newfontFamily = this.ele.oldFontFamily;

	this.newfColor = this.ele.oldColor;

	this.newtextDecoration = this.ele.oldTextDecoration;

	this.newfontWeight = this.ele.oldFontWeight;

	this.newfontStyle = this.ele.oldFontStyle;

	this.newfontSize = this.ele.oldFontSize;

	this.newBackgroundColor = this.ele.oldBackgroundColor;

	

	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{// to retrieve the setting

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "font-family" : this.newfontFamily = arrOneSet[1]; break;

		case "color" : this.newfColor = arrOneSet[1]; break;

		case "underline" : this.newtextDecoration = (arrOneSet[1]=="on")? "underline" : "none"; break;

		case "bold" : this.newfontWeight = (arrOneSet[1]=="on")? "bold" : "normal"; break;

		case "italic" : this.newfontStyle = (arrOneSet[1]=="on")? "italic" : "normal"; break;

		case "size" : this.newfontSize = arrOneSet[1]; break;

		case "background-color" : this.newBackgroundColor = arrOneSet[1]; break;

		}

	}

}



CAgencyFontChange.prototype.RetrieveOldFont = function(objChild)

{

	if( typeof(objChild.oldFontFamily) == "undefined" )

		objChild.oldFontFamily = objChild.style.fontFamily;

	if( typeof(objChild.oldColor) == "undefined" )

		objChild.oldColor = objChild.style.color;

	if( typeof(objChild.oldTextDecoration) == "undefined" )

		objChild.oldTextDecoration = objChild.style.textDecoration;

	if( typeof(objChild.oldFontWeight) == "undefined" )

		objChild.oldFontWeight = objChild.style.fontWeight;

	if( typeof(objChild.oldFontStyle) == "undefined" )

		objChild.oldFontStyle = objChild.style.fontStyle;

	if( typeof(objChild.oldFontSize) == "undefined" )

		objChild.oldFontSize = objChild.style.fontSize;

	if( typeof(objChild.oldBackgroundColor) == "undefined" )

		objChild.oldBackgroundColor = objChild.style.backgroundColor;

}



CAgencyFontChange.prototype.PrepareEffect = function()

{

	// as for expanding text, the child is created after the constructor called

	var arr = this.ele.getElementsByTagName ('*');

	for(var index = 0; index < arr.length; index++)

		this.RetrieveOldFont(arr[index]);

	CCSSP.ShowObject(this.ele, true );

}



CAgencyFontChange.prototype.UpdateEffect = function()

{// to change the font

	this.PrepareEffect();

	this.UpdateEffectAllChildren( this.ele );

	var arr = this.ele.getElementsByTagName ('*');

	for( var index = 0; index < arr.length; index++)

		this.UpdateEffectAllChildren(arr[index]);

}



CAgencyFontChange.prototype.UpdateEffectAllChildren = function(objChild)

{

	objChild.style.fontFamily = this.newfontFamily;

	objChild.style.color = this.newfColor;

	objChild.style.textDecoration = this.newtextDecoration;

	objChild.style.fontWeight = this.newfontWeight;

	objChild.style.fontStyle = this.newfontStyle;

	objChild.style.fontSize = this.newfontSize;

	objChild.style.backgroundColor = this.newBackgroundColor;

}



CAgencyFontChange.prototype.EndEffect = function()

{// to reinstate the original font style

	this.EndEffectAllChildren( this.ele );

	var arr = this.ele.getElementsByTagName ('*');

	for( var index = 0; index < arr.length; index++)

		this.EndEffectAllChildren(arr[index]);

}



CAgencyFontChange.prototype.EndEffectAllChildren = function( objChild )

{

	if( typeof(objChild.oldFontFamily) != "undefined" )

		objChild.style.fontFamily = objChild.oldFontFamily;

	if( typeof(objChild.oldColor) != "undefined" )

		objChild.style.color = objChild.oldColor;

	if( typeof(objChild.oldFontWeight) != "undefined" )

		objChild.style.fontWeight = objChild.oldFontWeight;

	if( typeof(objChild.oldFontStyle) != "undefined" )

		objChild.style.fontStyle = objChild.oldFontStyle;

	if( typeof(objChild.oldFontSize) != "undefined" )

		objChild.style.fontSize = objChild.oldFontSize;

	if( typeof(objChild.oldTextDecoration) != "undefined" )

		objChild.style.textDecoration = objChild.oldTextDecoration;

	if( typeof(objChild.oldBackgroundColor) != "undefined" )

		objChild.style.backgroundColor = objChild.oldBackgroundColor;

}

// End of the CAgencyFontChange definition



// Begin of the CAgencyChangeStyle definition

function CAgencyChangeStyle( element, settings )

{//this class can be replace by CAgencyChangeStyle,provided the "settings" is standard CSS string.

	this.ele = element;

	

	// to retrieve the original style

	this.oldstyle = this.ele.style.cssText;

	

	// to set the default style

	this.newStyle = this.oldstyle;

	

	if( typeof(settings) == "string" && settings.length > 1 )

		this.newStyle = this.oldstyle + " " + settings;

}



CAgencyChangeStyle.prototype.PrepareEffect = function()

{

	CCSSP.ShowObject(this.ele, true );

}



CAgencyChangeStyle.prototype.UpdateEffect = function()

{// to change the style

	this.ele.style.cssText = this.newStyle;

}



CAgencyChangeStyle.prototype.EndEffect = function()

{// to reinstate the original style

	this.ele.style.cssText = this.oldStyle;

}

// End of the CAgencyChangeStyle definition



//End the definition of CAgencyXXXX classes



//Begin to collaborate with other event handler settings 

CCSSP.RegisterEventHandler( window, "onload", "CEngine.OnPageLoad(event);BSSCOnLoad(event);InitTriggersInHead(event);");

CCSSP.RegisterEventHandler( document, "onclick", "CEngine.OnPageClick(event);BSSCOnClick(event);");

CCSSP.RegisterEventHandler( document, "onmouseover", "CEngine.OnMouseOver(event);BSSCOnMouseOver(event);" );

CCSSP.RegisterEventHandler( document, "onmouseout", "CEngine.OnMouseOver(event);BSSCOnMouseOut(event);" );

CCSSP.RegisterEventHandler( window, "onunload", "BSSCOnUnload();");







// function related to autosize popup, custom popup and textonly popup

var gMsgSeparator = "::";



function isInsidePopup()

{

	return (window.name.indexOf("BSSCPopup")!=-1);

}



if(isLocal && (gbChrome || gbBsNS6))

{

	if(window.addEventListener)

		window.addEventListener("message", onRcvContentSizeMsg, false);

}



function getDocHeight(D) {

    return Math.max(

        Math.max(D.body.scrollHeight, D.documentElement.scrollHeight),

        Math.max(D.body.offsetHeight, D.documentElement.offsetHeight),

        Math.max(D.body.clientHeight, D.documentElement.clientHeight)

    );

}



function getDocWidth(D) {

    return Math.max(

        Math.max(D.body.scrollWidth, D.documentElement.scrollWidth),

        Math.max(D.body.offsetWidth, D.documentElement.offsetWidth),

        Math.max(D.body.clientWidth, D.documentElement.clientWidth)

    );

}



function trim(stringToTrim) {

	return stringToTrim.replace(/^\s+|\s+$/g,"");

}



function parseMsgData(strData)

{

	var nvPairs = strData.split(","); //get name value pairs

	if(nvPairs.length>0)

	{

		var obj = new Object();

		for(var i=0; i<nvPairs.length; i++)

		{

			trim(nvPairs[i]);

			var nvPair = nvPairs[i].split(":");

			if(nvPair.length == 2)

			{

				obj[nvPair[0]] = nvPair[1];

			}

		}

		return obj;

	}

	return null;

}





function replyContentSize(targetWnd)

{

	targetWnd.postMessage("sendContentSize" + gMsgSeparator + ",height:" + getDocHeight(document) + ",width:" + getDocWidth(document), "*");

}







var	gLastHeight = 0;

var	gLastWidth = 0;

function onRcvContentSizeMsg(event)

{

    var msg = event.data.split(gMsgSeparator);

    var msgType = msg[0];

    var msgData = msg[1];

    switch(msgType)

    {

    case "sendContentSize":

	    {

	       		var  	stepSize = 50;

			

			var obj  = parseMsgData(msgData);

	       		rhPopupEx.setHeight(parseInt(obj.height));

			rhPopupEx.setWidth(parseInt(obj.width));

			

			if(typeof(rhPopupEx.gLastGoodHeight) == 'undefined' || rhPopupEx.gLastGoodHeight == 0)

			{

				rhPopupEx.gLastGoodHeight = rhPopupEx.height;

				rhPopupEx.gLastGoodWidth = rhPopupEx.width;

			}

			else

			{

				if(rhPopupEx.height < gLastHeight) 

				{

					rhPopupEx.gLastGoodHeight = rhPopupEx.height;

					rhPopupEx.gLastGoodWidth = rhPopupEx.width;

				}

			}



			if(rhPopupEx.canDoBetter())

			{

				gLastWidth = rhPopupEx.width;

				gLastHeight = rhPopupEx.height;

				

				rhPopupEx.resizePopup(rhPopupEx.width+stepSize, 1);

				requestContentSize(event.source);

				

			}

			else{

				rhPopupEx.setHeight(rhPopupEx.gLastGoodHeight);

				rhPopupEx.setWidth(rhPopupEx.gLastGoodWidth);

				rhPopupEx.gLastGoodHeight = 0;

				rhPopupEx.gLastGoodWidth = 0;

				gLastHeight = 0;

				gLastWidth = 0;

				rhPopupEx.resizeMoveAndShowPopup();

			}

	    }

	break;

     case "getContentSize":

	replyContentSize(event.source);

        break;

     case "updateLinks":

	BSSCPopup_ChangeTargettoParent(document);

	break;

     case "getCpHTML5Size":

	replyCpHTML5Size(event.source, msgData);

	break;

     case "setCpHTML5Size":

	onGetReplyCpHTML5Size(event.source, msgData);

	break;

    }

}



function requestContentSize(targetWnd)

{

	if(targetWnd && targetWnd.postMessage)

		targetWnd.postMessage("getContentSize" + gMsgSeparator + " ", "*");

}



function requestUpdateLinks(targetWnd)

{

	if(targetWnd && targetWnd.postMessage)

		targetWnd.postMessage("updateLinks" + gMsgSeparator + " ", "*");

}



function onPopupClicked(e)

{

	var target = null;

	var popupIFrame = rhPopupEx.getPopupIFrame();

	if(!e) 

		e = popupIFrame.contentWindow.event;

	if(e)

	{

		if(e.target)

			target = e.target;

		else 

			target = e.srcElement;

	}

	if(!gbAIR)

	{

		if(target && isInsideHyperLink(target))

			return;

	}

	if(window.removeEventListener)

		window.removeEventListener("mousedown", onPopupParentClicked, false);

	else if(window.document.detachEvent)

		window.document.detachEvent('onmousedown', onPopupParentClicked);

	rhPopupEx.removePopup();

}



function onPopupParentClicked(e)

{

	if(window.removeEventListener)

		window.removeEventListener("mousedown", onPopupParentClicked, false);

	else if(window.document.detachEvent)

		window.document.detachEvent('onmousedown', onPopupParentClicked);

	rhPopupEx.removePopup();

}



var rhPopupEx = new RHPopupEx;

function RHPopupEx()

{

	this.strPopupID = 'BSSCPopup';

	this.strPopupShadowID = 'BSSCPopupShadow';

	this.strPopupTopicID = 'BSSCPopupTopic';

	this.strPopupIFrameID = 'BSSCPopupIFrame';

	this.strPopupIFrameName = 'BSSCPopupIFrameName';

	this.strPopupURL = '';

	this.strBookmark = '';

	this.width = 0;

	this.height = 0;

	this.clientWidth = 0;

	this.clientHeight = 0;

	this.gHeight = 0;

	this.gWidth = 0;

	this.bCustomHeight = false;



	//scrollbar height and width

	this.scrollbarheight = 20; //can we ask the browser for this info

	this.scrollbarwidth = 20;



	this.init = function()

	{

		this.getVisibilityStyle();

		this.strPopupURL = '';

		this.strBookmark = '';

		this.width = 0;

		this.height = 0;

		this.clientWidth = 0;

		this.clientHeight = 0;

		this.gHeight = 0;

		this.gWidth = 0;

		this.removePopup();

	}



	this.setPopupURL = function(strURL)

	{

		var indx = strURL.indexOf("#");

		if(indx != -1)

		{

			this.strPopupURL = strURL.substring(0, indx);

			this.strBookmark = strURL.substring(indx);

		}

		else

			this.strPopupURL = strURL;

	}

	this.setWidth = function(width)

	{

		this.width = width;

	}

	this.setHeight = function(height)

	{

		this.height = height;

	}

	this.setClickPosition= function(x, y)

	{

		this.clickX = x + getScrollLeft();

		this.clickY = y + getScrollTop();

	}



	this.createPopup= function(strURL, width, height)

	{

		this.init();

		if ("undefined" != typeof(width) && "undefined" != typeof(height)) {

			this.setWidth(width);

			this.setHeight(height);

			this.bCustomHeight = true;

		}

		if(typeof(strURL) == 'undefined' || strURL == '')

			return false;

		this.setPopupURL(strURL);

		this.createPopupContainer();

	}



	this.createPopupContainer = function()

	{

		// DO NOT SET Width and height for the div, otherwize it will make IE4 popup do not work when view the topic alone.

		var strPopupDiv = "<div id='" + this.strPopupID + "' style='position:absolute; top:-100; left:0; z-index:600; visibility:hidden;'>";

		strPopupDiv += "<div id='" + this.strPopupShadowID + "' style=\"position:absolute;top:0; left:0; background-color:#C0C0C0;\"></div>";

		strPopupDiv += "<div id='" + this.strPopupTopicID + "' style=\"position:absolute;top:0; left:0;  background-color:#FFFFFF;border:1px #000000 outset;"; 

		if(gbSafari3 && gbBsIsMobile)

			strPopupDiv += "overflow:auto; -webkit-overflow-scrolling:touch;";

		strPopupDiv += "\">";

		strPopupDiv += "<iframe height=\"10px\" width=\"200px\" title=\"Popup Window\" id='" + this.strPopupIFrameID + "' name='" + this.strPopupIFrameName + "' src='" + this.strPopupURL + "' frameborder=0 scrolling=auto";

		strPopupDiv += " onload=\"rhPopupEx.OnLoadRHPopup();\"";

		strPopupDiv += "></iframe></div>";  

		strPopupDiv += "</div>";



		var oBody = getElementsByTag(document, "body")[0];

		if( typeof(oBody) != "object" )

			return;



		insertAdjacentHTML(oBody, "beforeEnd", strPopupDiv);

	}



	this.removePopup = function()

	{

		var popup = this.getPopupContainer();

		if(popup)

			removeThis(popup);

	}



	this.getPopupContainer = function()

	{

		var elem  = document.getElementById(this.strPopupID);

		if(typeof(elem) != 'undefined' && elem != null)

			return elem;

		return null;

	}

	this.getPopupIFrame = function()

	{

		var elem  = document.getElementById(this.strPopupIFrameID);

		if(typeof(elem) != 'undefined' && elem != null)

			return elem;

		return null;

	}

	this.getPopupShadow = function()

	{

		var elem  = document.getElementById(this.strPopupShadowID);

		if(typeof(elem) != 'undefined' && elem != null)

			return elem;

		return null;

	}

	this.getPopupTopic = function()

	{

		var elem  = document.getElementById(this.strPopupTopicID);

		if(typeof(elem) != 'undefined' && elem != null)

			return elem;

		return null;

	}



	this.hidePopup = function()

	{

		this.getPopupContainer().style.visibility = this.strStyVisHide;

		this.getPopupIFrame().style.visibility = this.strStyVisHide;

	}



	this.showPopup = function()

	{

		this.getPopupContainer().style.visibility = this.strStyVisShow;

		this.getPopupIFrame().style.visibility = this.strStyVisShow;

	}



	this.getVisibilityStyle = function()

	{

		if (gbBsNS4&&!gbBsNS6)

		{

			this.strStyVisShow	= "show";

			this.strStyVisHide	= "hide";

		}

		else

		{

			this.strStyVisShow	= "visible";

			this.strStyVisHide	= "hidden";

		}

	}



	this.getClientWndSize = function () {

	    var viewportwidth;

	    var viewportheight;



	    // the more standards compliant browsers (mozilla/netscape/opera/IE7) use window.innerWidth and window.innerHeight

	    if (typeof window.innerWidth != 'undefined') {

	        viewportwidth = window.innerWidth;

	        viewportheight = window.innerHeight;

	    }

	    // IE6 in standards compliant mode (i.e. with a valid doctype as the first line in the document)

	    else if (typeof document.documentElement != 'undefined'

         && typeof document.documentElement.clientWidth != 'undefined' && document.documentElement.clientWidth != 0) {

	        viewportwidth = document.documentElement.clientWidth;

	        viewportheight = document.documentElement.clientHeight;

	    }

	    // older versions of IE

	    else {

	        viewportwidth = document.getElementsByTagName('body')[0].clientWidth;

	        viewportheight = document.getElementsByTagName('body')[0].clientHeight;

	    }

	    this.clientWidth = viewportwidth;

	    this.clientHeight = viewportheight;

	    //golden ratio

	    this.gHeight = this.clientHeight * 0.8;

	    this.gWidth = this.clientWidth * 0.8;

	    

	    this.clientWidth -= this.scrollbarwidth;

	    this.clientHeight -= this.scrollbarheight; 

	}



	this.resizePopup = function(width, height)

	{

		//set height and width

		this.getPopupContainer().style.width = width + "px" ;

		this.getPopupContainer().style.height = height + "px" ;

	

		this.getPopupShadow().style.width = width + "px" ;

		this.getPopupShadow().style.height = height + "px" ;	

	

    		this.getPopupTopic().style.width = width + "px" ;

		this.getPopupTopic().style.height = height + "px" ;

	

		this.getPopupIFrame().style.width = width + "px" ;

		this.getPopupIFrame().style.height = height + "px" ;

	}



	this.getPopupContentSize = function()

	{

		var wnd = this.getPopupIFrame().contentWindow;

		this.setHeight(getDocHeight(wnd.document));

		this.setWidth(getDocWidth(wnd.document));

	}



	this.canDoBetter = function()

	{

		if(this.width < this.gWidth /*&& this.height > this.gHeight*/)

			return true;

	}



	this.computePopupWndSize = function()

	{

		if(!gbChromeLocal)

		{

			try

			{

				this.getPopupContentSize();



			//try to check if we have available width, increasing the width may decrease the height for reflowable content

			//whenever a change is detected we save that size

			//increasing width by an amount does not always decrease height, but increasing further may decrease it based on the 

			//reflow content

			

			var  	stepSize = 50;

			var	lastWidth = 0;

			var	lastHeight = 0;

			var lastGoodHeight = this.height;

			var lastGoodWidth = this.width;



			while(this.canDoBetter())

			{

				lastWidth = this.width;

				lastHeight = this.height;

				this.resizePopup(this.width+stepSize, 1);

				this.getPopupContentSize();

				//if no change in height detected

				if(this.height < lastHeight) //may be there is no reflow content to reduce height on increasing width

				{

					lastGoodHeight = this.height;

					lastGoodWidth = this.width;

					

				}

				//alert("height = " + this.height + "width=" + this.width)

			}



			//adding extra 20 pixel in height to be sure no scroll bar comes even if content fits in size computed

			lastGoodHeight += 20;

			//adding extra 5 pixel in width

			lastGoodWidth += 5;



			this.setHeight(lastGoodHeight);

			this.setWidth(lastGoodWidth);



			this.resizeMoveAndShowPopup();

			}

			catch(e)

			{

				requestContentSize(this.getPopupIFrame().contentWindow);

			}

		}

		else

			requestContentSize(this.getPopupIFrame().contentWindow);

	}



	this.resizeMoveAndShowPopup = function()

	{

		var bNeedHScroll = false;

		var bNeedVScroll = false;



		if(this.height > this.gHeight)

		{

			this.setHeight(this.gHeight);

			//need vertical scroll bars

			bNeedVScroll = true;

			this.setWidth(this.width+this.scrollbarwidth);

		}		

		if(this.width > this.gWidth)

		{

			this.setWidth(this.gWidth);

			//need horizontal scroll bars

			bNeedHScroll = true;

			this.setHeight(this.height+this.scrollbarheight);

		}



		var nClickX = this.clickX;

		var nClickY = this.clickY;

		var nTop = 0;

		var nLeft = 0;

		var shadowpos = 5; //shadow pos relative to popup frame

	

		var scrollTop = getScrollTop();

		var scrollLeft = getScrollLeft();



		if (nClickY + this.height + shadowpos < this.clientHeight + scrollTop) {

			nTop = nClickY;

		} else {

			nTop = nClickY - this.height - shadowpos;

			if(nTop < scrollTop)

			{

				nTop = (scrollTop + this.clientHeight) - this.height - shadowpos;

				if(nTop < scrollTop)

				{

					nTop = scrollTop;

					this.height = this.clientHeight - shadowpos;

					//need vertical scroll bars

					if(bNeedVScroll == false)

					{

						bNeedVScroll = true;

						this.setWidth(this.width+this.scrollbarwidth);

					}

				}

			}

		}

		if (nClickX + this.width + shadowpos < this.clientWidth + scrollLeft) {

			nLeft = nClickX;

		} else {

			nLeft = nClickX - this.width - shadowpos;

			if(nLeft < scrollLeft)

			{

				nLeft = (scrollLeft + this.clientWidth) - this.width - shadowpos;

				if(nLeft < scrollLeft)

				{

					nLeft = scrollLeft;

					this.width = this.clientWidth - shadowpos;

					//need horizontal scroll bars

					if(bNeedHScroll == false)

					{

						bNeedHScroll = true;

						this.setHeight(this.height+this.scrollbarheight);

					}

				}

			}

		}





		//set height and width

		this.resizePopup(this.width, this.height);



		//set position

		this.getPopupContainer().style.left = nLeft + "px";

		this.getPopupContainer().style.top = nTop + "px";



		// Set the location of the background blocks

		this.getPopupShadow().style.left = shadowpos + "px";

		this.getPopupShadow().style.top = shadowpos + "px";



		if(this.strBookmark != '')

		{

			//alert(this.strBookmark);

			this.getPopupIFrame().contentWindow.location.href = this.strPopupURL + this.strBookmark;

		}



		try{

			BSSCPopup_ChangeTargettoParent(this.getPopupIFrame().contentWindow.document);

		}catch(e)

		{

			//comes here for chrome local

			requestUpdateLinks(this.getPopupIFrame().contentWindow);

		}

		this.showPopup();

		this.postWork();

	}



	this.postWork = function()

	{

		try{

			if(gbBsIsMobile == false)

			{

				if (window.addEventListener){  

					this.getPopupIFrame().contentWindow.addEventListener('click', onPopupClicked, false);  

				} else if (window.document.attachEvent){  

					this.getPopupIFrame().contentWindow.document.attachEvent('onclick', onPopupClicked);

				}

			}

		}catch(e)

		{

			//alert popup does not close on clicking on it, valid for chrome local

		}



		if(window.addEventListener)

		{

			window.addEventListener("mousedown", onPopupParentClicked, false);

			window.document.addEventListener("touchstart", onPopupParentClicked, false);

		}

		else if(window.document.attachEvent)

			window.document.attachEvent('onmousedown', onPopupParentClicked);



	}



	this.OnLoadRHPopup = function()

	{

		rhPopupEx.hidePopup();



		if(gbBsIE4 && rhPopupEx.getPopupIFrame().contentWindow.document.location.href.indexOf("about:blank") != -1)

		{

			rhPopupEx.getPopupIFrame().contentWindow.document.location.href = rhPopupEx.strPopupURL;

			return;

		}

		

		this.getClientWndSize();

		if (rhPopupEx.width == 0 || rhPopupEx.height == 0) 

		{

			rhPopupEx.computePopupWndSize();

		}

		else

			rhPopupEx.resizeMoveAndShowPopup();



	}

}



function supports_video() {

  return !!document.createElement('video').canPlayType;

}



function supports_mp4_video()

{

	if(!supports_video()) 

		return false;

	var v = document.createElement("video");

  	var playType = v.canPlayType('video/mp4');

	//alert(playType);

	if(playType == "" || playType == "no")

		return false;

	else

		return true;

}



function getUrlParam(paramName, url)

{

  if(url == null || url == 'undefined')

        url = document.location.href;

  paramName = paramName.replace(/[\[]/,"\\\[").replace(/[\]]/,"\\\]");

  var regexS = "[\\?&]"+paramName+"=([^&#]*)";

  var regex = new RegExp(regexS);

  var results = regex.exec(url);

  if( results == null )

    return "";

  else

    return results[1];

}



function send_flv_command(strMultimediaFlvName, strMultimediaFlvCommand)

{

	try

	{

		if(strMultimediaFlvName != null && typeof(strMultimediaFlvName) != undefined)

		{

			var flashMediaPlayer = document.getElementById(strMultimediaFlvName);

			if(flashMediaPlayer != null && typeof(flashMediaPlayer) != undefined)

			{

				if(strMultimediaFlvCommand != null && typeof(strMultimediaFlvCommand) != undefined)

				{

					flashMediaPlayer.TakeMultimediaAction(strMultimediaFlvCommand.replace("%20", " "));

				}

			}

		}

	}

	catch(err)

	{

		//alert(strMultimediaFlvName + ' ' + strMultimediaFlvCommand);

	}

}



function onLoad_FLV_Player(strMultimediaFlvName)

{

	if(strMultimediaFlvName != null && typeof(strMultimediaFlvName) != undefined)

	{

		var strMultimediaFlvNameHRef = getUrlParam('flv_name');

		if(strMultimediaFlvNameHRef != null && typeof(strMultimediaFlvNameHRef) != undefined)

		{

			if(strMultimediaFlvNameHRef == strMultimediaFlvName)

			{

				var strMultimediaFlvCommand = getUrlParam('flv_cmd');

				send_flv_command(strMultimediaFlvName, strMultimediaFlvCommand);

			}

		}

	}

}



function requestCpHTML5Size(targetWnd, iframeid)

{

	if(targetWnd && targetWnd.postMessage)

		targetWnd.postMessage("getCpHTML5Size" + gMsgSeparator + ",id:"+ iframeid, "*");

}



function replyCpHTML5Size(targetWnd, msgData)

{

	var obj  = parseMsgData(msgData);

	

	var pc = getProjectContainer();



	

	

	targetWnd.postMessage("setCpHTML5Size" + gMsgSeparator + ",id:" + obj.id + ",height:" + parseFloat(pc.style.height) + ",width:" + parseFloat(pc.style.width), "*");

}



function onGetReplyCpHTML5Size(targetWnd, msgData)

{

	var obj  = parseMsgData(msgData);

	var iframeelem = getElement(obj.id);

	if(typeof iframeelem != 'undefined')

	{

		iframeelem.style.width = obj.width + "px" ;

		iframeelem.style.height = obj.height + "px" ;

	}

}



function onHTML5OutputLoad(id)

{

	var iframeelem = getElement(id);

	if(typeof iframeelem != 'undefined')

	{

		var wnd = iframeelem.contentWindow;

		if(gbBsIE4)

		{

			try{

				var h = getDocHeight(wnd.document);

				var w = getDocWidth(wnd.document);



				iframeelem.style.width = w + "px" ;

				iframeelem.style.height = h + "px" ;

			}

			catch(e) {}

		}

		else

		{

			requestCpHTML5Size(wnd, id);

		}

	}

}



//End to collaborate with other event handler settings



/// Section End  - CCSSP DHTM 2 (JavaScript 1.2)



//// Segment End -- (JavaScript 1.2)
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